LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2009, 11:36 AM   #1
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
Has anyone upgraded ALSA on their own?


From my exhaustive googling it appears the best chance to get my sound card going is to upgrade to ALSA 1.0.20. I have tried this and only made a mess of things. Has anyone successfully done this? If so, what was your procedure? I guess a more hopeful question might be <fingers_crossed> will it show up in -current soon? </fingers_crossed>

I am running kernel 2.6.30.5 on Slackware64-current. I have 1.0.18 for alsa-lib and -utils and 1.0.17 for -oss. I have an Intel 82801I ICH9 HD Audio Controller with a VIA VT17085 Codec Chip. The proper kernel modules are loading but alas no sound. alsaconf has been run, no channels are muted in alsamixer. The silence is deafening and it's making me crazy. It appears that I am not the only slacker with some HD audio problems around here either.

Thanks in advance,
Eric
 
Old 08-20-2009, 11:47 AM   #2
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,612

Rep: Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414
There's a similar thread here:
http://www.linuxquestions.org/questi...ackage-747817/

I have upgraded ALSA, but it was before I learned how to use SlackBuilds. I removed ALSA support from my kernel, removed the ALSA packages from my installation, and installed the tarballs from the ALSA homepage using ./configure; make; make install. The thread I just linked to suggests a better solution.

Last edited by dugan; 08-20-2009 at 11:51 AM.
 
Old 08-20-2009, 12:44 PM   #3
Ilgar
Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware 14.1, Slackware64 14.1
Posts: 921

Rep: Reputation: 92
I also used to do it long ago, that is, installing the alsa-drivers package (my card needed the latest drivers). I didn't have any problems on my Slackware system.
 
Old 08-20-2009, 01:32 PM   #4
/dev/me
Member
 
Registered: May 2008
Distribution: Slackware 13
Posts: 116

Rep: Reputation: 20
My card wasn't included in the ALSA most distros shipped with when I bought my laptop, so I did it a couple of times. But it's been a while.


I think the biggest problem of upgrading ALSA is deciding which packages to build. There's 8 packages on the ALSA download page. I got away with only building alsa-driver and alsa-lib. YMMV
 
Old 08-20-2009, 03:35 PM   #5
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Original Poster
Rep: Reputation: 40
digging deeper into the thread that dugan posted, led me to a link where they explained how to merge the newest ALSA into the Kernel source and rebuild. I went that way and rebuilt my Kernel with the new files, but still no sound. I'll keep digging.
 
Old 08-20-2009, 04:39 PM   #6
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Original Poster
Rep: Reputation: 40
I finally have sound!! After adding the 1.0.20 driver I had to download and run ALSA's HDA Analyzer where I checked EAPD on Node [0x1c] PIN. MOre information can be found here. Apparently this bug is still yet to be fixed in a release.
 
Old 08-20-2009, 08:30 PM   #7
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Original Poster
Rep: Reputation: 40
Just to add a little more documentation:

/etc/modprobe.d/sound
Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=auto
options snd-hda-intel enable_msi=1
/etc/rc.d/rc.local
Code:
echo "Enabling EAPD for sound"
hda-verb /dev/snd/hwC0D0 0x1c SET_EAPD_BTLENABLE PCM
 
  


Reply

Tags
alsa, audio, hd, intel, via


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Slackware 9 12-04-2008 07:29 AM
kernel-2.6.3 compiled with alsa but xmms alsa output dont plays demmylls Linux - General 3 09-01-2006 04:32 AM
Those who upgraded and have no sound (ALSA) gbonvehi Slackware 8 03-31-2005 10:02 AM
Upgraded to 2.6.10: ALSA crashes kernel intens Linux - Hardware 0 01-02-2005 07:24 AM


All times are GMT -5. The time now is 09:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration