LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-20-2012, 05:05 AM   #1
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 39

Rep: Reputation: 6
Has anyone transcode working on Slackware 14?


Dear Slackers,

Has anyone of you transcode working? It is needed for ripping DVD's either using dvdrip or in k3b?

I get an error like this in k3b:
Code:
[export_ffmpeg.so] Using FFMPEG codec 'mpeg4' (FourCC 'DIVX', MPEG4 compliant video).
[export_ffmpeg.so] No profile selected
[export_ffmpeg.so] Error opening configuration file ./ffmpeg.cfg: No such file or directory
[export_ffmpeg.so] Starting 1 thread(s)
/usr/bin/transcode: symbol lookup error: /usr/lib64/transcode/export_ffmpeg.so: undefined symbol: avcodec_thread_init
Any pointers much appreciated

Marcel

By the way running Slackware 14 64bit multilib

Last edited by emgee_1; 11-20-2012 at 05:07 AM. Reason: forgot about my config
 
Old 11-20-2012, 09:07 AM   #2
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 245

Rep: Reputation: 26
Did you do ffmpeg from slackbuilds?

I also did k9copy and handbrake from slackbuilds.
 
Old 11-20-2012, 09:42 AM   #3
emgee_1
Member
 
Registered: Aug 2009
Location: Nijmegen, The Netherlands
Distribution: Slackware 14
Posts: 39

Original Poster
Rep: Reputation: 6
@glorsplitz: Yes I did; I also tried an ffmpeg package from AlienBob;
And also a transcode package from ponce be it that the latter is actually a Slackware 64 current package; to no avail;

I spotted on a ArchLinux forum the same kind of problem with transcode;

So I am interested in anybody getting k3b ripping dvd's using transcode or dvdrip using transcode

As usual any pointers are greatly welcomed.

Marcel
 
Old 11-20-2012, 10:45 AM   #4
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-C ML
Posts: 883

Rep: Reputation: 78
I have it working on Slack64-14.0 multilib.
I ran off the deps with sbopkg and did transcode manually as "su -"

My transcode.sqf

##transcode
a52dec
libmp4v2
faac
libdv
libmpeg2
mjpegtools
x264
orc
schroedinger
lame
## ffmpeg used AlienBobs 0.11.2
faad2
libquicktime
x264
xvidcore

### EDIT SLACKBUILD
### Right between the lines:
### CXXFLAGS="$SLKCFLAGS" \
### and
### ./configure \
### add the following line (do not leave empty lines around it!):
### LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \


### Build transcode manually as su - edit options

Last edited by slackass; 11-20-2012 at 11:08 AM.
 
Old 11-20-2012, 10:52 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,428

Rep: Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867
Quote:
Originally Posted by emgee_1 View Post
And also a transcode package from ponce be it that the latter is actually a Slackware 64 current package; to no avail
if you want to try the prebuilt packages I'm using on my installs, do it with the ones that you find here (install also all the dependencies needed from there, I don't guarantee any mixing with other packages sources )

http://ponce.cc/slackware/slackware64-14.0/packages/

Last edited by ponce; 11-20-2012 at 11:40 AM.
 
Old 11-20-2012, 01:50 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0/14.1
Posts: 3,482

Rep: Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533Reputation: 533
Patches to build transcode in Slackware 14.0 64-bit:

ffmpeg 0.10:

https://bugs.gentoo.org/401287?id=401287

ffmpeg 0.11:

https://bugs.gentoo.org/show_bug.cgi?id=419551
 
Old 11-20-2012, 01:54 PM   #7
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,428

Rep: Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867Reputation: 867
the one for ffmpeg-0.11.x is already with the build script on slackbuilds.org (courtesy of Heinz Wiesinger), that's the one I used to build my package.
 
Old 12-09-2012, 11:32 AM   #8
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
Has anyone gotten this working with the ffmpeg from slackbuilds.org? It looks as if it has only been successful with AlienBOB's ffmpeg. If I upgrade to Alien's ffmpeg, do I also need to remove any of the deps that I installed to build ffmpeg from slackbuilds?

As a side note, this is also a problem in other distros. I get the exact error when ripping DVD's in Mageia (cauldron) so the issue is definatley with transcode and ffmpeg. It also seems that the patch will allow you to compile transcode but it does not alleviate the error when using it with ffmpeg. I don't see the patch, or any patch, used in Alien's ffmpeg so maybe it is not needed at all with the newer version.
 
Old 12-10-2012, 02:48 AM   #9
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 425

Rep: Reputation: 123Reputation: 123
Just use HandBrake. Especially the version supplied by AlienBob. You're probably just wasting your time with anything else.
 
1 members found this post helpful.
Old 12-10-2012, 01:19 PM   #10
VolvoxNo9
LQ Newbie
 
Registered: Dec 2010
Posts: 6

Rep: Reputation: 0
I get the same error in k3b and I use the 32bit version of Slackware 14.0.

I've built and installed all packages from the list above (using sbopkg) after I did run "su -", but it didn't help.
 
Old 12-11-2012, 09:26 AM   #11
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
So I decided to not be lazy for a bit and downloaded the gentoo patch in post #6. I had to add the filter_pp.c section from the original patch (from the slackbuild) and it not only compiled but it works. What I don't understand is why I needed that extra patching and others didn't. Is it possible that different hardware could cause this?

Anyway, if anyone is having the same trouble I had, get the gentoo patch for ffmpeg 0.11 above and copy the bit that starts "diff -Naur transcode..." down to the next diff line from the original patch into the gentoo patch, rename the gentoo patch (or edit slackbuild to include it and not the original) and run the slackbuild. If you have a multilib system, be sure to edit the slackbuild to add the LDFLAGS line from post #4.

Hope that helps

Oh, BTW this is build against ffmpeg from slackbuilds.org . You can test transcode with the following:
Code:
transcode -y ffmpeg -F mpeg4 -i <some video file to be transcoded>

Last edited by ryerke; 12-11-2012 at 09:50 AM. Reason: Added content
 
Old 12-12-2012, 02:33 PM   #12
CMartin
LQ Newbie
 
Registered: Sep 2010
Distribution: Slackware
Posts: 25

Rep: Reputation: Disabled
Quote:
Originally Posted by ryerke View Post
So I decided to not be lazy for a bit and downloaded the gentoo patch in post #6. I had to add the filter_pp.c section from the original patch (from the slackbuild) and it not only compiled but it works. What I don't understand is why I needed that extra patching and others didn't. Is it possible that different hardware could cause this?

Anyway, if anyone is having the same trouble I had, get the gentoo patch for ffmpeg 0.11 above and copy the bit that starts "diff -Naur transcode..." down to the next diff line from the original patch into the gentoo patch, rename the gentoo patch (or edit slackbuild to include it and not the original) and run the slackbuild. If you have a multilib system, be sure to edit the slackbuild to add the LDFLAGS line from post #4.

Hope that helps

Oh, BTW this is build against ffmpeg from slackbuilds.org . You can test transcode with the following:
Code:
transcode -y ffmpeg -F mpeg4 -i <some video file to be transcoded>

I did exactly what you described here with this patch from Gentoo and filters.pp code from the original patch, but there is an error: *** glibc detected *** transcode: munmap_chunk(): invalid pointer: 0x00007f793bc80be2 ***

======= Backtrace: =========
/lib64/libc.so.6(+0x7d4d6)[0x7f794eb934d6]
/usr/lib64/transcode/export_ffmpeg.so(+0x640c)[0x7f793bc7b40c]
/usr/lib64/transcode/export_ffmpeg.so(+0x8a21)[0x7f793bc7da21]
/usr/lib64/transcode/export_ffmpeg.so(tc_export+0x403)[0x7f793bc7e8f3]
transcode(tcv_export+0x43)[0x414053]
transcode(tc_encoder_init+0xc6)[0x414f66]
transcode(main+0x26a2)[0x40b1b2]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x7f794eb37a95]
transcode[0x40dbf1]
======= Memory map: ========

The 'Memory map' is a long list of libs with the final message 'Aborted', uploaded at http://pastebin.ca/2291968

Couple of years ago I used precompiled transcode in Debian (original Debian, not a derivative) to split an .avi file into video .m2v and audio .ac3 in order to put them back together into the .mpg which will be used for DVD authoring. There were no any problems.

I'd like to do the same again with an option "--export_asr 2" for 4:3 as I used to back then, but the original transcode from slackbuilds with only Wiesinger's patch didn't work, and now it doesn't work just in a different way. The same for .mp4 files in your suggested line above.

GUI applications I found not to be really up to the task; I found no way for export_asr 2 in HandBrake for .mpg, and Bombono-dvd totally lacks the option for setting a full screen.

Oh, yes, I did compile transcode against all suggested libs on Slackbuilds's transcode page. All dependencies taken from Slackbuilds and compiled successfully. Please suggest something. Thank you.

Last edited by CMartin; 12-12-2012 at 02:36 PM.
 
Old 12-14-2012, 09:42 AM   #13
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
Quote:
Originally Posted by CMartin View Post
I did exactly what you described here with this patch from Gentoo and filters.pp code from the original patch, but there is an error: *** glibc detected *** transcode: munmap_chunk(): invalid pointer: 0x00007f793bc80be2 ***
I didn't notice this until now since I was using k3b to rip and it did not show errors. I tried to use transcode in the terminal and I got similar errors but instead of munmap_chunk(); I get free(); and naturally the address is different. The file that I am working with does get transcoded and then the error shows up at the end so it isn't devestating in my case. I don't know too much about what goes on under the hood so I hope there is someone here that can help us figure out what is happening here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
which version of mplayer and transcode works for ripping dvds in slackware 11 hoodooman Slackware 18 07-15-2007 08:46 PM
tv-recording whith transcode and init whith v4lctl is not working with cron Goofy180173 Linux - Software 1 10-13-2006 12:54 PM
Transcode and ffmpeg not working together Aioth Linux - Software 3 02-26-2005 05:16 AM
wine and winesetuptk working well with slackware 9.0 and slackware 9.1 oobe Linux - Software 0 10-19-2003 12:29 PM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration