LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Has anyone transcode working on Slackware 14? (http://www.linuxquestions.org/questions/slackware-14/has-anyone-transcode-working-on-slackware-14-a-4175437930/)

emgee_1 11-20-2012 05:05 AM

Has anyone transcode working on Slackware 14?
 
Dear Slackers,

Has anyone of you transcode working? It is needed for ripping DVD's either using dvdrip or in k3b?

I get an error like this in k3b:
Code:

[export_ffmpeg.so] Using FFMPEG codec 'mpeg4' (FourCC 'DIVX', MPEG4 compliant video).
[export_ffmpeg.so] No profile selected
[export_ffmpeg.so] Error opening configuration file ./ffmpeg.cfg: No such file or directory
[export_ffmpeg.so] Starting 1 thread(s)
/usr/bin/transcode: symbol lookup error: /usr/lib64/transcode/export_ffmpeg.so: undefined symbol: avcodec_thread_init

Any pointers much appreciated

Marcel

By the way running Slackware 14 64bit multilib

glorsplitz 11-20-2012 09:07 AM

Did you do ffmpeg from slackbuilds?

I also did k9copy and handbrake from slackbuilds.

emgee_1 11-20-2012 09:42 AM

@glorsplitz: Yes I did; I also tried an ffmpeg package from AlienBob;
And also a transcode package from ponce be it that the latter is actually a Slackware 64 current package; to no avail;

I spotted on a ArchLinux forum the same kind of problem with transcode;

So I am interested in anybody getting k3b ripping dvd's using transcode or dvdrip using transcode

As usual any pointers are greatly welcomed.

Marcel

slackass 11-20-2012 10:45 AM

I have it working on Slack64-14.0 multilib.
I ran off the deps with sbopkg and did transcode manually as "su -"

My transcode.sqf

##transcode
a52dec
libmp4v2
faac
libdv
libmpeg2
mjpegtools
x264
orc
schroedinger
lame
## ffmpeg used AlienBobs 0.11.2
faad2
libquicktime
x264
xvidcore

### EDIT SLACKBUILD
### Right between the lines:
### CXXFLAGS="$SLKCFLAGS" \
### and
### ./configure \
### add the following line (do not leave empty lines around it!):
### LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \


### Build transcode manually as su - edit options

ponce 11-20-2012 10:52 AM

Quote:

Originally Posted by emgee_1 (Post 4833327)
And also a transcode package from ponce be it that the latter is actually a Slackware 64 current package; to no avail

if you want to try the prebuilt packages I'm using on my installs, do it with the ones that you find here (install also all the dependencies needed from there, I don't guarantee any mixing with other packages sources ;) )

http://ponce.cc/slackware/slackware64-14.0/packages/

Woodsman 11-20-2012 01:50 PM

Patches to build transcode in Slackware 14.0 64-bit:

ffmpeg 0.10:

https://bugs.gentoo.org/401287?id=401287

ffmpeg 0.11:

https://bugs.gentoo.org/show_bug.cgi?id=419551

ponce 11-20-2012 01:54 PM

the one for ffmpeg-0.11.x is already with the build script on slackbuilds.org (courtesy of Heinz Wiesinger), that's the one I used to build my package. :)

ryerke 12-09-2012 11:32 AM

Has anyone gotten this working with the ffmpeg from slackbuilds.org? It looks as if it has only been successful with AlienBOB's ffmpeg. If I upgrade to Alien's ffmpeg, do I also need to remove any of the deps that I installed to build ffmpeg from slackbuilds?

As a side note, this is also a problem in other distros. I get the exact error when ripping DVD's in Mageia (cauldron) so the issue is definatley with transcode and ffmpeg. It also seems that the patch will allow you to compile transcode but it does not alleviate the error when using it with ffmpeg. I don't see the patch, or any patch, used in Alien's ffmpeg so maybe it is not needed at all with the newer version.

Mark Pettit 12-10-2012 02:48 AM

Just use HandBrake. Especially the version supplied by AlienBob. You're probably just wasting your time with anything else.

VolvoxNo9 12-10-2012 01:19 PM

I get the same error in k3b and I use the 32bit version of Slackware 14.0.

I've built and installed all packages from the list above (using sbopkg) after I did run "su -", but it didn't help.

ryerke 12-11-2012 09:26 AM

So I decided to not be lazy for a bit and downloaded the gentoo patch in post #6. I had to add the filter_pp.c section from the original patch (from the slackbuild) and it not only compiled but it works. What I don't understand is why I needed that extra patching and others didn't. Is it possible that different hardware could cause this?

Anyway, if anyone is having the same trouble I had, get the gentoo patch for ffmpeg 0.11 above and copy the bit that starts "diff -Naur transcode..." down to the next diff line from the original patch into the gentoo patch, rename the gentoo patch (or edit slackbuild to include it and not the original) and run the slackbuild. If you have a multilib system, be sure to edit the slackbuild to add the LDFLAGS line from post #4.

Hope that helps :)

Oh, BTW this is build against ffmpeg from slackbuilds.org . You can test transcode with the following:
Code:

transcode -y ffmpeg -F mpeg4 -i <some video file to be transcoded>

CMartin 12-12-2012 02:33 PM

Quote:

Originally Posted by ryerke (Post 4847039)
So I decided to not be lazy for a bit and downloaded the gentoo patch in post #6. I had to add the filter_pp.c section from the original patch (from the slackbuild) and it not only compiled but it works. What I don't understand is why I needed that extra patching and others didn't. Is it possible that different hardware could cause this?

Anyway, if anyone is having the same trouble I had, get the gentoo patch for ffmpeg 0.11 above and copy the bit that starts "diff -Naur transcode..." down to the next diff line from the original patch into the gentoo patch, rename the gentoo patch (or edit slackbuild to include it and not the original) and run the slackbuild. If you have a multilib system, be sure to edit the slackbuild to add the LDFLAGS line from post #4.

Hope that helps :)

Oh, BTW this is build against ffmpeg from slackbuilds.org . You can test transcode with the following:
Code:

transcode -y ffmpeg -F mpeg4 -i <some video file to be transcoded>


I did exactly what you described here with this patch from Gentoo and filters.pp code from the original patch, but there is an error: *** glibc detected *** transcode: munmap_chunk(): invalid pointer: 0x00007f793bc80be2 ***

======= Backtrace: =========
/lib64/libc.so.6(+0x7d4d6)[0x7f794eb934d6]
/usr/lib64/transcode/export_ffmpeg.so(+0x640c)[0x7f793bc7b40c]
/usr/lib64/transcode/export_ffmpeg.so(+0x8a21)[0x7f793bc7da21]
/usr/lib64/transcode/export_ffmpeg.so(tc_export+0x403)[0x7f793bc7e8f3]
transcode(tcv_export+0x43)[0x414053]
transcode(tc_encoder_init+0xc6)[0x414f66]
transcode(main+0x26a2)[0x40b1b2]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x7f794eb37a95]
transcode[0x40dbf1]
======= Memory map: ========

The 'Memory map' is a long list of libs with the final message 'Aborted', uploaded at http://pastebin.ca/2291968

Couple of years ago I used precompiled transcode in Debian (original Debian, not a derivative) to split an .avi file into video .m2v and audio .ac3 in order to put them back together into the .mpg which will be used for DVD authoring. There were no any problems.

I'd like to do the same again with an option "--export_asr 2" for 4:3 as I used to back then, but the original transcode from slackbuilds with only Wiesinger's patch didn't work, and now it doesn't work just in a different way. The same for .mp4 files in your suggested line above.

GUI applications I found not to be really up to the task; I found no way for export_asr 2 in HandBrake for .mpg, and Bombono-dvd totally lacks the option for setting a full screen.

Oh, yes, I did compile transcode against all suggested libs on Slackbuilds's transcode page. All dependencies taken from Slackbuilds and compiled successfully. Please suggest something. Thank you.

ryerke 12-14-2012 09:42 AM

Quote:

Originally Posted by CMartin (Post 4847986)
I did exactly what you described here with this patch from Gentoo and filters.pp code from the original patch, but there is an error: *** glibc detected *** transcode: munmap_chunk(): invalid pointer: 0x00007f793bc80be2 ***

I didn't notice this until now since I was using k3b to rip and it did not show errors. I tried to use transcode in the terminal and I got similar errors but instead of munmap_chunk(); I get free(); and naturally the address is different. The file that I am working with does get transcoded and then the error shows up at the end so it isn't devestating in my case. I don't know too much about what goes on under the hood so I hope there is someone here that can help us figure out what is happening here.


All times are GMT -5. The time now is 01:29 AM.