LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Has anyone succeeded in running xorg WITHOUT hal? (http://www.linuxquestions.org/questions/slackware-14/has-anyone-succeeded-in-running-xorg-without-hal-800716/)

harryhaller 04-07-2010 10:56 PM

Has anyone succeeded in running xorg WITHOUT hal?
 
My old xorg.conf (copied over from 12.1) leaves X without a keyboard or a mouse so that I have to switch the machine off and on again.

I need to run X without hal because I need to be specific about my keyboard as I have modified it.

Hal generates weird devices - 2 keyboards, one AT and the other called "Power Button" (??). I also find it difficult to get good documentation on hal. The man pages aren't helpful.

"X -configure" created an xorg.conf similar to my own - which didn't work.

I really would like to hear from someone who has succeeded in running xorg without hal.

Until then, I'm sticking with 12.1.

GrapefruiTgirl 04-07-2010 11:23 PM

There are some threads around here about Xorg and HAL (or not-HAL) and I believe at least one of them outlines building X for Slackware without HAL. Right off, I cannot recall the details. Search around a bit and see what you find.

Meanwhile, if you just want to toss HAL out of your devices situation, consider the following for your xorg.conf's "ServerFlags" section:

Code:

Section "ServerFlags"
# try one or the other: Xinerama or randr
# as software + drivers improve
    Option        "Xinerama" "True"
#  Next 3 lines: disable HAL input hotplugging:
    Option        "AutoAddDevices" "False"
    Option        "AutoEnableDevices" "False"
    Option        "AllowEmptyInput" "False"

#  Which of the next 2 lines is right? Either of them?
#  Option        "RandR" "True"
#    Option        "RandRRotation" "True"
EndSection

Those 3 bold lines may well solve your problem, at least for now..

Sasha

UPDATE -- coincidentally, I just came across this thread you might like:
http://www.linuxquestions.org/questi...5/#post3921681

harryhaller 04-08-2010 10:43 AM

Thanks, Sasha!

That plus xorgsetup did the trick:)

Hal and dbus have now been deactivated - and my keyboard reconfiguration is working.

Didier Spaier 04-08-2010 10:50 AM

There is more than one way to skin a cat.

You could have recompiled xorg-server adding --disable-config-hal to the configure options of the SlackBuild.


All times are GMT -5. The time now is 08:14 PM.