LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-30-2011, 10:00 AM   #1
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Rep: Reputation: Disabled
Has anyone installed Wifi without rc.hald and message bus?


I have my old PC (256mb memory) attached to my wifi router via wire. So it is connected via eth0. I don't run hal or messagebus (nor wireless nor wicd, of course).

In order to have less wiring and more freedom where I put my cable modem etc., I bought a usb wireless adapter for my old pc, turned on hal, messagebus, wireless and wicd - and it worked. However the performance loss was huge. Hal seems to be the culprit since it is busy monitoring all devices. This is, of course, just an assumption.

I have returned my configuration back to the wire connection, but I was wondering whether anyone had installed wifi without hal and messagebus. In other words I want to know whether this is possible and how to do it.

btw - wicd-curses is great!
 
Old 01-30-2011, 11:22 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
I used Slackware-Current and KDE 4.6 from AlienBOB's KTown repository and since it can work without HAL, i have disabled HAL and so far, i have no problem with it. Everything still works just like before.

If you are still using 13.1, then you still need HAL and messagebus at least until Slackware 13.2. The next next (probably 14) should be the first HAL-free Slackware release
 
Old 01-30-2011, 12:15 PM   #3
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Original Poster
Rep: Reputation: Disabled
I have Slackware-current on my netbook, but I don't use it. Yet wifi works fine.

When you say:
Quote:
I used Slackware-Current and KDE 4.6 from AlienBOB's KTown repository and since it can work without HAL
by "it" do you mean KDE?

In anycase, I'll see if my netbook can run wifi without hal and messagebus. It uses them at the moment, because memory isn't a problem (1Gb) and the processor is faster.

Thanks for the info.
 
Old 01-30-2011, 06:20 PM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
Yes, it means KDE
 
Old 02-21-2011, 06:53 AM   #5
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Original Poster
Rep: Reputation: Disabled
Wicd works well without hald but needs messagebus.
 
Old 02-21-2011, 07:55 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,384

Rep: Reputation: Disabled
You can configure your wireless card in /etc/rc.inet1.conf too. Does not require HAL or messagebus at all. Messagebus (UDEV) is only required if you want your software to be able to automatically detect a switch between wired and wireless.

Eric
 
1 members found this post helpful.
Old 02-21-2011, 12:14 PM   #7
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Original Poster
Rep: Reputation: Disabled
Thanks Eric.

I've been reading your documentation - probably not very well since I was playing around with this last night until I couldn't keep my eyes open

But I think I was starting of too complicated - so now I am keeping it simple.
I'm not going to try to connect to my own network, which is encrypted, but am going to try to connect to a nearby network which is quite strong, not encrypted and never seems to get turned off. Thus I can save the complications of essid's and passwords.

In inet1.conf I have tried to let it default as much as possible thus I have the following entries:
Code:
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]=""
DHCP_HOSTNAME=""
n.b. none of these infos are copied and pasted since the infos are on a different machine, so if there are typos, they are probably just here and not in the original configuration.

The preceding ethernet clauses, etho-eth3, have all their values set to "".

I ran "ifconfig wlan0":
Quote:
Link encap:Ethernet HWaddr 4c:0f:6e:01:6a:75
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
In wireless.conf, I commented out the catch all clause at the beginning and then added a new clause immediately afterwards
Code:
4C:0F:6E:01:6A:75)
  INFO="Atheros AR9285 Wireless Network Adapter"
  ESSID="any"
  NWID=""
  MODE="Managed"
  FREQ=""
  CHANNEL="7"
  SENS=""
  RATE=auto"
  RTS=""
  FRAG=""
  IWCONFIG=""
  IWSPY=""
  IWPRIV=""
;;
I have not changed anything else.

In rc.d I have hal, messagebus and wicd disabled, but wireless is executable.

At the end of the boot, I see the message:
Quote:
/etc/rc.d/rc.M: wlan0 information: 'Atheros AR9825 Wireless Network Adapter'
Error for wireless request "Set Nickname (8B1C) :
SET failed on device wlan0 ; Operation not supported
I have no wifi connection as far as I can see - the red signal light is off.

This is being run on an Acer Aspire One D255.

The network controller, from lspci, is an Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01).

In the /var/log files I see in the "messages" file with the id "logger"
Quote:
/etc/rc.d/rc.inet1: /sbin/ifconfig lo 127.0.0.1
/etc/rc.d/rc.inet1: /sbin/route add -net 127.0.0.1 netmask 255.0.0.0 lo
/etc/rc.d/rc.M: /sbin/iwconfig wlan0 mode Managed
/etc/rc.d/rc.M: /sbin/iwconfig wlan0 nick slackwear
/etc/rc.d/rc.M: /sbin/iwconfig wlan0 channel 7
/etc/rc.d/rc.M: /sbin/iwconfig wlan0 rate auto
/etc/rc.d/rc.M: /sbin/iwconfig wlan0 essid "any"
/etc/rc.d/rc.M: /sbin/iwconfig wlan0 esid "any"
otherwise I can't see anything remarkable in the log files - no relevant complaints, warnings etc.

I have a feeling I'm missing something very obvious here - e.g. where does wpa-supplicant enter the picture - in the wicd scenario it wasn't needed.
 
Old 02-21-2011, 12:29 PM   #8
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,500

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
if can help, I set this relevant options in /etc/rc.d/rc.inet1.conf: the ip data too - I don't use dhcp - and some additional info for the wlan, following the commented example in the same file
Code:
GATEWAY="192.168.1.1"
...
IFNAME[4]="wlan0"
IPADDR[4]="192.168.1.8"
NETMASK[4]="255.255.255.0"
WLAN_ESSID[4]=MYESSID
WLAN_WPA[4]="wpa_supplicant"
then I have this in my /etc/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
eapol_version=2
ap_scan=1
network={
  scan_ssid=1
  ssid="MYESSID"
  proto=WPA2
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="mysupersecretpsk"
}

Last edited by ponce; 02-21-2011 at 12:32 PM.
 
1 members found this post helpful.
Old 02-21-2011, 01:04 PM   #9
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Original Poster
Rep: Reputation: Disabled
Smile I'm connected !!!

Thanks for the pointer, ponce - I'm connected!

I added my essid and key to wpa_supplcant.conf - I was reluctant to do so because I thought it would stop me being able to roam. Before that I had tried wpa_supplicant and it refused it because of the dummy entries.

Now wpa_supplicant is running - connected to the neighbouring wifi - so my fears were in vain. Now I just have to learn to use wpa_cli so that I can choose and switch which wifi lan I want to connect to.

Many thanks again.

I'm now in a hal/messagebus free zone - long live manual configurations! (excuse my joy )

Last edited by harryhaller; 02-21-2011 at 01:07 PM.
 
Old 02-21-2011, 03:13 PM   #10
harryhaller
Member
 
Registered: Sep 2004
Distribution: Slackware-14.0
Posts: 452

Original Poster
Rep: Reputation: Disabled
I was premature.

The interface is up. It says that it is connected to an ssid, it then breaks the connection and is bringing messages about try to associate with an ssid.

I have not been able to ping or get a browser to connect successfully.

So, though it says it is connected - I am not connected to the internet.

It is very difficult to read the messages from wpa_supplicant in debug mode and also wpa_cli.
They come very fast.
I have to find some way of logging them, before I can make sense of this.
 
  


Reply

Tags
i hal, messagebus, wicd, wif, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting system message bus :dbus --ldap client hangs at this stage sarajevo Linux - Server 1 02-05-2010 02:03 PM
Fedora system stuck at system message bus service upon bootup guy_ripper Linux - Software 4 02-16-2009 02:54 PM
Can't open system message bus connection... PhilTR Linux - Security 13 08-19-2007 09:40 AM
FC5 ---message bus -initialization --x server not starting narendra.pant Fedora 4 09-19-2006 06:47 AM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration