LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
 
Search this Thread
Old 10-30-2012, 12:39 AM   #1
bimboleum
Member
 
Registered: Oct 2009
Posts: 57

Rep: Reputation: 11
Has anyone got Bluetooth headset to work under Slackware 14


Hey,
I am trying to get my bluetooth (Motorola H375) headset to work under Slackware 14 (64 bit) on my thinkpad w530.

I run xfce and the bluetooth device manager that comes with xfce.

I can pair the headset with the adapter.
hcitool ouput shows:-

Code:
root=>hcitool con
Connections:
	> ACL 00:0B:2E:57:C9:EC handle 12 state 1 lm MASTER AUTH ENCRYPT
aplay -L shows

Code:
root=>aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
btheadset
    BT Headset
default:CARD=PCH
    HDA Intel PCH, ALC269VC Analog
    Default Audio Device
sysdefault:CARD=PCH
    HDA Intel PCH, ALC269VC Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    Front speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC269VC Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
and my /etc/asound.conf is:-
Code:
pcm.btheadset {
    type plug
    slave {
        pcm {
            type bluetooth
            device 00:0B:2E:57:C9:EC
            profile "auto"
        }
    }

    hint {
        show on
        description "BT Headset"
    }
}

ctl.btheadset {
  type bluetooth
}
If I try to play a tune e.g

aplay -D btheadset <some random mp3 file>

all I get is a high-pitched hum through the headset.

if I try to switch the headset to slave role using hcitool I get:-

Code:
root=>hcitool sr 00:0B:2E:57:C9:EC s
Switch role request failed: Input/output error
So can anyone give me a hint as to what is wrong .. I am obviously part way there in that I can successfuly connect to my headset but I cannot work out what else needs to happen to get a successful connection.

I must add that this headset used to work fine under 13.37 (32 bit) on my old t61.

It exhibits the same (broken) behaviour under Slackware 14 (64 bit)on the t61.

cheers
pete

pete hilton
saruman@ruvolo-hilton.org
 
Old 10-30-2012, 03:59 AM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 147Reputation: 147
My "/etc/asound.conf" is
Code:
@hooks [
        {
                func load
                files [
                        "/etc/alsa/bluetooth.conf"
                ]
                errors false
        }
]
 
Old 10-30-2012, 04:40 AM   #3
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware64
Posts: 101

Rep: Reputation: 61
Quote:
If I try to play a tune e.g

aplay -D btheadset <some random mp3 file>

all I get is a high-pitched hum through the headset.
aplay on my system (slackware 12.2.0) does not play mp3
try with some .wav file

Last edited by ml4711; 10-30-2012 at 04:45 AM.
 
Old 11-04-2012, 01:44 AM   #4
thegato
Member
 
Registered: Nov 2006
Posts: 42

Rep: Reputation: 4
Does anyone have any more in depth info on this?

Did you have to do anything else to get it to work?

I'm getting the same trouble with only a horrid noise coming out of my headset. Using both methods listed above.

EDIT:

I believe I've found the issue. The headset is meant for voice only so it can only send/recieve at 8000 Hz. Anything higher results in that awful noise spewing through the headset. Try this:

For reference all I needed to do was add the commented section from /etc/alsa/bluetooth.conf into /etc/asound.conf , I did not need to edit bluetooth.conf
I use blueman-manager to pair and connect to my headset.

Make sure Enable=Socket is set in /etc/bluetooth/audio.conf

in a console do

arecord -D bluetooth test.wav and sing into the headset mic. It should default to 8000Hz but you can set -r 8000 if you want.

aplay -D bluetooth test.wav and you should hear your wonderful singing.

I hope that solves it for you, however disappointing. To get better quality audio you'd need a non-phone headset.

Last edited by thegato; 11-06-2012 at 11:56 PM.
 
Old 01-27-2015, 12:31 PM   #5
caiquo
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
I am using slackware-current. I am sure it will work for slackware 14.1 as well

First of all this is how my asound.conf looks like

pcm.!default {
type bluetooth
device "00:1E:7C:23:BA:49"
}

Then I use /usr/bin/blueman-manager

I hope this help. Bluetooth becomes the default sound for your whole system. With the above set up, you can hear sound online as well
with any browser.
 
Old 01-27-2015, 10:19 PM   #6
caiquo
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
I am using Slackware-current. I am sure it will work for Slackware 14.1 as well

First of all this is how my asound.conf looks like in /etc/asound.conf

Code:
pcm.!default {
type bluetooth
device "00:1E:7C:23:BA:49"
}
Code:

As a user, I have created .asoundrc in my /home/user that looks like this:

code:

pcm.btheadset {
type plug
slave {
pcm {
type bluetooth
device "00:1E:7C:23:BA:49"
profile "auto"
}
}

hint {
show on
description "BT Headset"
}
}

ctl.btheadset {
type bluetooth
}

code:

I did restart the computer for the settings to configure properly.

Then I use /usr/bin/blueman-manager as a user to find my bluetooth headset after I have set my bluetooth headset in discovery mode

The /usr/bin/blueman-manager helps you discover the right device input. In my case my headset was identified as device "00:1E:7C:23:BA:49"

Note that bluetooth becomes the default sound for your whole system due to /etc/asound.conf With the above set up, you can hear sound online as well with any browser or when using your favourite media to play videos or songs.

I hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bluetooth headset problems ninja master Linux - Hardware 2 10-03-2012 06:43 PM
Bluetooth headset, Alsa - no soundcard in /proc/asound/cards (but headset works) simopal6 Linux - Hardware 1 04-29-2009 09:07 AM
Bluetooth Headset wdowning Linux - Hardware 1 02-23-2009 11:30 AM
Bluetooth headset as DVD? minchina Linux - Hardware 1 09-29-2006 11:33 AM
Bluetooth headset patthew Linux - Hardware 1 06-14-2005 07:17 AM


All times are GMT -5. The time now is 07:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration