LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-30-2009, 02:46 PM   #1
Cotobear
Member
 
Registered: Nov 2007
Location: Canada
Distribution: Slackware 12.0
Posts: 100

Rep: Reputation: 16
HAL, Xorg, and Fluxbox on Slackware 13.0


Hey everyone,

So has anyone tried loading up Fluxbox on there shiny new 13.0 installation? My first thought was:

Will HAL and Xorg still work together to configure X without an xorg.conf file?

It seems that the short answer (in my case anyway) is no. In fact, it seems Fluxbox fails completely if no xorg.conf file is detected. I have yet to experiment with creating an xorg.conf file that properly works with both Fluxbox and KDE.

Has anyone done much with this yet?

Coto
 
Old 08-30-2009, 02:52 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Well, fluxbox works fine for me with no xorg.conf. But, after I installed the nvidia drivers I needed to make an xorg.conf ... and fluxbox still works fine. Does it post any errors ?
 
Old 08-30-2009, 03:05 PM   #3
Cotobear
Member
 
Registered: Nov 2007
Location: Canada
Distribution: Slackware 12.0
Posts: 100

Original Poster
Rep: Reputation: 16
Got it to work.

Since I was just checking to see it did work, I just ran "startfluxbox" instead of changing the windows manager through xwmconfig and then running startx.

If I remember correctly though, this was never a problem. I guess with this new system, it's what you have to do.
 
Old 08-30-2009, 03:28 PM   #4
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
If you don't change the window manager, even if typing startfluxbox aren't you still using kdm?
 
Old 08-30-2009, 04:14 PM   #5
Cotobear
Member
 
Registered: Nov 2007
Location: Canada
Distribution: Slackware 12.0
Posts: 100

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by forum1793 View Post
If you don't change the window manager, even if typing startfluxbox aren't you still using kdm?
I prefer to start from the console , so no kdm. Interesting point though. I wonder how kdm starts a windows manager and if you might get a problem from doing it this way.
 
Old 08-30-2009, 05:02 PM   #6
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Posts: 652

Rep: Reputation: 141Reputation: 141
I used xwmconfig to change to fluxbox and she fired right up with startx. I like starting from console too.
 
Old 08-30-2009, 06:25 PM   #7
linuxpokernut
Member
 
Registered: Jul 2007
Distribution: Slackware 14
Posts: 237
Blog Entries: 8

Rep: Reputation: 59
This is interesting, I was thinking about running fluxbox and KDE in 13.1 when I load it up. I play a lot of games and in Ubuntu the compbiz/KDE took up most of my 2 gigs of ram and ran games slower (than 3.5 in slackware 12.2)

I always start from console so that shouldn't be an issue.
 
Old 08-31-2009, 03:10 PM   #8
alkos333
Member
 
Registered: Dec 2006
Posts: 271

Rep: Reputation: 31
One of the issues that I ran into was that my keyboard mapping got screwed up. Subsequently, all of the combos that I set up in ~/.fluxbox/keys stopped working. I think the new X is either identifying the keyboard wrong, or I had it set up the wrong way previously.
 
Old 08-31-2009, 03:17 PM   #9
Melkor
Member
 
Registered: Aug 2003
Location: MN
Distribution: Linux Mint
Posts: 179

Rep: Reputation: 34
Quote:
Originally Posted by jkirchner View Post
I used xwmconfig to change to fluxbox and she fired right up with startx. I like starting from console too.
I also used xwmconfig to switch the default wm to Fluxbox and it worked fine for me when I typed "startx" from the console.
 
Old 09-01-2009, 10:43 PM   #10
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
Quote:
Originally Posted by alkos333 View Post
One of the issues that I ran into was that my keyboard mapping got screwed up. Subsequently, all of the combos that I set up in ~/.fluxbox/keys stopped working. I think the new X is either identifying the keyboard wrong, or I had it set up the wrong way previously.
I just finished upgrading from 12.2 to 13 on my Pavilion ze4315 and this is the biggest issue I'm having. I still have to use my xorg.conf for Fluxbox to work. I'll browse the xorg log, xorg.conf and xev later. I just now found that my End key does what the Window key (keycode 115) is supposed to do. And even though my omnibook driver is loaded only one of my quick access keys responds.

Also, if I have to quit X with Ctrl+Alt+BkSpc, Fluxbox (or KDE) won't restart properly until I reboot. Probably a radeon driver issue between my laptop's ati Mobility U1 and the new Xorg.
 
Old 09-02-2009, 09:11 PM   #11
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
I solved the keyboard issue by adding
Code:
Section "ServerFlags"
Option "AllowEmptyInput""false"
Option "AutoAddDevices" "false"
EndSection
to xorg.conf

And solved my desktop issue. If the 3ddesktop daemon is running before startx it paints the background on top of my desktop.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf and hal conficts: unable to set keyboard or monitor settings. Gustav 4 Slackware 3 08-16-2009 08:01 AM
No sound when in XOrg and openbox or fluxbox Dankles Ubuntu 1 12-30-2008 01:02 AM
HAL & Fluxbox alkos333 Slackware 1 07-06-2007 12:56 AM
BlackBox or Fluxbox using Hal davimint Linux - Desktop 1 06-07-2007 11:03 AM
xorg + fluxbox -> huge fonts darkleaf Linux - Software 3 07-14-2005 05:16 AM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration