LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-19-2008, 03:36 AM   #1
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
HAL and fmask dmask in automounting ntfs-3g drives


Hi

My external 'My Book', is ntfs-3g and HAL currently mounts it as drwxrwxrwx root:root , I want to mount it with
dmask=0007,fmask=0117,gid=100,uid=1000

I managed to do this using ivman & pmount , but the problem is .. now I can't right click on the drive (in my file manager) and do an umount (as it has been manually mounted)


How do I tell hal what dmask and fmask values to use while mounting ? Preferrably , I would like to use this setting for all ntfs-3g drives.

Googling didn't help much ..
http://wiki.archlinux.org/index.php/...sk_for_ntfs-3g

talks about making fmask / dmask as a permissible setting but not how to set it.


Any help would be great. I had put this in Robby's thread but I think everyone has stopped checking it out .. so the new thread.
 
Old 09-19-2008, 09:55 PM   #2
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 37
I can't help you with the other stuff but, I have Western Digital "My Book" and came formatted in vfat.
 
Old 09-23-2008, 02:42 PM   #3
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Original Poster
Rep: Reputation: 46
okos: you should reformat it to NTFS. Using 1TB as FAT is nearly criminal . and anyways FAT doesn't support files > 4GB in size.


Ok I added the following line to fstab :

UUID=<uuid> /media/My\040Book ntfs-3g users,dmask=0027,fmask=0137,gid=100,uid=1000 1 0


This is fine, but I thought that by adding the users option I will be able to mount it as a normal user but I can't seem to. when I do mount /dev/sdc1 as normal used , ntfs-3g says "can't mount as normal user, must be run as root)

thus when I dbl click on the disk in my filemanager , HAL gives a error. Which I don't understand cos I thought HAL ran with practically root privileges.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is fmask & dmask required to write to a WinXP share mounted on Mdrake SMB client ruscook_oz Linux - Networking 1 02-08-2007 05:50 PM
getting fat32 (Win98SE) part to mount with dmask and fmask options Simon Bridge Linux - General 3 06-22-2005 01:50 AM
smbmnt,fmask=,dmask=,umask= ARRGGHHH mickboda Linux - Networking 3 12-23-2004 05:04 PM
dmask=,fmask=,umask= ARGHHHHHHH mickboda Linux - General 1 03-16-2004 04:32 AM
umask,dmask,fmask mmm Linux - General 1 08-14-2003 12:29 AM


All times are GMT -5. The time now is 03:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration