LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   HAL and fmask dmask in automounting ntfs-3g drives (http://www.linuxquestions.org/questions/slackware-14/hal-and-fmask-dmask-in-automounting-ntfs-3g-drives-670993/)

duryodhan 09-19-2008 03:36 AM

HAL and fmask dmask in automounting ntfs-3g drives
 
Hi

My external 'My Book', is ntfs-3g and HAL currently mounts it as drwxrwxrwx root:root , I want to mount it with
dmask=0007,fmask=0117,gid=100,uid=1000

I managed to do this using ivman & pmount , but the problem is .. now I can't right click on the drive (in my file manager) and do an umount (as it has been manually mounted)


How do I tell hal what dmask and fmask values to use while mounting ? Preferrably , I would like to use this setting for all ntfs-3g drives.

Googling didn't help much ..
http://wiki.archlinux.org/index.php/...sk_for_ntfs-3g

talks about making fmask / dmask as a permissible setting but not how to set it.


Any help would be great. I had put this in Robby's thread but I think everyone has stopped checking it out .. so the new thread.

okos 09-19-2008 09:55 PM

I can't help you with the other stuff but, I have Western Digital "My Book" and came formatted in vfat.

duryodhan 09-23-2008 02:42 PM

okos: you should reformat it to NTFS. Using 1TB as FAT is nearly criminal . and anyways FAT doesn't support files > 4GB in size.


Ok I added the following line to fstab :

UUID=<uuid> /media/My\040Book ntfs-3g users,dmask=0027,fmask=0137,gid=100,uid=1000 1 0


This is fine, but I thought that by adding the users option I will be able to mount it as a normal user but I can't seem to. when I do mount /dev/sdc1 as normal used , ntfs-3g says "can't mount as normal user, must be run as root)

thus when I dbl click on the disk in my filemanager , HAL gives a error. Which I don't understand cos I thought HAL ran with practically root privileges.


All times are GMT -5. The time now is 12:17 AM.