LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-20-2008, 03:58 PM   #1
The_Beast
LQ Newbie
 
Registered: Mar 2008
Distribution: Archlinux
Posts: 29

Rep: Reputation: 15
Gyachi Problem


hi, i'm trying to install Gyachi and I get the following error from ./configure:

Code:
checking for GTKHTML... configure: error: Package requirements (libgtkhtml-2.0 >= 2.0) were not met:

Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gtk+-2.0', required by 'libgtkhtml', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTKHTML_CFLAGS
and GTKHTML_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
I already have Gtk+-2.10.0 and libgtkhtml, gtk+ is really annoying, firefox 3 can't find it either and after trying to fix that i uninstalled gtk-1.2 which was needed by xmms,atleast i managed to fix that, any help for the error above?

Thanks in advance.
 
Old 06-21-2008, 02:48 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,272

Rep: Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662Reputation: 2662
'gyachi-1.1.0' is the newest version, and not a word about libgtkhtml,
when running configure (libgtkhtml2 is required, according to the config files)
(grep gtkhtml gyachi-1.1.0/*)

Version 1.1.0 compiles with no problems on a clean Slacware 12,
so I can't see why you have the errors.
Suggest : reinstall libgtkhtml-2.11.0-i486-1.

No need to uninstall gtk-1.2, total different names for all files and
different locations.

Some dependencies are not checked by 'configure'. You will also need :
...(lib)jasper => version 1.900.1 source from
http://www.ece.uvic.ca/~mdadams/jasper/#download
...libmcrypt (=> libmcrypt-2.5.8-i486-1sl.tgz)
...xmms (xmmsctrl.h is required)

Rgds

Last edited by knudfl; 06-22-2008 at 04:29 AM.
 
Old 06-26-2008, 06:38 PM   #3
The_Beast
LQ Newbie
 
Registered: Mar 2008
Distribution: Archlinux
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks, but I have already found the solution in irc's slackware channel, it seems Gtk-2 was broken somehow and had to reinstall it, guess I messed up something and didn't understand it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
webcam and audio is not working on Gyachi, help me fix this problem stingphil Linux - Newbie 0 06-05-2008 12:30 AM
installing GYachI JUbuntu Linux - Newbie 1 03-22-2008 09:19 AM
problem with installation of gyachi maheshadadrsh Linux - Software 4 01-12-2008 02:03 PM
clamav and GYachi problem jonny_b4e Slackware 4 01-13-2007 07:18 PM
Could this be a virus? (gyachi) odiseo77 Linux - Security 4 03-03-2006 09:40 AM


All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration