LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-20-2009, 11:38 PM   #1
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Rep: Reputation: 39
gtk-qt-engine and KDE4 (Slackware Current)


I wonder if anyone else is having this problem...

When I install gtk-qt-engine and enable it, firefox hangs on close. I get an error message telling me that firefox is already running and I can't start it up until I kill all the firefox processes.
 
Old 05-21-2009, 05:49 PM   #2
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Original Poster
Rep: Reputation: 39
Well, seems like gtk-KDE4 is the way to go. It doesn't look quite as nice but it is functional and doesn't look fugly like the default look for gtk apps in Slackware.
 
Old 05-21-2009, 06:41 PM   #3
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
Could you try the fix offered in this article: http://www.vcn.bc.ca/~dugan/setting-up-slackware.html. Scroll to "Eye Candy"

"You've probably noticed that your GTK2-based programs look like crap unless they're running in Xfce. That's because Xfce use the xfce-mcs-manager daemon to set the appearance of your GTK2-based apps to whatever you've specified using Xfce's control panel. When xfce-mcs-manager isn't running, the appearance of your GTK2 widgets remains at default.

So if you're running anything other than Xfce then have, as appropriate, your .xsession or .xinitrc or your window manager's startup file launch xfce-mcs-manager."

I have had luck with this in the past.
 
Old 05-21-2009, 07:56 PM   #4
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Original Poster
Rep: Reputation: 39
Quote:
Originally Posted by justin_p View Post
Could you try the fix offered in this article: http://www.vcn.bc.ca/~dugan/setting-up-slackware.html. Scroll to "Eye Candy"

"You've probably noticed that your GTK2-based programs look like crap unless they're running in Xfce. That's because Xfce use the xfce-mcs-manager daemon to set the appearance of your GTK2-based apps to whatever you've specified using Xfce's control panel. When xfce-mcs-manager isn't running, the appearance of your GTK2 widgets remains at default.

So if you're running anything other than Xfce then have, as appropriate, your .xsession or .xinitrc or your window manager's startup file launch xfce-mcs-manager."

I have had luck with this in the past.
That's what I used to do but its pretty much just a bad hack... The beauty of things like gtk-qt-engine and gtk-KDE4 (when they actually work) is that it gives a nicer integration of gtk apps in kde.

Alas, it looks like gtk-KDE4 breaks some menus in gimp... sigh... I miss KDE3

When is KDE4 going to come out of beta? :P
 
Old 05-21-2009, 10:22 PM   #5
happybear
LQ Newbie
 
Registered: Jul 2006
Location: Pilipinas
Distribution: slackware-current
Posts: 16

Rep: Reputation: 1
i'm also having a hard time setting that up, so i gave up and just installed QtCurve for both toolkit, now my kde apps and gtk apps look the same...
 
Old 05-22-2009, 01:03 AM   #6
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Original Poster
Rep: Reputation: 39
Quote:
Originally Posted by happybear View Post
i'm also having a hard time setting that up, so i gave up and just installed QtCurve for both toolkit, now my kde apps and gtk apps look the same...
I'll check it out, thanks!
 
Old 05-22-2009, 01:45 AM   #7
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Original Poster
Rep: Reputation: 39
This is how I de-fuglified firefox:

xfsettingsd (probably want to put this in autostart KDE4)

from there, I use xfce4-settings-manager to configure
section appearence
section style: qt

you can also set the anti-aliasing in the font section

oh ya, you can match the mouse to the KDE4 appearance in the mouse section as well: oxygen black theme

Last edited by mattydee; 05-22-2009 at 01:49 AM.
 
Old 05-22-2009, 03:54 AM   #8
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
It's a bug, I got it too, it's caused because you choose QT4 as style and it has many bugs at the moment, now if you install QtCurve and use it as default GTK style firefox will finally work and it won't give you bugs. Bye.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving to Kde4 in Current TNWestTex Slackware 4 05-20-2009 11:42 AM
Problem with Slackware current KDE4 and HAL I guess heimdal Slackware 6 11-05-2008 02:03 AM
gtk-qt-engine causes white border on gtk tray icons tdtooke Linux - Desktop 0 08-08-2008 12:25 PM
GTK+ 2.10.x on Slackware-current? AntZero Slackware 1 09-22-2006 12:48 AM
GTK installing from Slackware current AhYup Slackware 3 06-25-2005 11:26 AM


All times are GMT -5. The time now is 01:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration