Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-12-2010, 08:33 PM   #1
Registered: May 2004
Distribution: Slackware
Posts: 46

Rep: Reputation: 23
GTK apps not respecting Compose Key

I often have to use accents, umlauts, and even sometimes an ogonek. QT apps work just fine. GTK apps used to work fine. I don't think there was a problem before Slackware 13.0, and though I've seen this problem described elsewhere on the 'net, the solutions seem Gnome-centric and don't work for me.

I set my .Xmodmap file to give me a Compose Key (Multi_key) with ralt and lwin. On my computer, this does the trick:

keycode 108 = Multi_key
keycode 133 = Multi_key
I've also set both ralt and lwin to be compose keys in my xorg.conf:

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "kbd"
  Option "XkbModel" "pc101"
  Option "XkbOptions" "compose:lwin"
  Option "XkbOptions" "compose:ralt"
The non-Gnome-centric solutions involve adding to the ~/.gtkrc-2.0 one of the following lines:

Neither of these seem to work for me.

Though the problem seems independent of WM/DE choice (has been present in all I've used), I generally use E16. I have tried removing redundancy (i.e., only setting the Multi_key option in ~/.Xmodmap, or, conversely, only setting it in xorg.conf; or only setting it for ralt or lwin exclusively). Any ideas?



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating new compose and dead-key combinations DavidMcCann Linux - General 3 10-13-2007 05:01 AM
GTK Applications Not Respecting Subpixel Settings tvynr Linux - Desktop 1 09-06-2006 06:42 PM
How to disable compose key (Right Control) under GNOME? wirawan0 SUSE / openSUSE 0 10-05-2005 11:57 AM
KDE, compose key, and xkb problems nazdrowie Linux - General 0 02-24-2005 12:37 AM
compose key not working jkobrien Linux - Hardware 1 08-05-2004 08:18 AM

All times are GMT -5. The time now is 10:31 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration