LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-10-2006, 01:51 AM   #1
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Rep: Reputation: 0
GTK applications in kde problem


hi

I've aproblem that some GTK applications
uses my language I set in locale files

in another meaning :

some of them like xchat uses arabic in some buttons .

some others like gftp are totally translated to arabic and I'd like it to use english

the common thing for all of them is the arabic style " menues are arranged from right to left that means file menu for example comes in the right not left .

so how to fix this "I dont have gnome installded " and make them just appear in english with the right style ?
 
Old 05-11-2006, 02:31 PM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,752

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Set your locale to English.
 
Old 05-20-2006, 08:31 AM   #3
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Original Poster
Rep: Reputation: 0
if you mean that I've to make my language set to english in control centerregional and languages\country region

I did so .

actually I've set it only to english but invain

btw :

I have those two lines been added to /etc/profile.d/lang.sh

this how I can use arabic (reading and writing)


export LC_ALL=ar_EG.UTF-8

export CHARSET=ISO_8859-6

but it seems that gtk applications use arabic because of those two lines , but I can't remove them since I want arabic support in my linux

so is there any solution to make gtk applications use just english or is there any other way to change locale ?
 
Old 06-15-2007, 02:19 PM   #4
secretlydead
Member
 
Registered: Sep 2003
Location: Qingdao, China
Distribution: mandriva, slack, red flag
Posts: 248

Rep: Reputation: 31
http://www.linuxquestions.org/questi....php?p=2788176
 
Old 01-05-2008, 02:54 AM   #5
nglbrkr
Member
 
Registered: May 2005
Location: hiroshima
Distribution: debian
Posts: 75
Blog Entries: 9

Rep: Reputation: 17
I have the same problem as the OP. This thread and the one linked don't answer satisfactorily.

I installed Debian japanese, with KDE, to get japanese input working easily(like the arabic of the OP)
I want all apps in English, so I set language to English using the KDE settings menu. In fact I even removed japanese from the list.

Now KDE and most apps are in English, but I can still type japanese. Hurray.

BUT, gtk apps are stubbornly appearing in Japanese. Where do I fix this?

thanks
 
Old 01-05-2008, 03:18 AM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
run set in terminal and check if any of environment variables are referring to japanese.
 
Old 01-05-2008, 04:31 AM   #7
nglbrkr
Member
 
Registered: May 2005
Location: hiroshima
Distribution: debian
Posts: 75
Blog Entries: 9

Rep: Reputation: 17
Quote:
Originally Posted by Alien_Hominid View Post
run set in terminal and check if any of environment variables are referring to japanese.
Thanks for this pointer, but I'm still struggling

running env shows that LANG is still set to Japanese (so is KDE ignoring LANG?)
However when I changed it in
/etc/locale.gen
and
/etc/environment

it is still coming up as japanese!

How the hell do you change LANG in debian? Must change for all users - this is a workstation in a multi-user environment, and I need to clone it when fixed.

I tried dpkg-reconfigure locales
if I choose en_US.UTF8 only, then everything is in English, but Japanese SCIM doesn't work.
If I choose en_US.UTF8 AND ja_JP.UTF8 then I am back to my original problem.

Last edited by nglbrkr; 01-05-2008 at 04:57 AM.
 
Old 01-05-2008, 06:49 AM   #8
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Maybe LANG is set in bash profile in /etc/profile. Check all places where bash could set this environmental variable (like ~/.bashrc).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird font problem with GTK applications running in KDE Jeshua Linux - Software 1 02-22-2006 08:16 AM
Having a problem with large fonts with non-KDE applications blk96gt Slackware 6 01-12-2006 01:14 AM
Too small fonts in GTK applications (XMMS, Winetools) in KDE pinknick Linux - Software 1 01-09-2006 06:43 PM
kde applications crash problem Pazabo Linux - Software 0 12-15-2005 04:08 AM
kde, GTK+ problem sadeer Linux - General 1 08-20-2002 11:07 AM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration