LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2009, 08:13 PM   #1
agrestic
Member
 
Registered: Jan 2009
Location: atlanta, ga, usa
Distribution: sabayon 5, slack64, Lenny, LFS 6.4 user # 20665
Posts: 61

Rep: Reputation: 16
gst-plugins-bad error regarding x264


Slack 12.2; fresh install. I have the x264 slackbuild installed, but when installing the bad set of gstreamer plugins, I get this:
Code:
gstx264enc.c:394:3: error: attempt to use poisoned "gst_debug_log_valist"
gstx264enc.c: In function 'gst_x264_enc_log_callback':
gstx264enc.c:394: warning: implicit declaration of function 'gst_debug_log_valist'
gstx264enc.c:394: error: 'x264_enc_debug' undeclared (first use in this function)
gstx264enc.c:394: error: (Each undeclared identifier is reported only once
gstx264enc.c:394: error: for each function it appears in.)
gstx264enc.c: In function 'gst_x264_enc_init_encoder':
gstx264enc.c:544: error: 'x264_param_t' has no member named 'b_bframe_adaptive'
make[3]: *** [libgstx264_la-gstx264enc.lo] Error 1
make[3]: Leaving directory `/tmp/SBo/gst-plugins-bad-0.10.9/ext/x264'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/SBo/gst-plugins-bad-0.10.9/ext'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/gst-plugins-bad-0.10.9'
make: *** [all] Error 2
Why? IDK what plugins, if any, i would need to listen to streaming radio that ends in .asp (wsbradio.com) and watch the news (foxnews.com/video and breitbart.tv). So do i even need the bad set of gst plugins?

TIA.
 
Old 01-31-2009, 11:50 AM   #2
rkfb
Member
 
Registered: Oct 2003
Location: Guildford, England
Distribution: slackware
Posts: 289

Rep: Reputation: 39
Open pkgtool, remove x264
Install bad plugins
Install x264

hth
 
Old 01-31-2009, 01:00 PM   #3
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 291

Rep: Reputation: 75
Quote:
Originally Posted by agrestic View Post
Code:
gstx264enc.c:544: error: 'x264_param_t' has no member named 'b_bframe_adaptive'
I'm not sure what the entire error message is telling you but I ran into something similar with xmms2. In my situation, ffmpeg had changed one of the variables in their avcodec.h file and gave me a similar error. If you were to open up /usr/include/x264.h then you'd most likely not find a variable called "b_bframe_adaptive" in it. I didn't find it in mine. It looks like they changed it to "i_bframe_adaptive". The easiest solution is to uninstall x264, install gst-plugins-bad, and then reinstall x264 like frostierh9 mentioned. Otherwise, you may need to find a suitable patch.
 
Old 01-31-2009, 01:22 PM   #4
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 291

Rep: Reputation: 75
Just as a quick follow up. It looks like the latest version of gst-plugins-bad, available here, now takes into account for this issue. Try the 0.10.10 version and see if it will compile against x264 properly.
 
Old 02-01-2009, 12:52 AM   #5
agrestic
Member
 
Registered: Jan 2009
Location: atlanta, ga, usa
Distribution: sabayon 5, slack64, Lenny, LFS 6.4 user # 20665
Posts: 61

Original Poster
Rep: Reputation: 16
Removed x264, installed the latest bad set, reinstalled x264.
Works perfect!
Thanks, guys.
 
Old 02-24-2009, 09:51 PM   #6
mancho
LQ Newbie
 
Registered: Feb 2009
Location: Manizales, Colombia
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
I had exactly the same problem in Slamd64 12.2, did the same as agrestic and it worked!

Thank you!

(bad 0.10.10 says it requires gstreamer >= 0.10.21.1 and I have 0.10.21)
 
Old 02-24-2009, 11:54 PM   #7
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 517

Rep: Reputation: 132Reputation: 132
I was also having this problem. Thanks, frostierh9
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mencoder: x264 [error]: no ratecontrol method specified PsypherPunk Linux - Software 1 01-12-2008 08:45 AM
installing gst-base-plugins ankscorek Linux - Software 1 01-18-2007 03:28 AM
mplayer with x264 compile error jaykup Linux - Software 1 04-19-2006 02:22 PM
'document relations' plugins the bad tony yu Mandriva 0 01-18-2005 11:30 PM
Slackware 9.1/garnome-0.29.1 & gst-plugin error cybrjackle Slackware 1 01-18-2004 04:39 PM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration