LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-10-2013, 10:58 AM   #1
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Rep: Reputation: Disabled
Grub2 and freebsd problems.


Hi all, I'm trying to get grub2 from slackbuilds to boot FreeBSD with Slackware 14 and Windows XP. It picks up both Windows and Slackware fine, I've been following Dive's slackwiki but I just can't figure it out to get FreeBSD working with grub2. My Partition table looks like this.

/dev/sda1 Windows
/dev/sda2 swap
/dev/sda3 Slackware
/dev/sda4 FreeBSD

Any help, will be much appreciated.
 
Old 02-10-2013, 11:23 AM   #2
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,004

Rep: Reputation: 474Reputation: 474Reputation: 474Reputation: 474Reputation: 474
Quote:
Originally Posted by humid View Post
Hi all, I'm trying to get grub2 from slackbuilds to boot FreeBSD with Slackware 14 and Windows XP. It picks up both Windows and Slackware fine, I've been following Dive's slackwiki but I just can't figure it out to get FreeBSD working with grub2. My Partition table looks like this.

/dev/sda1 Windows
/dev/sda2 swap
/dev/sda3 Slackware
/dev/sda4 FreeBSD

Any help, will be much appreciated.
Perhaps this wiki will be of some help to you.

http://slackwiki.com/Dual_Booting_With_FreeBSD_9
 
Old 02-10-2013, 11:30 AM   #3
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
That's the slackwiki I've been looking at hitest, I've added the rule to /etc/grub.d/40_custom but it doesn't seem to pick up FreeBSD, even on the grub menu on boot.
 
Old 02-10-2013, 11:42 AM   #4
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,611
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
Hi

I have just been doing the same thing try
Code:
menuentry "FREEBSD 9.0" {
set root=(hd0,2)
chainloader +1
}
Add that to the /etc/grub.d/40_custom file then update-grub

of course set the hd0,2 to where you have put bsd
Did you put bsd on a primary partition as well?

Last edited by spiky0011; 02-10-2013 at 11:46 AM.
 
Old 02-10-2013, 11:51 AM   #5
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
yeah, I put it on a primary partition, is that a problem?
Another question 'set root=(hd0,2) ....does that mean the second partition?
I'm beginning to question myself now.
 
Old 02-10-2013, 11:57 AM   #6
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,611
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
Hi

No it has to go on a primary partition
Where did you install it to?? Do you have more than 1 drive? What partition did you install to?

hd0 is the 1st hdd
the 2 is the 2nd partition
hope this helps

BTW freebsd is cli only I am using PCBSD which has a gui
 
Old 02-10-2013, 12:05 PM   #7
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
Thanks for the help spiky0011, it's all on one drive /dev/sda on linux ...my partitions are posted with my first post. Do you need to run a command after you edit grub? I can't even see anything on the grub menu about FreeBSD.
 
Old 02-10-2013, 12:10 PM   #8
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,611
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
The file is in /etc/grub.d
Open 40_custom as root then make the entry close file.
Code:
sudo update-grub
 
Old 02-10-2013, 12:15 PM   #9
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
I have no 'update-grub' command? ...I've added everything to /etc/grub.d/40_custom
 
Old 02-10-2013, 12:21 PM   #10
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,611
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
Hi

I dont use slackware so not much help with that I use Ubuntu with grub2 and I,m sure you should have the same commands, If I,m wrong I hope a slckware user can point you in the right direction
 
Old 02-10-2013, 12:51 PM   #11
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: Ubuntu 12.04/12.10/13.04/LFS/Centos6.3/Debain/PCBSD/Mageia 3
Posts: 1,611
Blog Entries: 1

Rep: Reputation: 226Reputation: 226Reputation: 226
You did run update-grub as root, or with root privilages
 
Old 02-10-2013, 08:22 PM   #12
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
Yes, I have have no command called 'update-grub'
 
Old 02-10-2013, 09:22 PM   #13
harryhaller
Member
 
Registered: Sep 2004
Posts: 428

Rep: Reputation: Disabled
Try the following:
Code:
su
[root password]
update-grub
update-grub is probably in directory /sbin
 
Old 02-10-2013, 09:24 PM   #14
harryhaller
Member
 
Registered: Sep 2004
Posts: 428

Rep: Reputation: Disabled
don't forget to type "exit" to stop being root
 
Old 02-10-2013, 09:31 PM   #15
humid
LQ Newbie
 
Registered: Jan 2013
Posts: 12

Original Poster
Rep: Reputation: Disabled
I've exploded the package into a separate directory, and I still can't find the command. I installed grub2 from slackbuilds with sbopkg.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] GRUB2 can't boot FreeBSD, neither directly nor via the loader JZL240I-U Linux - Software 7 03-04-2013 02:43 AM
configure Grub2 to boot FreeBSD cccc Debian 5 06-26-2012 10:48 AM
I can't get grub2 to boot FreeBSD j1alu *BSD 12 02-11-2011 06:50 PM
Booting FreeBSD iso grub2 jmc1987 Linux - Newbie 3 01-20-2011 08:03 PM
[SOLVED] GRUB2 after a minor update of GRUB2 /boot prefix no longer needed?? wikapuki Linux - Software 1 10-24-2010 02:39 PM


All times are GMT -5. The time now is 02:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration