LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-13-2004, 08:20 AM   #1
Noogie
LQ Newbie
 
Registered: Jan 2004
Location: Western Australia
Distribution: SUSE 9.1 Professional
Posts: 12

Rep: Reputation: 0
GRUB and Slackware 9.1


A little while ago, I had Fedora on this evil box, after a little while I decided to leap to something a little more trickier. And now I'm baffled.

I still have GRUB on another partition leftover from Fedora, I'm pretty sure anyway, as it didn't disappear after I wiped Fedora, is there any way I can edit it to boot up Slackware? LILO refuses to work unless it's on a floppy and I find GRUB much more "friendly" anyway.

One other thing, I'm using a Logitech Optical Mouse, USB, but on the included PS/2 adaptor, any way I can get the scroller to work? I tried editing a file which slips my mind at the moment (only adding a line somewhere in the mouse input area, not changing anything else), but to no avail.

Please be as detailed as possible.
Thank you for any help.
 
Old 02-13-2004, 08:34 AM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
If the grub configuration file is still on the partition you have, you can add Slackware with this line:
kernel (hd0,0)/path/to/slack/kernel [options]
(hd0,0) == hda1.
For your mouse, the file is /etc/X11/XF86Config. Search here for which lines to add and where.
 
Old 02-13-2004, 09:11 AM   #3
ekoome
Member
 
Registered: Sep 2003
Posts: 52

Rep: Reputation: 15
I have a similar problem. I just installed Slack9.1 on my second harddisk (/dev/hdb5) but when i boot i can't see it on Grub. I already have REdhat 9 and win2K on the first harddisk.

My question is, what is the usual path to Slack Kernel since i have never used it before for me to update Grub in my first harddisk?

Eric
 
Old 02-13-2004, 10:37 AM   #4
Noogie
LQ Newbie
 
Registered: Jan 2004
Location: Western Australia
Distribution: SUSE 9.1 Professional
Posts: 12

Original Poster
Rep: Reputation: 0
Ok, I booted into GRUB, edited the Fedora boot thingies to this:

root (hd0,2)
kernel /boot/vmlinuz-ide-2.4.22 root=/dev/hda3

That got it up and running, even though I got some sort of an error, I am on Slackware now.
Hopefully it saved that, otherwise I'll have to try and mount the GRUB partition or something and get in there.
EDIT: @#$%!!
(Which I don't know exactly how to do, if that's what I do at all)

And with the mouse, I have it like this and it still doesn't work, I'll just post the whole lot and someone can point out what I did wrong, I know it comes up often, but I guess the more who understand, the better.

Quote:
# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

# Option "Protocol" "Auto"

# The available mouse protocols types that you can set below are:
# Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
# Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
# MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
# ThinkingMouse ThinkingMousePS/2 Xqueue
Option "Protocol" "PS/2"

# The mouse device. The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

Option "Device" "/dev/mouse"
# Option "Device" "/dev/psaux"
# Option "Device" "/dev/ttyS0"
# Option "Device" "/dev/ttyS1"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Option "SampleRate" "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

Option "ZAxisMapping" "45"

EndSection
Sorry about this. ^^;

Last edited by Noogie; 02-13-2004 at 11:06 AM.
 
Old 02-13-2004, 12:03 PM   #5
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Rep: Reputation: 15
Re: GRUB and Slackware 9.1

Quote:
Originally posted by Noogie
A little while ago, I had Fedora on this evil box, after a little while I decided to leap to something a little more trickier. And now I'm baffled.

I still have GRUB on another partition leftover from Fedora, I'm pretty sure anyway, as it didn't disappear after I wiped Fedora, is there any way I can edit it to boot up Slackware? LILO refuses to work unless it's on a floppy and I find GRUB much more "friendly" anyway.

One other thing, I'm using a Logitech Optical Mouse, USB, but on the included PS/2 adaptor, any way I can get the scroller to work? I tried editing a file which slips my mind at the moment (only adding a line somewhere in the mouse input area, not changing anything else), but to no avail.

Please be as detailed as possible.
Thank you for any help.
Please, can you try searching the forum before asking questions?
You can easily solve your mouse problem reading the thousands of posts on that topic.
And (after a quick forum search) now I'm sure the grub problem is not a unique case.
Sorry for being hard, but the same questions are being asked too frequently.
 
Old 02-13-2004, 01:00 PM   #6
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
For your mouse you need to put
Code:
Option "Protocol" "IMPS/2"
replacing Option "Protocol" "PS/2"
And I beleive the ZAxisMapping option needs to have a space between the 4 and 5.. just how Ive always seen it and used it.
 
Old 02-13-2004, 01:49 PM   #7
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
Option "ZAxisMapping" "45"
put a space between 4 & 5, while using the imps/2 protocol like above. If that doesn't work, try adding:
Option "Buttons" "5"

This useful page turned up in a search:
http://www.linuxquestions.org/questi...hreadid=145012
 
Old 02-13-2004, 02:08 PM   #8
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Quote:
Originally posted by ekoome


My question is, what is the usual path to Slack Kernel since i have never used it before for me to update Grub in my first harddisk?

Eric
/boot/vmlinuz


Now, if you need to make an emergency boot disk, Slackware installs
syslinux. just do this in a term window or CLI
makebootdisk /boot/vmlinuz

and wa la............
!! makebootdisk is ONE word!!
 
Old 02-13-2004, 11:24 PM   #9
Noogie
LQ Newbie
 
Registered: Jan 2004
Location: Western Australia
Distribution: SUSE 9.1 Professional
Posts: 12

Original Poster
Rep: Reputation: 0
I did search, I know the mouse thing had come up, I followed what was said in the threads I looked in and none that I read said anything about the mouse type, just the ZAxis bit. And the "45" was where I was getting pissed off when it wouldn't work (thanks Zero-0-Effect by the way, I'll try that).
The mouse bit was supposed to be a tiny question alongside the rest. ^^;

Now if someone has any clue how to edit the boot loader permanently, I'd appreciate it.
 
Old 02-14-2004, 10:12 AM   #10
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
What partition is grub on? What partition is Slack on? What arrangement do you currently have?
Try looking around in the grub partition for something like menu.lst (that's an L), that may be the configuration file.
 
Old 02-14-2004, 08:22 PM   #11
Noogie
LQ Newbie
 
Registered: Jan 2004
Location: Western Australia
Distribution: SUSE 9.1 Professional
Posts: 12

Original Poster
Rep: Reputation: 0
http://irev.net/noogie/Partitions.png
That's how my partitions are set up, I'm not sure how everything is, but my Windows and Slackware partitions are (obviously) the bigger ones.
 
Old 02-14-2004, 11:55 PM   #12
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try looking in the /boot for a menu.lst file or similar, however Red Hat usually placed the configuration file at /etc/grub.conf (which appears to be gone...).
 
Old 02-15-2004, 04:54 AM   #13
Noogie
LQ Newbie
 
Registered: Jan 2004
Location: Western Australia
Distribution: SUSE 9.1 Professional
Posts: 12

Original Poster
Rep: Reputation: 0
EDIT: Nevermind, I just went and wiped over it with LILO, I can't be bothered tinkering about so much. Thanks for any help given, now I'll try this Affero thingy, because it's obviously deserved in certain cases in my mind.

Last edited by Noogie; 02-15-2004 at 07:42 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware and grub? quaylet Slackware 6 06-26-2005 11:53 PM
Help with Slackware and grub? BajaNick Linux - Distributions 1 07-31-2003 05:58 AM
Slackware 9 and GRUB? likuidkewl Slackware 7 06-24-2003 02:04 AM
Grub in Slackware bongski55 Slackware 2 06-16-2003 07:40 PM
Slackware 8.1 and GRUB StevenPUlrick Slackware 10 02-16-2003 01:02 PM


All times are GMT -5. The time now is 04:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration