LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-01-2013, 06:23 PM   #1
ljb643
Member
 
Registered: Nov 2003
Posts: 292

Rep: Reputation: Disabled
Graphics tablet OK in 14.0, not so good in 14.1


I have a VisTablet PenPad graphics input tablet* that worked well under Slackware 14.0 (kernel 3.2.45 plus digimend patch for non-Wacom tablets).

With Slackware 14.1, the pen tracks and pressure levels work, but the two buttons on the pen no longer work at all. That is, Gimp doesn't see them, and "xinput test" doesn't show them doing anything. The tablet is fine, as I can boot the same PC back into Slackware 14.0 and it works.

With the Slackware 14.1 kernel 3.10.17, no patch is supposed to be needed for this device to work, but I'm wondering if something didn't make it in. Before I try asking at the digimend project, does anyone else have one of these with Slackware?

*Note: The VisTablet PenPad is the same device as the Waltop Q Pad, Aiptek Hyperpen Mini, NGS Flexi Style, iVistaTablet Q Flex Pad, and others. It is a very basic, very thin (bendable) graphics input tablet, 6x4.5" active area, pen with 2 buttons on it, AAA battery in the pen.
 
Old 12-02-2013, 04:08 PM   #2
ljb643
Member
 
Registered: Nov 2003
Posts: 292

Original Poster
Rep: Reputation: Disabled
It's not the kernel (or digimend patches). This was proven using the "evtest" diagnostic. The kernel reports the same events under Slackware 14.0 (patched kernel) and Slackware 14.1 (as-shipped) when the pen does something (proximity, touches the pad, or the 2 stylus buttons).

The problem was an option in my xorg.conf.d/*.conf file for this device. "Option "TPCButton" "on"" was necessary under Slackware 14.0 or the two buttons would not report correctly. Apparently the underlying bug was fixed, and now using this option prevents the buttons from reporting at all. Removed the option, and the tablet works fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Good compatible graphics tablet? Romanus81 Slackware 6 03-31-2008 11:27 AM
Help Installing Graphics Tablet chibiace Linux - Hardware 0 06-05-2005 12:32 PM
Graphics Tablet NightLord Linux - Hardware 0 06-03-2005 02:07 PM
Graphics Tablet odd Linux - Software 1 06-08-2004 12:07 PM
Graphics Tablet dnar Linux - Hardware 5 12-17-2002 02:24 AM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration