LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Graphics artifacts on Slackware 14.0, Radeon HD 6750 (http://www.linuxquestions.org/questions/slackware-14/graphics-artifacts-on-slackware-14-0-radeon-hd-6750-a-4175434914/)

andrixnet 10-31-2012 10:27 AM

Graphics artifacts on Slackware 14.0, Radeon HD 6750
 
I got a system with i5 and Radeon HD 6750 video card.
On Slackware 13.37 I just couldn't run X because it didn't recognize the chipset properly and had to use vesa driver. But that is history.

I just installed Slackware 14.0, full, plain install.

Immediately after booting, after it loads the framebuffer kernel driver (radeon, drm, kms), small red horizontal lines appear at random and change with display contents.
I configured X with xorgsetup (plain autodetect everything) and I started X.
Here there are a lot more such artifacts, some red, some different colors. They multiply so the screen becomes visually unusable after a short time.

From X.log :

(II) Kernel mode setting enabled
(WW) falling back to old probe method for modesetting
(WW) falling back to old probe method for vesa

....
(--) Radeon chipset "TURKS" ChipID=0x6759

Using Driver "vesa" in the config file yields no such artifacts.
In text console, with framebuffer loaded, there are artifacts, but much fewer.

How can I solve this and use the native driver for video?

Thank you.

ReaperX7 10-31-2012 09:28 PM

You may have to download and use the official AMD/ATI driver to get it working, which is recommended for most later model Radeons. The X11 Radeon driver may not have the proper support yet for this card.

andrixnet 11-07-2012 04:30 PM

Thank you ReaperX7.

I will try it.

The odd thing though is that the chipset is over 2 years old.
The video card is ATI Radeon HD 6570 1GB GDDR3 AX6570 1GBK3-H packaged by Power Color.

ReaperX7 11-07-2012 10:05 PM

Check the AMD/ATI website for the correct package. Driver packages 12.10-Official and 12.11-Beta should work with this card.

tuxbg 11-08-2012 05:17 AM

Remove all vga options from lilo,and maybe append this to lilo video=vesafb:off.
I have exact same problem with ATI HD 6670 :)


All times are GMT -5. The time now is 08:45 PM.