LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Google Talk Plugin, Slackware64-Current, Google Chrome (Latest) and Multilib - Error (http://www.linuxquestions.org/questions/slackware-14/google-talk-plugin-slackware64-current-google-chrome-latest-and-multilib-error-853546/)

Gavin Harper 01-01-2011 05:51 AM

Google Talk Plugin, Slackware64-Current, Google Chrome (Latest) and Multilib - Error
 
I receive this error when I try to run a webcam conversation (Family back in Scotland).

"A problem occurred while attempting to access your graphics hardware."

The camera works flawlessly with Skype on the same system and setup but for some reason, not google talk plugin.

I have built it for x86_64 and when I test with a laptop next to me, I can see my image on that screen but I get a broken plugin error when viewing the incoming stream.

/opt/google/talkplugin/libnpgtpo3dautoplugin.so is the crashing library.

Anyone have any ideas?

willysr 01-01-2011 10:18 AM

google talk plugin is known to have a broken package for x86_64

Gavin Harper 01-04-2011 07:39 AM

Same error on x86

Gavin Harper 01-04-2011 07:45 AM

After investigation and some debugging, I found a potential cause and so googling it returned me this:

"We have investigated this issue and determined that it is caused by the video card hardware/drivers missing certain features of OpenGL 2.0 that are required for Google video chat on Linux. We are working to support these kinds of video cards, but in the meantime the following work-arounds may allow you to place video calls:

For users of ATI hardware with the open-source drivers: Try EITHER switching to the proprietary ATI drivers (which should offer full OpenGL 2.0) OR continue to use the open-source drivers and create a file at /opt/google/talkplugin/envvars with the content "LIBGL_ALWAYS_SOFTWARE=1" (which will disable hardware acceleration, but incur a performance penalty)

For users of older-model NVIDIA hardware (e.g. GeForce4): Try uninstalling the NVIDIA drivers"

http://www.google.com/support/forum/...74683e9c&hl=en

I am using the FOSS ATI driver... I am currently trying the mini-hack fix.

EDIT: The fix works

# echo "LIBGL_ALWAYS_SOFTWARE=1" > /opt/google/talkplugin/envvars


All times are GMT -5. The time now is 06:08 PM.