LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Google Earth Slackware64 Multilib (http://www.linuxquestions.org/questions/slackware-14/google-earth-slackware64-multilib-769294/)

mlangdn 11-15-2009 10:40 AM

Google Earth Slackware64 Multilib
 
Using AlienBob's tutorial, I upgraded, installed any new, or just plain installed all of his packages after mirroring his multilib site. I just tried to install Google Earth (after a reboot) and I got this:

./setup.sh: line 216: setup.data/bin/Linux/amd64/setup.gtk2: cannot execute binary file

Google has not been any help in resolving this. I know some of you have done this successfully, so I wonder what or where I went wrong.

And I did reinstall the nvidia driver and clicking yes to 32bit layer.

I have not tried any other 32 bit stuff because this is all I wanted at the moment.

slackass 11-15-2009 11:17 AM

Did you try the SlackBuild?
http://slackbuilds.org/repository/13...a/GoogleEarth/

mlangdn 11-15-2009 01:40 PM

I tried that as well, it says it cannot execute the binary file.

thatquietboy 11-15-2009 04:25 PM

I tried it today, from the slackbuild. It worked fine. Are you sure you have the 32 bit libraries set up properly?

slackass 11-15-2009 04:44 PM

I never have a problem, but I don't use the packages on Eric's site because I run Current and the packages in
'a', 'ap', 'd', 'l', 'n', 'x'
may be different so I make my own using Eric's instructions.
I just did a Slack64 -C install this morning from the Current tree as of 11.14.09 and made the compat32 packages from Slack32 tree as of 11.14.09 as well and everything went perfect.
After I read your post I installed sbopkg and had it do GoogleEarth and it just slammed it right in an it works good.
Is it possible that the compat32 packages that you installed are not compatible with your system because of an update or something?

mlangdn 11-15-2009 08:38 PM

Well, I am running -current, but I don't believe that any of those packages have yet been changed. I could be wrong, though - that's been known to happen! :)

I'm at work right now. Tomorrow, I will plug away again. Maybe just start over on another partition.

slackass 11-15-2009 09:06 PM

There was a few changes according to the ChangeLog.txt
ftp://ftp.slackware.at/slackware64-c.../ChangeLog.txt

I think I would just remove the compat32 packages and make your own from -Current32
'a', 'ap', 'd', 'l', 'n', 'x'

The only time I had multi-lib fail me was when I cross bred something.

Hangdog42 11-16-2009 07:17 AM

By any chance are you running on a custom kernel? I had a similar problem running 32 bit binaries on Slackware64 and it turned out I had missed an option on the kernel config.

cwwilson721 11-16-2009 08:48 AM

Quote:

Originally Posted by mlangdn (Post 3757995)
I tried that as well, it says it cannot execute the binary file.

I know it's a silly question(s), but....
  • Did you make the file executable? (I've forgotten on more than one occasion, and have lost hair and sleep over it, until the light bulb blinks on...)
  • Is the file in a folder that allows you to execute it? (Not on a drive, for instance, that is flagged noexec, cdrw drive, usb thumbdrive with wrong permissions, or in a folder where permissions don't allow changing of files for the user or group)
  • Does the SlackBuild script start with
    Code:

    #!/bin/sh
    ?
All of those have tripped me up in the past, the first more than the second, and on occasion, the third when I forget to double-check

I usually run into the second issue (folder permissions or incorrect mounting of a thumbdrive) when I've downloaded with a different user than the one I tried executing the file with.

I've even tried running a SlackBuild file on a data backup cd from time to time (Makes life easier for me on reinstalls or new systems)...Amazing what you can do when in a hurry, or late at night when sleepy.

Just a small reminder....

Alien Bob 11-16-2009 10:15 AM

Quote:

Originally Posted by mlangdn (Post 3758349)
Well, I am running -current, but I don't believe that any of those packages have yet been changed. I could be wrong, though - that's been known to happen! :)

I use that same set of -compat32 packages both on Slackware64 13.0 and on Slackware64-current. It just keeps working since the 64-bit and 32-bit environments of the multilib setup are completely separate.

Eric

mlangdn 11-16-2009 10:29 AM

Quote:

Originally Posted by Hangdog42 (Post 3758689)
By any chance are you running on a custom kernel? I had a similar problem running 32 bit binaries on Slackware64 and it turned out I had missed an option on the kernel config.

Yes - daggonnit I am! I know I did not select 32bit capability. I purposely left it out to keep a pure 64 bit system. I am off to the kernel config to do another.

I'll be baaaaaack!

slackass 11-16-2009 10:45 AM

Quote:

Originally Posted by Alien Bob (Post 3758871)
I use that same set of -compat32 packages both on Slackware64 13.0 and on Slackware64-current. It just keeps working since the 64-bit and 32-bit environments of the multilib setup are completely separate.

Eric

Ah Ha! I didn't know that. I "assumed" that the -compat32 packages were supposed to be the same. I had problem before Slack64 13 came out that I "thought" I fixed by making my own -compat32 packages. If I remember it right, I had Fred's packages on the system at first and removed them to install your packages and I couldn't make something work after that.
I did a "hose & reload", made my own -compat32 packages. After that everything worked which led my to my incorrect assumption.

mlangdn 11-16-2009 11:48 AM

All-righty, then. I rebuilt the kernel, but now I have a more serious problem. Although Google Earth is now functional, I cannot install the nvidia driver. It complains about the kernel source not being right. I tried:

Code:

make oldconfig && make prepare
on the build tree, but I got the same error.

Code:

        echo "  ERROR: Kernel configuration is invalid.";              \
        echo "        include/linux/autoconf.h or include/config/auto.conf are mis
  sing.";      \
        echo "        Run 'make oldconfig && make prepare' on kernel src to fix it
  .";  \
        echo;                                                          \
        /bin/false)

Now to figure this one out.

mlangdn 11-16-2009 12:04 PM

Well - I finally got it right using the above command. I must have had my mouth open funny or something. Who knows what I did? I am famous for syntax errors, working in the wrong directory, and just generally screwing it up.

On the bright side, I learned how to mirror only what I needed. Google Earth now works. I built a new kernel that will work with 32bit programs.

Its 5 o'clock somewhere, so I'm gonna get a beer.

brianL 11-17-2009 07:40 AM

I zoomed in on my street, ran outside and waved, ran back to see if I could see myself - but no, I wasn't there. :confused:


All times are GMT -5. The time now is 12:08 PM.