LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-16-2012, 10:41 AM   #1
s1aw0
LQ Newbie
 
Registered: Jun 2012
Posts: 17

Rep: Reputation: Disabled
Google Earth in fluxbox (blackbox)


Hello everybody,

I am facing a strange problem when running GE in black/fluxbox. As expected, a photo appears as I click an object on the map (an icon of a pic, a remarkable place, etc.) but this happens just once. The following clicks on any object give just an empty white rectangular that looks like a placeholder for a photo. In XFCE, everything works as expected.

My question is: do you observe the following behavior of GE and do you know a way to fix this? Filling [PATH] in qt.conf as suggested elsewhere didn't help. [Slack >= 13.37]

TIA!
 
Old 10-16-2012, 09:33 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,235

Rep: Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553
My GoogleEarth ran okay on Slackware 13.37 with Fluxbox and is still fine under --Current, so I don't think this is a general problem.

Try starting it from the command line and watching for error messages. They might reveal something.
 
Old 10-17-2012, 04:45 AM   #3
s1aw0
LQ Newbie
 
Registered: Jun 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
Thank you for the reply. I have checked GE in fluxbox once again and ... GE works as expected! The problem with blackbox probably relates to the fact that I have tried an older version than that included in Slack-14.0.

Last edited by s1aw0; 10-17-2012 at 08:22 AM.
 
Old 10-17-2012, 09:12 PM   #4
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,235

Rep: Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553
Glad it's working. And that sounds like a nice guess to me.

I've looked at Blackbox, but never felt inclined to use it much. How's it working out for you?

Last edited by frankbell; 10-17-2012 at 09:14 PM.
 
Old 10-18-2012, 02:11 AM   #5
s1aw0
LQ Newbie
 
Registered: Jun 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
I had the problem for a year or so. Stupid me :-)

As for blackbox, I'm running version 0.65.0 from Slack-13.0 or so. I have a personal theme for it, which I don't have time to port to fluxbox or a newer version of bb. I like the way it switches between windows more than the fluxbox way: it doesn't switch immediately but shows a list of windows first. And it has a nice pager, which I haven't found for fluxbox yet.

I had absolutely no problems with bb other than the one with GE. In Slack-14.0, it cannot set the background image at startup: shows it for a moment and then hides. This is strange since it worked fine in -current. Probably, it's time to move to a newer version :-)
 
Old 10-18-2012, 10:34 PM   #6
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,235

Rep: Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553
Quote:
I had absolutely no problems with bb other than the one with GE. In Slack-14.0, it cannot set the background image at startup: shows it for a moment and then hides.
I have run into this in Fluxbox. I fixed it, but it was a while ago.

I think this was the fix (like I said, it's been a while): http://fluxbox-wiki.org/index.php/Ho...the_background

. . . in conjunction with setting up a last wallpaper file. http://fluxbox.org/help/man-fbsetbg.php

Since Fluxbox is built on Blackbox, maybe this will help you.
 
Old 10-19-2012, 04:37 PM   #7
s1aw0
LQ Newbie
 
Registered: Jun 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
Thank you! I will check them. BTW, I have found bbpager works nice in fluxbox.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Show Photos on Google Earth and Google Maps with*digiKam LXer Syndicated Linux News 0 10-12-2011 09:20 PM
no 'Earth' on Google earth blastradius Linux - Software 19 02-01-2009 01:05 PM
LXer: Google Maps and Google Earth KML overlays LXer Syndicated Linux News 0 10-29-2008 05:30 AM
Google Earth produces 'holes' in planet earth greengrocer Linux - Newbie 5 07-18-2006 11:57 PM
Blackbox or Fluxbox Trijicon Linux - Software 2 10-12-2005 03:15 PM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration