LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-01-2013, 01:15 PM   #1
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 42

Rep: Reputation: 18
google chrome 30


Slackware64-14, latest version of google-chrome (30.0.1599.66), installed using the slackbuild that came with the DVD. I'm getting this:

12167:12193:1001/141258:FATAL:nss_util.cc(396)] NSS_VersionCheck("3.14.3") failed. NSS >= 3.14.3 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.

NSS (mozilla-nss) is 3.15. Any ideas how to either fix this or where I can find the last version of the 29.xx tree? (Stupidly, I didn't save it when I upgraded the package.)\

ETA: I may just switch back to firefox out of pure spite.

Last edited by garpu; 10-01-2013 at 01:30 PM.
 
Old 10-01-2013, 01:30 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,175

Rep: Reputation: Disabled
Quote:
Originally Posted by garpu View Post
Slackware64-14, ...NSS (mozilla-nss) is 3.15.
The version of NSS in the "mozilla-nss" package of Slackware 14 is 3.13.5. You can build a newer mozilla-nss package using the sources in Slackware-current (where NSS is at version 3.14.3).

Eric
 
1 members found this post helpful.
Old 10-01-2013, 02:20 PM   #3
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 18
Gotcha, thanks. I must've misread *.13 for *.15.
 
Old 10-01-2013, 03:32 PM   #4
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 18
Well maybe it isn't solved.

I just grabbed mozilla-nss from /current, compiled it, and upgraded it. Same error. I'm wondering if the issue isn't with them?

ETA: double-checked that I compiled the right one (x86-64).

Last edited by garpu; 10-01-2013 at 05:30 PM.
 
Old 10-01-2013, 06:56 PM   #5
mattallmill
Member
 
Registered: Nov 2009
Location: Salina,Kansas
Distribution: Slackware64-current
Posts: 182

Rep: Reputation: 27
Quote:
Originally Posted by garpu View Post
Well maybe it isn't solved.

I just grabbed mozilla-nss from /current, compiled it, and upgraded it. Same error. I'm wondering if the issue isn't with them?

ETA: double-checked that I compiled the right one (x86-64).
I have run into the same problem. A solution would be greatly appreciated.
 
Old 10-01-2013, 07:30 PM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,493

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
I have a -current machine and building Google Chrome is not a problem here
 
Old 10-01-2013, 08:05 PM   #7
neymac
Member
 
Registered: May 2009
Distribution: Slackware64-14.0
Posts: 114

Rep: Reputation: 11
After read your post I updated my google-chrome using ruario's script (latest-chrome.sh),I use Slackware64-14.0 and no problems at all. The script can be found at http://www.panix.com/~ruari/latest-chrome . Good luck!
 
Old 10-01-2013, 11:54 PM   #8
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,784

Rep: Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797
From the start this post made no sense to me. The error complains about an older NSS version but as Alien Bob pointed out in the first reply, Slackware 14 already has a version of NSS that is more recent than what is required. Sure enough Chrome stable works just fine for me (indeed I can even run Google Chrome 30.0.1599.66 beta and Google Chrome 31.0.1650.4 dev without issue).

From my own system:

Code:
$ cat /etc/os-release 
NAME=Slackware
VERSION="14.0"
ID=slackware
VERSION_ID=14.0
PRETTY_NAME="Slackware 14.0"
ANSI_COLOR="0;34"
CPE_NAME="cpe:/o:slackware:slackware_linux:14.0"
HOME_URL="http://slackware.com/"
SUPPORT_URL="http://www.linuxquestions.org/questions/slackware-14/"
BUG_REPORT_URL="http://www.linuxquestions.org/questions/slackware-14/"
Code:
$ uname -m
x86_64
Code:
$ ls /var/log/packages/mozilla-nss-*
/var/log/packages/mozilla-nss-3.13.5-x86_64-3
Code:
$ google-chrome --version
Google Chrome 30.0.1599.66
What does the following report for you (so that someone with a working Chrome can compare with their own):

Code:
$ for f in $(find /opt/google/chrome/ -type f -exec file {} \; | grep ELF | cut -d: -f1); do echo $f; ldd $f; done
EDIT: My own reports the following:

Code:
/opt/google/chrome/PepperFlash/libpepflashplayer.so
        linux-vdso.so.1 (0x00007fff74a47000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fc4a1f90000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fc4a1d88000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fc4a1a86000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fc4a178b000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007fc4a1576000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fc4a1359000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fc4a0f99000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fc4a32f3000)
/opt/google/chrome/chrome
        linux-vdso.so.1 (0x00007fff161ff000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fdac44ba000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007fdac42b1000)
        libXss.so.1 => /usr/lib64/libXss.so.1 (0x00007fdac40ad000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fdac3e9c000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fdac3c94000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fdac3a8f000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007fdac3842000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007fdac3524000)
        libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007fdac2ef2000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007fdac2c40000)
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007fdac2a1e000)
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007fdac2811000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007fdac25f2000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007fdac2344000)
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007fdac20f8000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007fdac1e6b000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007fdac1c35000)
        libnss3.so => /usr/lib64/seamonkey/libnss3.so (0x00007fdac192d000)
        libnssutil3.so => /usr/lib64/seamonkey/libnssutil3.so (0x00007fdac1706000)
        libsmime3.so => /usr/lib64/seamonkey/libsmime3.so (0x00007fdac14df000)
        libplc4.so => /usr/lib64/seamonkey/libplc4.so (0x00007fdac12da000)
        libnspr4.so => /usr/lib64/seamonkey/libnspr4.so (0x00007fdac109c000)
        libgconf-2.so.4 => /usr/lib64/libgconf-2.so.4 (0x00007fdac0e76000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007fdac0c73000)
        libasound.so.2 => /usr/lib64/libasound.so.2 (0x00007fdac0984000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007fdac0782000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007fdac057b000)
        libcups.so.2 => /usr/lib64/libcups.so.2 (0x00007fdac0330000)
        libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x00007fdac00b2000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fdabfe95000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007fdabfc6c000)
        libdbus-1.so.3 => /usr/lib64/libdbus-1.so.3 (0x00007fdabfa28000)
        libudev.so.0 => /lib64/libudev.so.0 (0x00007fdabf81a000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fdabf519000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fdabf21e000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007fdabf008000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fdabec48000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fdaca3da000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fdabea2a000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fdabe826000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fdabe621000)
        libgthread-2.0.so.0 => /usr/lib64/libgthread-2.0.so.0 (0x00007fdabe41f000)
        libffi.so.6 => /usr/lib64/libffi.so.6 (0x00007fdabe217000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007fdabe015000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007fdabde06000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007fdabdbfe000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007fdabd9f4000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007fdabd76e000)
        libpng14.so.14 => /usr/lib64/libpng14.so.14 (0x00007fdabd549000)
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007fdabd1fd000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fdabcfe2000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007fdabcdb6000)
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007fdabcbb3000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00007fdabc99d000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x00007fdabc78d000)
        libplds4.so => /usr/lib64/seamonkey/libplds4.so (0x00007fdabc589000)
        libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007fdabc361000)
        libssl.so.1 => /lib64/libssl.so.1 (0x00007fdabc0f7000)
        libcrypto.so.1 => /lib64/libcrypto.so.1 (0x00007fdabbd1a000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fdabbae2000)
        libgpg-error.so.0 => /usr/lib64/libgpg-error.so.0 (0x00007fdabb8df000)
/opt/google/chrome/lib/libpeerconnection.so
        linux-vdso.so.1 (0x00007fffc471b000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fb2e2fa6000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fb2e2ca5000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fb2e29a9000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fb2e278d000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fb2e23cd000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fb2e34f7000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007fb2e21b7000)
/opt/google/chrome/libffmpegsumo.so
        linux-vdso.so.1 (0x00007fff9d7ff000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fa39af70000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa39ad54000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fa39a993000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fa39b610000)
/opt/google/chrome/libpdf.so
        linux-vdso.so.1 (0x00007fffa7360000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f0d31df7000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f0d31af6000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f0d317fa000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f0d315e5000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0d313c9000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f0d31008000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f0d326a2000)
/opt/google/chrome/libppGoogleNaClPluginChrome.so
        linux-vdso.so.1 (0x00007fff117ff000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f9f9fe01000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f9f9fbe5000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f9f9f8e3000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f9f9f5e8000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f9f9f228000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f9fa00c1000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f9f9f012000)
/opt/google/chrome/libwidevinecdm.so
        linux-vdso.so.1 (0x00007fff7390f000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f26eabe7000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f26ea8ec000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f26ea6cf000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f26ea30f000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f26eb594000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f26ea0fa000)
/opt/google/chrome/libwidevinecdmadapter.so
        linux-vdso.so.1 (0x00007ffffaf4e000)
        libwidevinecdm.so => /opt/google/chrome/libwidevinecdm.so (0x00007f39f6bca000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f39f6890000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f39f6674000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f39f62b4000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f39f5fb8000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f39f724f000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f39f5da3000)
/opt/google/chrome/nacl_helper
        linux-vdso.so.1 (0x00007fffbfb09000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f8e03666000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f8e0345e000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f8e03259000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f8e02f3b000)
        libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f8e0290a000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f8e02657000)
        libnss3.so => /usr/lib64/seamonkey/libnss3.so (0x00007f8e02350000)
        libnssutil3.so => /usr/lib64/seamonkey/libnssutil3.so (0x00007f8e02129000)
        libnspr4.so => /usr/lib64/seamonkey/libnspr4.so (0x00007f8e01eea000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f8e01cce000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f8e019cd000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f8e016d1000)
        libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f8e014bc000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f8e010fc000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f8e03bd6000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f8e00edd000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f8e00cda000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f8e00ad5000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f8e008d2000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f8e006c4000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f8e004bc000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f8e002aa000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f8e000a0000)
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f8dffe94000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f8dffc91000)
        libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f8dffa8f000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f8dff889000)
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f8dff666000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f8dff3b8000)
        libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f8dff133000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f8dfef29000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f8dfed0a000)
        libpng14.so.14 => /usr/lib64/libpng14.so.14 (0x00007f8dfeae5000)
        libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007f8dfe798000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f8dfe57e000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f8dfe352000)
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f8dfe106000)
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f8dfdf03000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f8dfdccd000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f8dfda3f000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00007f8dfd82a000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x00007f8dfd61a000)
        libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f8dfd3f0000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f8dfd1a3000)
        libgthread-2.0.so.0 => /usr/lib64/libgthread-2.0.so.0 (0x00007f8dfcfa2000)
        libffi.so.6 => /usr/lib64/libffi.so.6 (0x00007f8dfcd99000)
        libplc4.so => /usr/lib64/seamonkey/libplc4.so (0x00007f8dfcb95000)
        libplds4.so => /usr/lib64/seamonkey/libplds4.so (0x00007f8dfc991000)
/opt/google/chrome/nacl_helper_bootstrap
        not a dynamic executable
/opt/google/chrome/nacl_irt_x86_64.nexe
        not a dynamic executable

Last edited by ruario; 10-02-2013 at 12:56 AM.
 
Old 10-02-2013, 12:06 AM   #9
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,784

Rep: Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797
Also do you have a full install? I just noticed whilst looking at my own ldd output that Chrome is using the /usr/lib64/seamonkey/libnss3.so, which is from seamonkey-solibs-2.20-x86_64-2_slack14.0, rather than the mozilla-nss-3.13.5-x86_64-3.

P.S. It is not a problem that nacl_helper_bootstrap and nacl_irt_x86_64.nexe state "not a dynamic executable" in my above output because they are statically linked binaries.

Last edited by ruario; 10-02-2013 at 12:57 AM. Reason: Added postscript
 
Old 10-02-2013, 02:09 AM   #10
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,784

Rep: Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797
As side note since Alien Bob is reading this, you might want to mention to Pat that google-chrome-pam-solibs is no longer needed by Chrome, so could potentially be removed from /extra on -current. This has been the case since at least February.

Additionally this part of google-chrome.SlackBuild is now redundant:
Code:
# Link to the standard Mozilla library names:
sed -i 's,libnss3.so.1d,libnss3.so\x00\x00\x00,g;
        s,libnssutil3.so.1d,libnssutil3.so\x00\x00\x00,g;
        s,libsmime3.so.1d,libsmime3.so\x00\x00\x00,g;
        s,libssl3.so.1d,libssl3.so\x00\x00\x00,g;
        s,libplds4.so.0d,libplds4.so\x00\x00\x00,g;
        s,libplc4.so.0d,libplc4.so\x00\x00\x00,g;
        s,libnspr4.so.0d,libnspr4.so\x00\x00\x00,g;' opt/google/chrome/chrome

Last edited by ruario; 10-02-2013 at 02:11 AM.
 
Old 10-02-2013, 04:14 AM   #11
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,784

Rep: Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797
Quote:
Originally Posted by neymac View Post
After read your post I updated my google-chrome using ruario's script (latest-chrome.sh),I use Slackware64-14.0 and no problems at all. The script can be found at http://www.panix.com/~ruari/latest-chrome . Good luck!
Whilst it is possible this could be the difference (I haven't actually tested) I think it is unlikely since there is no building going on. My script and Pat's SlackBuild are both just doing repacks and whilst the steps we take are not identical the end result should be very similar. I did considered the fact that he uses the deb as a source and I the rpm, however, having checked the binaries contained within both "source" packages (./nacl_helper_bootstrap ./nacl_helper ./libpdf.so ./nacl_irt_x86_64.nexe ./libwidevinecdmadapter.so ./PepperFlash/libpepflashplayer.so ./lib/libpeerconnection.so ./libppGoogleNaClPluginChrome.so ./chrome-sandbox ./libffmpegsumo.so ./chrome ./libwidevinecdm.so) I see that they have exactly the same md5sums.
 
Old 10-02-2013, 07:39 AM   #12
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 18
Yes, full install. (From a few days ago, even.) Yes, 64 bit.

Code:
$ for f in $(find /opt/google/chrome/ -type f -exec file {} \; | grep ELF | cut -d: -f1); do echo $f; ldd $f; done
parse error near 'do'.

Here's what LDD shows:

% /opt/google/chrome ldd chrome hildegard@guibert
linux-vdso.so.1 (0x00007fffe83ff000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f53c0736000)
libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f53c052d000)
libXss.so.1 => /usr/lib64/libXss.so.1 (0x00007f53c0329000)
libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f53c0118000)
librt.so.1 => /lib64/librt.so.1 (0x00007f53bff10000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f53bfd0b000)
libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f53bfabe000)
libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f53bf7a0000)
libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00007f53bf16e000)
libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00007f53beebc000)
libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00007f53bec9a000)
libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0 (0x00007f53bea8d000)
libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0 (0x00007f53be86e000)
libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00007f53be5c0000)
libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00007f53be374000)
libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f53be0e8000)
libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f53bdeb2000)
libnss3.so => /usr/lib64/seamonkey/libnss3.so (0x00007f53bdbac000)
libnssutil3.so => /usr/lib64/seamonkey/libnssutil3.so (0x00007f53bd98a000)
libsmime3.so => /usr/lib64/seamonkey/libsmime3.so (0x00007f53bd763000)
libplc4.so => /usr/lib64/seamonkey/libplc4.so (0x00007f53bd55e000)
libnspr4.so => /usr/lib64/seamonkey/libnspr4.so (0x00007f53bd320000)
libgconf-2.so.4 => /usr/lib64/libgconf-2.so.4 (0x00007f53bd0fa000)
libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f53bcef7000)
libasound.so.2 => /usr/lib64/libasound.so.2 (0x00007f53bcc08000)
libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f53bca06000)
libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f53bc7ff000)
libcups.so.2 => /usr/lib64/libcups.so.2 (0x00007f53bc5b4000)
libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x00007f53bc337000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f53bc11a000)
libexpat.so.1 => /usr/lib64/libexpat.so.1 (0x00007f53bbef1000)
libdbus-1.so.3 => /usr/lib64/libdbus-1.so.3 (0x00007f53bbcad000)
libudev.so.0 => /lib64/libudev.so.0 (0x00007f53bba9f000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f53bb79e000)
libm.so.6 => /lib64/libm.so.6 (0x00007f53bb4a3000)
libgcc_s.so.1 => /usr/lib64/libgcc_s.so.1 (0x00007f53bb28d000)
libc.so.6 => /lib64/libc.so.6 (0x00007f53baecd000)
/lib64/ld-linux-x86-64.so.2 (0x00007f53c6657000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f53bacaf000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f53baaab000)
libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f53ba8a6000)
libgthread-2.0.so.0 => /usr/lib64/libgthread-2.0.so.0 (0x00007f53ba6a4000)
libffi.so.6 => /usr/lib64/libffi.so.6 (0x00007f53ba49c000)
libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00007f53ba29a000)
libXi.so.6 => /usr/lib64/libXi.so.6 (0x00007f53ba08b000)
libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f53b9e83000)
libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00007f53b9c79000)
libpixman-1.so.0 => /usr/lib64/libpixman-1.so.0 (0x00007f53b99f3000)
libpng14.so.14 => /usr/lib64/libpng14.so.14 (0x00007f53b97ce000)
libgio-2.0.so.0 => /usr/lib64/libgio-2.0.so.0 (0x00007f53b9482000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f53b9267000)
libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00007f53b903b000)
libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f53b8e38000)
libz.so.1 => /usr/lib64/libz.so.1 (0x00007f53b8c22000)
libbz2.so.1 => /lib64/libbz2.so.1 (0x00007f53b8a12000)
libplds4.so => /usr/lib64/seamonkey/libplds4.so (0x00007f53b880e000)
libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00007f53b85e6000)
libssl.so.1 => /lib64/libssl.so.1 (0x00007f53b837e000)
libcrypto.so.1 => /lib64/libcrypto.so.1 (0x00007f53b7fa2000)
libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f53b7d6a000)
libgpg-error.so.0 => /usr/lib64/libgpg-error.so.0 (0x00007f53b7b67000)
 
Old 10-02-2013, 07:43 AM   #13
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 18
Hang on. It's getting libnss3.so from /usr/lib64/seamonkey. Is that right? Shouldn't it be getting it from mozilla-nss, instead?

Granted, I've had no coffee yet, but if I upgrade seamonkey it should theoretically work?

Still seems like a problem that it's loading some libraries from another browser...
 
Old 10-02-2013, 07:59 AM   #14
garpu
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 18
Slightly caffeinated. Upgraded seamonkey, and google chrome works again. Seems like really poor behavior on chrome's part, though, to prefer seamonkey's libraries over mozilla-nss.
 
Old 10-02-2013, 01:35 PM   #15
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,784

Rep: Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797Reputation: 797
The source of your issue however was that you didn't keep all of you Slackware packages up to date. Why are you selectively applying the security updates?

Quote:
Originally Posted by garpu View Post
Seems like really poor behavior on chrome's part, though, to prefer seamonkey's libraries over mozilla-nss.
seamonkey-solibs was the package that needed updating. You can have this installed without having Seamonkey installed.

Also it is apparently not that weird, given that Chrome doesn't appear to work with just the mozilla-nss-3.13.5-x86_64-3 package. If you remove seamonkey-solibs Chrome will not start, you will get the "NSS >= 3.14.3" error. I just tried it.

Last edited by ruario; 10-02-2013 at 02:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Chrome New Tab Page (!)= Chrome OS Desktop Kenny_Strawn Linux - General 6 02-19-2011 05:36 PM
[SOLVED] This there a Slackware version of Google Chromium Browser? (not Google Chrome) Robert.Thompson Slackware 6 01-13-2011 05:27 AM
[SOLVED] Google Talk Plugin, Slackware64-Current, Google Chrome (Latest) and Multilib - Error Gavin Harper Slackware 3 01-04-2011 07:45 AM
LXer: As Goes Chrome OS, So Goes Google's Chrome Browser LXer Syndicated Linux News 4 10-09-2010 03:18 PM
LXer: Google Chrome Automatically Installs Google Repository in Ubuntu LXer Syndicated Linux News 3 05-07-2010 11:20 AM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration