LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   gnutls and libffi missing (http://www.linuxquestions.org/questions/slackware-14/gnutls-and-libffi-missing-4175418241/)

VisionIncision 07-23-2012 09:56 AM

gnutls and libffi missing
 
Hi all,
I just tried to update my system with
Code:

slackpkg upgrade-all
and something went wrong. I was getting errors stating that libffi.**.so was missing, so I tried to install it manually and got an error that gnutls.**.so was missing. This was when slackpkg attempted to use wget.

Then I did something monumentally stupid, I uninstalled gnutls thinking that I would just reinstall it, of course, wget does not work. I have tried to find the appropriate package online (gnutls 3.*) but have had no luck.

Any suggestions?
Thanks

sorinm 07-23-2012 10:17 AM

Upgrade wget,openssl and openssl-solibs manually.

willysr 07-23-2012 10:19 AM

Code:

slackpkg install-new

VisionIncision 07-23-2012 10:21 AM

Quote:

Originally Posted by sorinm (Post 4735893)
Upgrade wget,openssl and openssl-solibs manually.

Thanks, where do I find the most recent packages for Slackware64 13.37?

VisionIncision 07-23-2012 10:22 AM

Quote:

Originally Posted by willysr (Post 4735894)
Code:

slackpkg install-new

That's what I should have done first, but I can't now as wget is not working. Also, when I have done that in the past, there was a huge list, I'm sure I do not need all of the packages listed, do I? Is it normal to just install hundreds of packages?

sorinm 07-23-2012 10:23 AM

I think you upgraded to current, not 13.37. See slackware.com for a list of mirrors.

VisionIncision 07-23-2012 10:24 AM

Quote:

Originally Posted by sorinm (Post 4735903)
I think you upgraded to current, not 13.37. See slackware.com for a list of mirrors.

Oh bugger, that might explain it.

VisionIncision 07-23-2012 10:35 AM

Ok, so I reinstalled gnutls and libffi but when I start X, I have no fonts, only squares.

willysr 07-23-2012 10:37 AM

where did you get those packages?
please don't mix up between 13.37 and -Current
i'm sure you messed up your system after previous upgrade attempts

VisionIncision 07-23-2012 10:40 AM

Quote:

Originally Posted by willysr (Post 4735917)
where did you get those packages?
please don't mix up between 13.37 and -Current
i'm sure you messed up your system after previous upgrade attempts

I got the packages from here http://slackware.mirrors.tds.net/pub...slackware64/n/

Unfortunately, I think I might have inadvertently done so..... PLEASE tell me this does not mean I have to reinstall.......

willysr 07-23-2012 11:00 AM

please show me the mirror site you uncommented in /etc/slackpkg/mirrors
because there are no updates about libffi and gnutls in slackware64-13.37
it only applies to Slackware64-Current

VisionIncision 07-23-2012 11:04 AM

Quote:

Originally Posted by willysr (Post 4735934)
please show me the mirror site you uncommented in /etc/slackpkg/mirrors
because there are no updates about libffi and gnutls in slackware64-13.37
it only applies to Slackware64-Current

Hi, i can't show you now as I am reinstalling. However, it turned out that I did enable the current mirror, and I did seriously screw my system up. Thanks for the help though.

VisionIncision 07-23-2012 11:32 AM

Ok, just an update, I have reinstalled my system, kept my /home so its just a case of reinstalling my software now. Thanks for the responses, and I shall be sure not to enable an incorrect mirror this time.

Regards,
Jack Hunt


All times are GMT -5. The time now is 01:06 AM.