Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 06-12-2005, 11:56 PM   #1
Registered: Jan 2004
Posts: 131

Rep: Reputation: 15
gnome terminal, default browser?

I use gnome-terminal as my default terminal, and firefox as my browser, how can I make it so when i click on a link in a gnome-terminal it will open in firefox? Right now when i click on something it says that it cant open the browser..
Old 06-13-2005, 02:05 AM   #2
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 295

Rep: Reputation: 31
in your home directory edit the hidden file .bash_profile
export BROWSER=/usr/bin/firefox
and now firefox is your default browser. when you klick on a link it will be opened with it, but in gnome-terminal always uses epiphany, I don't know why
there you right klick on the link and choose open or copy link address. If u use copy link address u can paste it in already opened firefox and use it.
Old 06-19-2005, 06:10 PM   #3
Senior Member
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
I assume you've already checked that firefox is the default browser?

if not: Start Here -> Desktop Preferences -> Advanced -> Preferred Applications.

hth --Jonas
Old 07-21-2012, 11:36 PM   #4
LQ Newbie
Registered: Apr 2006
Posts: 2

Rep: Reputation: 0
Gnome-terminal still ignoring specified defaults

Moved /usr/bin/epiphany to /usr/bin/epiphany.old and /usr/bin/epiphany-browser to /usr/bin/epiphany-browser.old, replaced originals with softlinks to /usr/bin/google-chrome, seems to work fine now; though setting the default browser in half a dozen ways and locations hadn't. Bound to be some undesirable side-effects, but hey-ho.

reverted those moves and got rid of the softlinks, in my case the issue was illuminated by this:~

turned out google-chromium.desktop only existed in /opt rather than /usr/share/applications/ , linking it in there along with all the other fixes setting default browser to google-chrome.desktop did the trick. No more getting shocked by epiphanies.

Last edited by chadlongstaff; 07-21-2012 at 11:52 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
change default bash directory in gnome-terminal ming0 Linux - Software 5 10-01-2009 07:54 PM
gnome-terminal default geometry dunric Linux - Software 1 11-09-2005 03:02 AM
how to set gnome-terminal to open in full screen by default ankur_linuxfan Linux - Software 0 01-18-2005 06:45 AM
how to change default browser in Gnome? Lleb_KCir Linux - General 6 03-30-2004 04:30 PM
How can I modify the default configuration of gnome-terminalīs in RH 7.1 Coltrane Linux - Newbie 1 09-20-2001 03:04 AM

All times are GMT -5. The time now is 02:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration