Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 03-08-2005, 09:55 PM   #1
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Rep: Reputation: 30
Gnome-settings-daemon failed

On my old PIII, I've got X configured for a few different users. It's been working fine up untill today. And just this afternoon, someone, who uses gnome, tried to log on, and the gnome-settings-daemon failed. It just pops up with a window that says that when gnome tries to start. The program tries to restart itself again and again but it doesn't help anything. I've tried reinstalling a few packages, but it hasn't helped so far. What package is gnome-settings-daemon in? What do I need to reinstall, or what do I need to tweak to fix this?

-Thanks in advance.
Old 03-09-2005, 04:35 AM   #2
Registered: Aug 2003
Location: Germany
Distribution: Frugalware (everywhere), Ubuntu (notebook only), Tomato (router)
Posts: 73

Rep: Reputation: 15
Hi slackwarefan,

I can't help much, 'cause I use KDE, but had some kind of similar problem yesterday. If this occurs to just one user, you should perhaps check permissions and ownerships of his home directory - I had managed anyhow to pass the ownership of my home dir to root and therefore hat no writing possibilites to my own home dir - which resulted in KDE refusing to start.

Maybe I could help a little.


Old 03-09-2005, 05:58 AM   #3
Senior Member
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
check you $HOME/.gnome2 folders.. this usually indicates the control-center isn't able to do it's startup routine.
Old 03-09-2005, 07:30 AM   #4
LQ Newbie
Registered: Nov 2003
Posts: 24

Rep: Reputation: 4
If you want to have some more informations when that
kind of problem arise, here how I do:

In root, init 3
edit /etc/X11/xorg.conf and add in the section:

Section "ServerFlags"
Option "DisableVidModeExtension" "false"
Option "DontZoom" "false"
Option "DisableModInDev" "false"
Option "HandleSpecialKeys" "Always"

This will give you the function to return to a text console.

Log as a normal user in console 1 ( the one when you press
<ALT><F1> )
cp /etc/X11/xinit/xinitrc.gnome ~/.xinitrc

When the X start and when you see some graphics appear,
go to the console 1 ( <CTRL><ALT><F1> )

Check for the debug messages...


PS: Check to see if you have a process gnome-session running
even if the X is not active. ( init 3 )


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome-panel, nautilus and gnome settings daemon Fail on Startup hitman_et Linux - General 0 04-01-2005 10:06 PM
gnome-settings-daemon quits slackwarefan Slackware 2 03-21-2005 08:07 PM
Gnome Settings Daemon prob RedFox314 Slackware - Installation 2 02-17-2005 04:11 AM
gnome settings daemon b0uncer Linux - Software 1 10-05-2003 05:33 AM
Daemon Settings Failed At Startup!!!!!!!! kDwosk Linux - Newbie 2 08-22-2003 06:46 PM

All times are GMT -5. The time now is 05:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration