LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-15-2003, 02:34 PM   #1
LSD
Member
 
Registered: Jan 2003
Location: Northam, W.A., Australia
Distribution: Gentoo ~x86
Posts: 321

Rep: Reputation: 30
GNOME installed, still have a few problems.


After 2 months of downloading, compiling and reformatting I now have GNOME 2.1.90 installed to a point that I'm fairly happy with. Theres still a few rough edges though and I'd really like to get these sorted out so I'd appreciate any help you can give.

First up, Nautilus insists on covering my desktop background with a drab shade of grey. I can see the background momentarily when I close apps but when the desktop refreshes afterward the grey returns completely. Any ideas as to what may be causing this?

Secondly, the gnome-theme-manager refuses to work, crashing with a seg fault every time it's called. Should I rebuild/reinstall the package that installed this or is something else wrong?

Lastly, the GNOME mixer applet in the top right panel doesn't have a proper icon, just an IE-style red X, even though I've installed the gnome-icon package. Again, should I recompile/reinstall the package (I noticed that the Volume Control applet has an icon in all the menu so it seems that one exists for it but it just isn't showing up in the panel applet) or is there a problem elsewhere?

Once again, any help would be greatly appreciated.
 
Old 01-15-2003, 09:36 PM   #2
RRepster
Member
 
Registered: Dec 2002
Location: aksarben
Distribution: Several
Posts: 117

Rep: Reputation: 15
I d/loaded and use Dropline Gnome very fast and very easy setup. (Gorgeous too Gnome looks awesome it just doesn't automatically add icons to programs I install like KDE3 does)

I know this isn't direct help to your question but its a suggestion if you don't want to do a recompile of your current gnome setup.

Rob
 
Old 01-16-2003, 11:07 AM   #3
LSD
Member
 
Registered: Jan 2003
Location: Northam, W.A., Australia
Distribution: Gentoo ~x86
Posts: 321

Original Poster
Rep: Reputation: 30
I tried Dropline GNOME once but it didn't really agree with my system, I kept getting graphical glitches, particularly in the menus.

I think I have the problem with gnome-theme-manager worked out: It seems to be caused by my use of Sawfish as a WM instead of the default Metacity. Switching back to Metacity and restarting GNOME solved that problem. Since switching back to Metacity isn't an option (it's too bland and ugly) I think I'll just have to put up with this one.

Now if only I can get the other two problems, particularly the nautilus desktop background craziness, worked out...

edit: Here is a screenshot. In the top right you can see the red X where the mixer icon is supposed to be and the grey Nautilus background.

edit2: Solved the Nautilus craziness. It was a simple matter of compile version 2.1.91 (I had 2.1.6 installed previously). That leaves only the volume control issue. Any ideas?

Last edited by LSD; 01-16-2003 at 12:50 PM.
 
Old 01-18-2003, 11:18 PM   #4
LSD
Member
 
Registered: Jan 2003
Location: Northam, W.A., Australia
Distribution: Gentoo ~x86
Posts: 321

Original Poster
Rep: Reputation: 30
Using Sawfish instead of Metacity is causing a few more problems than I thought. Along with the Theme Manager, I've discovered that the "Show Desktop" button on the taskbar doesn't work (it gives the signal but sawfish doesn't appear to accept it) and several of the options in the "Desktop Preferences" don't work while Sawfish is running (Although much of the same functionality is replicated by the Sawfish capplet so it isn't show stopping, just annoying). My question is: Is there any way I can get Sawfish to integrate properly into GNOME 2? I really, really, really don't like Metacity but these integration issues that sawfish appears to have are driving me insane.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I installed Afterstep, now how can I Use it instead of Gnome? Jengo Ubuntu 3 03-25-2006 05:16 PM
Installed Slack 10.1 Fine | Please help with kde and gnome problems ComputerGeek Slackware 6 05-11-2005 03:33 PM
How can Kognition be installed to GNOME? jiapei100 Linux - Software 2 03-14-2005 09:42 AM
Just installed Dropline Gnome and .. etillman Slackware 2 06-05-2004 08:09 PM
Need help... installed new XFree and now GNOME doesn't come up... RAndreoni Linux - Newbie 1 02-07-2002 06:57 PM


All times are GMT -5. The time now is 04:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration