LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Gnokii doesn't work with Nokia 6021 and Nokia 6300 (http://www.linuxquestions.org/questions/slackware-14/gnokii-doesnt-work-with-nokia-6021-and-nokia-6300-a-746590/)

w1k0 08-10-2009 08:32 PM

[SOLVED] Gnokii doesn't work with Nokia 6021 and Nokia 6300
 
Gnokii doesn't work with Nokia 6021 and Nokia 6300

I can't establish Bluetooth connection between the computer with Slackware 12.2 and two mobiles phones -- Nokia 6021 and Nokia 6300 -- using SlackBuilds version of gnokii. I described my configuration of Bluetooth and gnokii at the end of that post.

The problem

When I run ``gnokii --identify'' command my first mobile asks ``Connect with? BlueZ (0)''. I reply by pressing ``Accept'' key and phone prompts: ``Enter passcode:''. I enter PIN ``1234'' and phone replies: ``Pairing failed''. Phone asks me these questions for the three times and for the three times pairing fails. At the same time gnokii displays the messages:

Code:

Serial device: opening device /dev/rfcomm0
Gnokii serial_open: open: Connection refused
Couldn't open FBUS device: Connection refused
Error in link initialisation: 1

This is the complete record of the session with gnokii:

$ gnokii --identify
Code:

GNOKII Version 0.6.27
LOG: debug mask is 0x1
Config read from file /root/.gnokiirc.
phone instance config:
model = 6510
port = /dev/rfcomm0
connection = serial
initlength = default
serial_baudrate = 19200
serial_write_usleep = -1
handshake = software
require_dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Connecting
Serial device: opening device /dev/rfcomm0
Gnokii serial_open: open: Connection refused
Couldn't open FBUS device: Connection refused
Error in link initialisation: 1
Serial device: opening device /dev/rfcomm0
Gnokii serial_open: open: Connection refused
Couldn't open FBUS device: Connection refused
Error in link initialisation: 1
Serial device: opening device /dev/rfcomm0
Gnokii serial_open: open: Connection refused
Couldn't open FBUS device: Connection refused
Error in link initialisation: 1
Telephone interface init failed: Command failed.
Quitting.
Command failed.

Fake solutions

I asked Google for the phrase: ``Couldn't open FBUS device: Connection refused''. There are three replies: one with ``FBUS'' word and two with ``PHONET'' word instead:

1. That link: http://pastebin.com/pastebin.php?dl=m5700485d is not available.

2. Here http://ubuntuforums.org/archive/index.php/t-487059.html is solved thread concerning similar problem. The original poster declares that he resolved the problem removing pairing on the device.

I replaced in /etc/bluetooth/hcid.conf entry:

Code:

        pairing multi;
by entry:

Code:

        pairing none;
and restarted /etc/rc.d/rc.bluetooth but the result was the same.

3. Here http://www.nabble.com/pin-help-td8844393.html I found the link to http://wiki.gnokii.org/index.php/Bluetooth. Unfortunately that last page concerns Ubuntu (there isn't pin_helper /usr/bin/bluez-pin in Slackware).

Finally I replaced in /etc/bluetooth/hcid.conf entry:

Code:

        security user;
by entry:

Code:

        security none;
and restarted /etc/rc.d/rc.bluetooth.

In result after running ``gnokii --identify'' mobile phone still asks about passcode, it accepts every passcode, it displays for the long time the message ``Pairing with BlueZ (0)'', and finally displays two messages: ``Pairing failed'' and ``Bluetooth connection failed''. At the same time gnokii displays a lot of messages about errors:

$ gnokii --identify
Code:

GNOKII Version 0.6.27
LOG: debug mask is 0x1
Config read from file /root/.gnokiirc.
phone instance config:
model = 6510
port = /dev/rfcomm0
connection = serial
initlength = default
serial_baudrate = 19200
serial_write_usleep = -1
handshake = software
require_dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Connecting
Serial device: opening device /dev/rfcomm0
Serial device: setting speed to 115200
Serial device: setting RTS to low and DTR to low
Serial write: write error 5
Serial write: write error 5
Serial write: write error 5
Serial write: write error 5
Serial write: write error 5
.
.
.
Serial write: write error 5
Serial write: write error 5
Serial write: write error 5
Serial write: write error 5
Serial write: write error 5
Getting model...
Message sent: 0x1b / 0x0006
00 01 00 07 01 00                              |               
Serial write: write error 5
SM_Block: exiting the retry loop
Message sent: 0x1b / 0x0006
00 01 00 07 01 00                              |               
Serial write: write error 5
SM_Block: exiting the retry loop
Message sent: 0x1b / 0x0006
00 01 00 07 01 00                              |               
Serial write: write error 5
^C

During my tests I tried differet ports: /dev/rfcomm0, /dev/rfcomm1, DE:AF:AB:BE:BE:AD, and DE:AD:BA:BE:AB:ED; different models: AT, 6510, and any other mentioned in .gnokiirc; and different connection's types: serial and bluetooth. The results were similar: no connection between the machine and the mobile phone.

At the moment I can only send some files to both these mobile phones using kbtobexclient. Three applications -- kbluemon, kinputwizard and kbluelock -- display the same crash handler: ``The application KBlueMon (kbluemon) crashed and caused the signal 6 (SIGABRT)''. Application kioobex_start displays two messages: ``The process for the bluetooth protocol died unexpectedly'' and then ``No working Bluetooth adapter found''.

Question

So my question is: How to establish connection between the computer and the mobile phone using gnokii? Every assistance will be welcomed.

Bluetooth and gnokii configuration

At the beginning I customized Bluetooth configuration:

1. First I checked both mobile phones Bluetooth addresses:

$ hcitool scan
Code:

Scanning ...
        DE:AF:AB:BE:BE:AD      Nokia 6021
        DE:AD:BA:BE:AB:ED      Nokia 6300

2. Next I added in /etc/bluetooth/rfcomm.conf two sections for both these mobile phones:

$ cat /etc/bluetooth/rfcomm.conf
Code:

rfcomm0 {
    bind yes;
    device DE:AF:AB:BE:BE:AD;
    channel 1;
    comment "Nokia 6021";
}

rfcomm1 {
    bind yes;
    device DE:AD:BA:BE:AB:ED;
    channel 1;
    comment "Nokia 6300";
}

3. Then I performed cosmetic changes in /etc/bluetooth/hcid.conf (I set passkey for incoming connections and I modified local device name):

$ diff /etc/bluetooth/hcid.conf.old /etc/bluetooth/hcid.conf
Code:

24c24
<      passkey "BlueZ";
---
>      passkey "12345678";
32c32
<      name "BlueZ (%d)";
---
>      name "BlueZ (%h %d)";

4. Afterwards I prepared /etc/bluetooth/passkeys/default with the PIN for outgoing connections:

$ cat /etc/bluetooth/passkeys/default
Code:

1234
At that moment I restarted Bluetooth:

$ /etc/rc.d/rc.bluetooth restart
Code:

Stopping Bluetooth subsystem:  pand dund rfcomm hidd hcid.
Starting Bluetooth subsystem:  hcid sdp rfcomm passkeys.

Finally I compiled and installed gnokii from SlackBuilds and customized ~/.gnokiirc:

1. At the beginning of the section [global] I commented /dev/ttyS0 device and added a few entries for useful devices:

Code:

# port = /dev/ttyS0
port = /dev/rfcomm0
# port = /dev/rfcomm1
# port = DE:AF:AB:BE:BE:AD
# port = DE:AD:BA:BE:AB:ED

2. Just below the entry for model 6510 I added the entry for model AT.

Code:

model = 6510
# model = AT

3. Just below the entry for serial type connection I added the entry for bluetooth type connection:

Code:

connection = serial
# connection = bluetooth

4. At the end of that file I added two sections for both mobile phones:

Code:

[phone_6021]
port = /dev/rfcomm0
# port = DE:AF:AB:BE:BE:AD
model = 6510
connection = serial
 
[phone_6300]
port = /dev/rfcomm1
# port = DE:AD:BA:BE:AB:ED
model = 6510
connection = serial


MS3FGX 08-10-2009 09:29 PM

The first thing I am not too clear on here is if you have managed to get the phones to pair with the machine in the first place. Gnokii doesn't have to do the pairing on it's own, and it would help diagnose the problem if you took it out of the equation for the time being. You should also put the configuration files back to the defaults as well, you shouldn't need to make any changes to hcid.conf (outside of changing name and PIN); and when you get to the point that Gnokii is working properly, it should be able to setup it's own RFCOMM links rather than you having to make manual ones.

The easiest way to attempt a pair would be to run a command like:

Code:

obexftp -b DE:AF:AB:BE:BE:AD -l
This would attempt to pull down a file listing from the phone, which would trigger the pairing process if it hasn't been successfully completed already. Since the computer will be the initiating party on this pair, the PIN would be the one you setup in hcid.conf, which means you don't need to setup a default PIN under /passkeys/default.

If you can get that working, then the problem is in the Gnokii configuration; otherwise you are having a core problem with BlueZ.

Assuming obexftp works, try configuring Gnokii to use the Bluetooth MAC directly, rather than an RFCOMM device node:

Code:

[phone_6021]
port = DE:AF:AB:BE:BE:AD
model = 6021
connection = bluetooth

Using AT mode only provides basic functionality, whereas using the specific phone model in non-AT mode lets Gnokii know about any additional functions or features your phone supports. Manually configuring RFCOMM in rfcomm.conf/gnokiirc is only necessary when Gnokii has been built without native Bluetooth support, which obviously isn't the case here. Since you built Gnokii with Bluetooth support, it can handle the creation and management of the RFCOMM bindings on it's own.

w1k0 08-11-2009 12:37 PM

I performed the tests described in the first post using both mobile phones -- Nokia 6021 and Nokia 6300.

In the first mobile phone's ``Bluetooth | Paired devices'' menu there are registered both the computer and the second mobile phone:

Code:

BlueZ (0)
Nokia 6300

In the second mobile phone's ``Bluetooth | Paired devices'' menu there is registered only the first mobile phone:

Code:

Nokia 6021
Despite of it during the tests described in the first post the second mobile phone behaves exactly the same as the first mobile phone.

So I restored default /etc/bluetooth/hcid.conf configuration (I only changed passkey ``Bluez'' to ``1234'') and I removed /etc/bluetooth/passkeys/default file according to your suggestions.

Then I tried to pair the second mobile phone and the computer:

$ obexftp -b DE:AD:BA:BE:AB:ED -l
Code:

Browsing DE:AD:BA:BE:AB:ED ...
Connecting...failed: connect
The user may have rejected the transfer: Connection refused

My second mobile phone asked ``Exchange data with? BlueZ (0)''. I replied by pressing ``Accept'' key and phone prompted: ``Enter passcode:''. I entered PIN ``1234'' and phone replied: ``Pairing failed'', and then: ``Bluetooth connection failed''.

Just for comparison I performed the same test using the first mobile phone:

$ obexftp -b DE:AF:AB:BE:BE:AD -l
Code:

Browsing DE:AF:AB:BE:BE:AD ...
Connecting...failed: connect
The user may have rejected the transfer: Connection refused

The results were exactly the same.

You wrote: ``Since the computer will be the initiating party on this pair, the PIN would be the one you setup in hcid.conf''. I'm not sure that's true. According to the comment in /etc/bluetooth/hcid.conf the PIN number stored in that file is: `` Default PIN code for incoming connections''. So in my opinion it's the PIN number to accept the connections from the mobile phone to the computer (used on the side of the computer).

Despite of it I used that PIN number in the above tests -- results were always negative. I tried to enter empty PIN but both these mobile phones don't accept it.

Then I modified ~/.gnokiirc according to your suggestions:

Code:

[phone_6021]
# port = /dev/rfcomm0
port =  DE:AF:AB:BE:BE:AD
model = 6021
connection = bluetooth

[phone_6300]
# port = /dev/rfcomm1
port =  DE:AD:BA:BE:AB:ED
model = 6300
connection = bluetooth

Next I tried to identify the first mobile phone:

$ gnokii --phone 6021 --identify
Code:

.
.
.
Connecting
Serial device: opening device  DE:AF:AB:BE:BE:AD
Channel: 14
Channel: 14
Using channel: 14
Can't connect: Connection refused
Couldn't open PHONET device: Connection refused
Error in link initialisation: 1
Telephone interface init failed: Command failed.
Quitting.
Command failed.

The results were similar as described in the first post though instead of: ``Couldn't open FBUS device'' gnokii replied: ``Couldn't open PHONET device''.

At the end I tried model AT. The results were different but still negative:

$ gnokii --phone 6021 --identify
Code:

.
.
.
Initializing AT capable mobile phone ...
Serial device: opening device DE:AF:AB:BE:BE:AD
Channel: 0
Channel: 3
Using channel: 3
Can't connect: Connection refused
AT bus initialization failed (1)
Initialization failed (1)
Serial device: closing device
Telephone interface init failed: Command failed.
Quitting.
Command failed.

I'm wondering why both these mobile phones ask me still about the passcode. I removed /etc/bluetooth/passkeys/default file and restarted /etc/rc.d/rc.bluetooth.

As I reported in the first post I can send some files to both these mobile phones using kbtobexclient. So Bluetooth works in the computer and in the mobile phones. There is only some problem with BlueZ or with gnokii.

w1k0 08-11-2009 02:38 PM

During further tests I modified three options in /etc/bluetooth/hcid.conf:

Code:

        security none;
        pairing none;
        passkey "1234";

Then I tried to identify the first mobile phone:

$ gnokii --phone 6021 --identify
Code:

GNOKII Version 0.6.27
LOG: debug mask is 0x1
Config read from file /root/.gnokiirc.
phone instance config:
model = 6021
port = DE:AF:AB:BE:BE:AD
connection = bluetooth
initlength = default
serial_baudrate = 19200
serial_write_usleep = -1
handshake = software
require_dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Connecting
Serial device: opening device DE:AF:AB:BE:BE:AD
Channel: 14
Channel: 14
Using channel: 14
Can't connect: Operation now in progress
Couldn't open PHONET device: Operation now in progress
Error in link initialisation: 1
Telephone interface init failed: Command failed.
Quitting.
Command failed.

In result I got the new message: ``Couldn't open PHONET device: Operation now in progress''. Using it I found that page: http://www.nabble.com/Connection-pro...d14984889.html. I read on it that suggestion:

Quote:

Yes, this did not have anything to do with gnokii as such. I found the solution: it was necessary to update obex to a more recent version.
So I downloaded ObexFTP 0.23 using that site: http://dev.zuckschwerdt.org/openobex/wiki/ObexDownloads and next I compiled and installed it.

Then I tried to pair the computer and the second mobile phone:

$ obexftp -b DE:AD:BA:BE:AB:ED -l
Code:

Browsing DE:AD:BA:BE:AB:ED ...
Connecting...failed: connect
Interupted/bad reception or the device moved out of range: Operation now in progress
Still trying to connect
Connecting...failed: connect
error on connect(): Device or resource busy
Still trying to connect
Connecting...failed: connect
error on connect(): Device or resource busy
Still trying to connect

My second mobile phone asked ``Connect with? BlueZ (0)''. I replied by pressing ``Accept'' key and phone prompted: ``Enter passcode:''. I entered PIN ``1234'' and phone displayed for a long time the message: ``Pairing with BlueZ (0)'' next replied: ``Pairing failed'', and then: ``Bluetooth connection failed''.

Pairing failed once again but I got consecutive message: ``Interupted/bad reception or the device moved out of range: Operation now in progress''. I found it on two pages. Here is an unanswered question: http://www.linuxquestions.org/questi...-error-697422/. Here is some discussion of the problem: http://forum.mandriva.com/viewtopic....e9c74b92112f62.

According to the suggestions I wrote PIN ``1234'' to /etc/bluetooth/pin, and I tried ObexFTP with new set of parameters:

$ obexftp -scan
Code:

obexftp: invalid option -- s
Try `obexftp --help' for more information.
Scanning for (null) ...
Found:  DE:AD:BA:BE:AB:ED
Browsing DE:AD:BA:BE:AB:ED ...
Connecting...failed: connect
Interupted/bad reception or the device moved out of range: Operation now in progress
Still trying to connect
Connecting...failed: connect
error on connect(): Device or resource busy
Still trying to connect
Connecting...failed: connect
error on connect(): Device or resource busy
Still trying to connect

My second mobile phone asked ``Exchange data with? BlueZ (0)''. I replied by pressing ``Accept'' key and phone prompted: ``Enter passcode:''. I entered PIN ``1234'' and phone displayed for a long time the message: ``Pairing with BlueZ (0)'' next replied: ``Pairing failed'', and then: ``Bluetooth connection failed''.

In that case the computer found the second mobile phone but pairing failed as before.

The command obexftp -scan recognizes different devices after consecutive activations: my first mobile, my second mobile, or my neighbor's mobile. In two first cases pairing fails -- in the third case I simply abort the program's execution.

The more I explore that problem the less I know. When I change different options I see different error messages. I try to follow them but all advices fail. When ``security’’ option is on pairing fails immediately. When it’s off mobile tries to pair with BlueZ for a long time but finally pairing fails. Both phones ask me about PIN independently of the setting of ``security’’ option.

MS3FGX 08-11-2009 05:15 PM

You are getting way ahead of yourself here. If you are not able to pair the device with obexftp, then Gnokii will never work. There is no point in trying different combinations of options and configurations for Gnokii, since you don't even have basic Bluetooth working.

First of all, you should not be disabling pairing in hcid.conf; devices will never be able to connect with the settings you are using. You are changing a lot of files and doing a lot of different things that are only getting you farther away from getting this to work. You really need to start with a clean slate, if you ever want to get this working properly.

Uninstall the bluez-utils and bluez-libs packages, then delete everything under /etc/bluetooth and /var/lib/bluetooth. Simply removing the packages will not delete all of the BlueZ configuration and associated device information, you must delete those two directories manually. Delete the pairing information from your phone, and then reinstall bluez-utils and bluez-libs. This will put both the phone and the computer back to their absolute default states, as if they were never before connected.

Open /etc/bluetooth/hcid.conf and change only the PIN and device name. Change the incoming PIN to 1234, and change the device name to simply "BlueZ". No other modifications are required or should be made. Then restart Bluez with "/etc/rc.d/rc.bluetooth restart".

Now search for Bluetooth devices from your phone. "BlueZ" should come up on the list, select it and enter "1234" for the PIN. If this fails, then nothing else you do will work. If you can't pair, then check the system error logs and see if they mention anything about the various Bluetooth daemons. If you were able to pair, then you can try and run Gnokii with the configuration I suggested above.

w1k0 08-11-2009 08:07 PM

I did everything as you suggested in the first four paragraphs: I restored default system settings and removed pairing information from both phones. Now I have the problem with the fifth paragraph.

Nokia 6021 discovers two devices:
BlueZ -- my machine
6300 -- my second phone

Nokia 6300 discovers two devices:
BlueZ -- my machine
S5230 -- my neighbor's phone

As a matter of fact I couldn't establish pairing with 6021 using 6300 but I could establish pairing with 6300 using 6021 so I paired both these devices. During that process 6300 asked me about the passcode and I entered ``12'' (any value). Then 6021 asked me about the passcode and I entered ``12'' once again.

Then I tried to establish pairing with the computer (BlueZ) using both these phones. The phone asked me about the passcode, I entered ``1234'', and the phone replied ``Pairing failed''.

As I suppose the phone expects to get the same passcode from the computer but it doesn't get it for some reason.

***

Here: http://www.csl.sri.com/users/rushby/bluetooth I found an interesting article about connecting laptop to the mobile phone. John Rushby, the author of that text, wrote it in 2003 and updated in 2008.

Here's the fragment from the old version:

Quote:

At some point, you'll need to establish "pairing" between your computer and the phone. You can try to provoke the phone into initiating pairing by digging around in its menus (it should detect a device called Bluez (0) ) but I've not found this to work because the laptop isn't in a mode to confirm the pin. So just proceed, but keep an eye on the phone in case it pops up with a question about pairing and requests a pin, in which case you'll need to type in the one from your /etc/bluetooth/givepin. Once they've paired successfully the devices seem to remember each other and don't need to do it again.
A mention about /etc/bluetooth/givepin file refers to the paragraphs about the configuration and seems to be outdated. The fragment telling: ``You can try to provoke the phone into initiating pairing by digging around in its menus (it should detect a device called Bluez (0) ) but I've not found this to work because the laptop isn't in a mode to confirm the pin'' seems to confirm my presumptions.

Here's the fragment from the new version:

Quote:

Recent Linuxes use a "dbus" protocol to communicate among components and for Bluetooth pairing we need a pin agent that knows about this. The old givepin and discovto 0 method for supplying a pairing pin doesn't know about dbus and works (if at all) only when the phone is able to initiate the pairing. The R520m can do this, but the T439 cannot. Instead, the pppd invocation above initiates pairing from the computer and the phone asks you to enter the pin--and nothing you enter will work.
The Bluez pin agent for dbus is called passkey-agent but, unfortunately, it is not included with the Eee (nor most other distributions)--the source is there, but not a compiled binary. To compile it yourself, you need the dbus development libraries. I got a suitable binary from somewhere and I've put a copy here. Download that file and put it in a directory like /usr/sbin and make it executable and do a rehash. Then, before you call pppd do
passkey-agent --default 1234 &
When the phone asks you for the pin, type in 1234 and you should be in business. Kill passkey-agent afterward. You only need to do this once to set up pairing. If you are having trouble, try deleting the subdirectories of /var/lib/bluetooth as a lot of stuff is cached there and you may be fighting data from previous attempts.
So I downloaded the above executable of passkey-agent but it didn't work. Here's the explanation of that its behavior:

$ ./passkey-agent --default 1234
Code:

Can't register passkey agent
A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.bluez.Security" member "RegisterDefaultPasskeyAgent" error name "(unset)" destination "org.bluez")
process 5641: Applications must not close shared connections - see dbus_connection_close() docs. This is a bug in the application.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted

I suppose there’s something wrong with that executable.

Here: http://bugs.archlinux.org/task/4930 I found next interesting information:

Quote:

bluez changed the pin_helper concept in the last release. If pairing with a device requires a PIN, then it will send a dbus-message. Unfortunately, there are currently no dbus helpers compatible with the new bluez dbus API.
There is a small program called passkey-agent in the bluez-utils source, which solves this problem. If you call "passkey-agent --default <pin>" just before the pairing attempt, it will use the right pin.
This program is built with bluez-utils, but make install ignores it.
I downloaded bluez-utils 3.36 and I found passkey-agent.c in test directory. Unfortunately after the compilation of the package that tiny program remains uncompiled and I have no idea how can I compile it manually.

***

How can I compile passkey-agent or how can I initialize pairing using the computer?

w1k0 08-11-2009 08:38 PM

A minute ago I changed security option in /etc/bluetooth/hcid.conf to:

Code:

      security auto;
Then I tried to pair both mobiles with the machine. Successfully! In the past I tried that setting too but apparently there were other configuration's issues.

So I solved the first part of the problem: pairing devices.

w1k0 08-11-2009 08:48 PM

Finally I managed to identify both phones using gnokii:

$ gnokii --phone 6021 --identify
Code:

GNOKII Version 0.6.27
LOG: debug mask is 0x1
Config read from file /root/.gnokiirc.
phone instance config:
model = 6021
port = DE:AF:AB:BE:BE:AD
connection = bluetooth
initlength = default
serial_baudrate = 19200
serial_write_usleep = -1
handshake = software
require_dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Connecting
Serial device: opening device DE:AF:AB:BE:BE:AD
Channel: 14
Channel: 14
Using channel: 14
Getting model...
.
.
.
Received model RM-94
IMEI        : 602160216021602
Manufacturer : Nokia
Found model "RM-94"
Model        : 6021
Product name : RM-94
Revision    : V 04.10
Serial device: closing device

$ gnokii --phone 6300 --identify
Code:

GNOKII Version 0.6.27
LOG: debug mask is 0x1
Config read from file /root/.gnokiirc.
phone instance config:
model = 6300
port = DE:AD:BA:BE:AB:ED
connection = bluetooth
initlength = default
serial_baudrate = 19200
serial_write_usleep = -1
handshake = software
require_dcd = 0
smsc_timeout = 10
rfcomm_channel = 0
sm_retry = 0
Connecting
Serial device: opening device DE:AD:BA:BE:AB:ED
Channel: 14
Channel: 14
Using channel: 14
Getting model...
.
.
.
Received model RM-217
IMEI        : 630063006300630
Manufacturer : Nokia
Found model "RM-217"
Model        : 6300
Product name : RM-217
Revision    : V 07.21
Serial device: closing device

The problem is solved. Thank you MS3FGX for your kind assistance!

w1k0 08-13-2009 12:47 PM

I just tested both gnokii and Gammu. Gammu is much better than gnokii.

Gnokii gets and writes phonebook replacing UTF-8 characters by ?.

Gammu backups and restores phonebook taking into consideration UTF-8.

Gnokii gets SMSes but sometimes cuts its contents and sometimes finds some strange messages:

Code:

21. Inbox Message (Unknown)
Date/time: 45/104/2040 85:43:98
Sender: 1347964643837393033323039303335*7331347 Msg Center:
Text:
???????????.???????????.?????????????.?????????????????.????????

or:

Code:

26. Inbox Message (Unknown)
Date/time: 16/07/2009 21:31:36 +0200
Sender: +48601231420 Msg Center:
Linked:
Linked (1/2):
@C@hP,-@$@@o@?@5@R?@u@@@7@R@$?@e@Lš2@Z@$@ @P$?@:@d?@h@8@@!@R(?@a@

Moreover in the case of my mobile phone gnokii is unable to get SMSes from ``Sent items''.

Gammu gets SMSes from ``Sent items'' and ``Inbox'' in a proper way.

Both programs don't recognize UFT-8 in stored messages.

Both gnokii and Gammu send SMSes in a proper way and get and put files on the memory card without problems.

So Gammu is better if you use in phonebook UTF-8 and more reliable when storing SMSes.


All times are GMT -5. The time now is 08:16 AM.