LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2007, 03:55 PM   #1
deftone`
Member
 
Registered: Dec 2005
Location: Sofia, Bulgaria
Distribution: Arch
Posts: 40

Rep: Reputation: 15
GLX (radeon) + VIA 8237: Sound problems1


Hi,
I've been having this problem for some time:
when changing the volume, scrolling text, moving windows, and on various other actions performed in X,

I get a buzzing sound in the right audio channel.

It's so annoying that it's about to drive me crazy.
I tracked down the problem to OpenGL in X (don't ask how, intuition). So,

when the GLX extension is enabled I get this annoying problem.

When it's disabled the buzz goes away.
This is rather strange in my opinion. I'm not sure how GLX interferes with sound performance...

I'm using:
Slackware 10.2 pretty much upgraded to current
Sound Card: VIA 8273
Video Card: Radeon 9200
Xorg: 6.9.0
Kernel: 2.6.19
ALSA: 1.0.9b

Any idea how I could go around this problem would be appreciated.

Last edited by deftone`; 01-26-2007 at 04:02 PM.
 
Old 04-26-2007, 06:51 AM   #2
xprometeus
Member
 
Registered: Jul 2003
Distribution: Turbo Linux 10D
Posts: 39

Rep: Reputation: 15
I have same problem under Gentoo (2.6.20-ck1) ,but i have
Nvidia FX 5200 ,and VIA 8273 sound card.



00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)


Alsa version 1.0.14rc1
Xorg 7.1
Motherboard: Asus A7V600-X
 
  


Reply

Tags
glx, noise, sound, via


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kubuntu 6.06 No Sound.....VIA 8237 hauger Ubuntu 7 06-07-2006 07:25 PM
Sound problems with via on board sound 8237 Melz_Dark_Angel Linux - Hardware 2 04-06-2006 03:34 AM
VIA 8237 Sound cuts out randomly sw67 Linux - General 6 06-14-2005 07:18 AM
Sound with Quake 3 on VIA 8237 vanquisher Linux - Games 0 02-25-2005 01:00 AM
via 8237 AMD64 getting sound to work /Fedora RacerD Linux - Software 1 07-18-2004 02:08 AM


All times are GMT -5. The time now is 12:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration