LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   GLib-GIO-Message when starting emacs after latest -current update (http://www.linuxquestions.org/questions/slackware-14/glib-gio-message-when-starting-emacs-after-latest-current-update-4175418191/)

TL_CLD 07-23-2012 03:39 AM

GLib-GIO-Message when starting emacs after latest -current update
 
When starting emacs from CLI I now get this:

Code:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
When using emacs -nw the message goes away.

Is this by intention, or a "bug"?

CTM 07-23-2012 12:56 PM

Starting with 23.2, Emacs uses GConf for some features - since GConf is now part of -current proper (it was moved from extra/ to the l/ series yesterday), I assume Emacs is picking up GConf at run time. You can disable Emacs's support for GConf by recompiling with --without-gconf.

edit: it seems it's also because Emacs requires dconf as well as GConf for the feature described in the post below to work correctly, so try installing dconf as an alternative to recompiling with --without-gconf. If it works, maybe dconf needs to be added to Slackware too...

CTM 07-23-2012 01:00 PM

...and playing detective, even though I don't use Emacs:

Code:

      -nw    Tells  Emacs not to use its special interface to X.  If you use
              this switch when invoking Emacs from an xterm(1)  window,  dis-
              play is done in that window.

Emacs uses GConf for its "font-use-system-font" feature, which I assume is only used in conjunction with Emacs's "special interface to X".

TL_CLD 07-24-2012 01:13 AM

I think I'll just wait for an official emacs package without the issue or perhaps Patrick will bring in dconf. :)

CTM 07-25-2012 07:50 AM

Your wish was granted:

Code:

Wed Jul 25 02:02:40 UTC 2012
e/emacs-24.1-x86_64-3.txz:  Rebuilt.
  Don't use GConf.

:)

TL_CLD 07-26-2012 03:32 AM

I'm still getting the message with the latest emacs package. Very odd, as I can see --disable-gconf added to the slackbuild script. Apparently something more is needed to get rid of it.

disturbed1 07-26-2012 08:21 AM

Quote:

Originally Posted by CTM (Post 4736082)
edit: it seems it's also because Emacs requires dconf as well as GConf for the feature described in the post below to work correctly, so try installing dconf as an alternative to recompiling with --without-gconf. If it works, maybe dconf needs to be added to Slackware too...

Any application that spouts
Code:

GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
Is looking for dconf.
http://permalink.gmane.org/gmane.comp.gnome.shell/5897

TL_CLD 07-26-2012 03:51 PM

OK, so I'm guessing we'll see dconf added to -current soon? Or perhaps --disable-dconf can be added to the emacs build script also?

BrZ 07-27-2012 12:19 AM

1 Attachment(s)
No problems here.


edit: sorry, starting from terminal:
Quote:

GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.

BrZ 07-27-2012 07:47 PM

Even after today's update, the message is still here.
Building emacs with "--without-dconf": "configure: WARNING: unrecognized options: --without-dconf"
After compiling dconf, no more error. Seems dconf is a new dependency now =[

GazL 07-28-2012 11:57 AM

"--without-gsettings"

BrZ 07-28-2012 10:31 PM

Thanks GazL, I'll try to build with that option and uninstall dconf. In the mean time, I discovered that if I "export GSETTINGS_BACKEND=memory", emacs start without warning.

BrZ 07-28-2012 11:13 PM

Worked a treat GazL, thanks again.

sanjioh 07-31-2012 02:45 PM

So what do you people think, should we expect emacs to be rebuilt or dconf to be added as a dependency? Or nothing at all?

GazL 07-31-2012 04:27 PM

I expect he'll get around to rebuilding it with '--without-gsettings', as that seemed to be the intent with the last rebuild when he disabled gconf (it just wasn't enough).

Of course, that's just my guess, which is no better than anyone else's.


All times are GMT -5. The time now is 12:52 PM.