LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-11-2005, 12:37 PM   #1
Barx
Member
 
Registered: Jun 2004
Distribution: Slack x86 current
Posts: 128

Rep: Reputation: 16
glapi fallback with ATI drivers


Hi all.

I'm running Slack 10.0, kernel 2.6.8.1 custom, xorg 6.8.1

I installed fglrx 8.8.25 drivers form Ati

I have a notebook with a xp-m 2800+, chipset via KM266, radeon 9200 mobile

After some troubles now I have X running, but without fglrx loaded.

In order:

- the fglrx module is compiled and loaded

- xorg.conf is correctly ( I think ) configured, under device section it loads the "fglrx" driver

But launching

LIBGL_DEBUG=verbose glxinfo

I get

Code:
libGL: XF86DRIGetClientDriverName: 8.8.25 fglrx (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/fglrx_dri.so
drmOpenByBusid: Searching for BusID PCI:1:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports PCI:1:0:0
fglrx: libGL version undetermined - OpenGL module is using glapi fallback
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.1)
Why I'm loading mesa code instead of fglrx?

all libgl.a* and libgl.so* seems to be regular ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 08:52 PM
ATI 9600Pro & ATI Proprietary Drivers problem Hyakutake Slackware 6 12-04-2005 11:08 AM
SuSE 9.1 - ATI Mobility 9600 (M10) - ATi Drivers 3.9.0 Beaviis Linux - Hardware 3 06-04-2004 01:51 PM
Red Hat9 + ATi Drivers + nForce2 Drivers sturreal Linux - Newbie 2 10-07-2003 08:17 AM
procmail fallback mazzo Linux - Newbie 3 06-09-2003 08:52 AM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration