LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-01-2011, 06:06 PM   #1
Lethys
LQ Newbie
 
Registered: Aug 2010
Posts: 9

Rep: Reputation: 0
Glade compile error, could not read symbols: File in wrong format


I'm currently trying to compile glade on slackware 64 current, with multilib enabled. When trying to compile, I get:

Code:
In file included from /usr/include/python2.6/Python.h:8:0,
                 from glade-python.c:27:
/usr/include/python2.6/pyconfig.h:1031:0: warning: "_POSIX_C_SOURCE" redefined
/usr/include/features.h:213:0: note: this is the location of the previous definition
/bin/sh ../../libtool --tag=CC --mode=link gcc  -g -O2   -o libgladepython.la -rpath /usr/local/lib/glade3/modules -module -avoid-version   libgladepython_la-glade-python.lo ../../gladeui/libgladeui-1.la -L/usr/lib -lpython2.6 -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo -lpng14 -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lxml2  
gcc -shared  .libs/libgladepython_la-glade-python.o  -Wl,--rpath -Wl,/home/rick/pkgs/glade3/glade3-3.6.7/gladeui/.libs ../../gladeui/.libs/libgladeui-1.so -L/usr/lib -lpython2.6 /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgio-2.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpangocairo-1.0.so /usr/lib/libgdk_pixbuf-2.0.so -lm /usr/lib/libcairo.so /usr/lib/libpng14.so /usr/lib/libpango-1.0.so /usr/lib/libfreetype.so /usr/lib/libfontconfig.so /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so /usr/lib/libgthread-2.0.so -lrt /usr/lib/libglib-2.0.so /usr/lib/libxml2.so  -pthread -Wl,-soname -Wl,libgladepython.so -o .libs/libgladepython.so
/usr/lib/libgtk-x11-2.0.so: could not read symbols: File in wrong format
The first thing I notice is that its looking in /usr/lib/ instead of /usr/lib64. Up until that point, it seemed to have been using just /usr/lib64, and thus I assume this is the problem. Can't figure out how to fix this, any ideas?

With or without slackbuild, I get the same result.
 
Old 03-03-2011, 11:03 AM   #2
hyperfluid
Member
 
Registered: Aug 2010
Location: /ger/nrw/ac
Distribution: Ubuntu 12.04
Posts: 34

Rep: Reputation: Disabled
Have you tried building the slackbuild with LDFLAGS="-L/usr/lib64 -L/lib64"?
 
1 members found this post helpful.
Old 03-04-2011, 03:55 AM   #3
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 874

Rep: Reputation: 174Reputation: 174
As glade is primarily for use in gnome I assume you have gnome installed so why not just use slapt-get ( or gslapt ) to install it?
 
Old 03-04-2011, 04:40 AM   #4
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 874

Rep: Reputation: 174Reputation: 174
I have noticed that the odd .pc file or generated configure/makefiles seem to ignore the libdir variable and use /usr/lib ( the usual default ) instead of /usr/lib64, as a quick and dirty workaround you can try
Code:
sudo mv /usr/lib /usr/lib.BAK
compile your code and then do
Code:
sudo mv /usr/lib.BAK /usr/lib
You shouldn't have to do this very often its just because of some sloppy written makefiles.
This works with the glad3 slackbuild by the way.
 
0 members found this post helpful.
Old 03-04-2011, 04:51 AM   #5
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
See: http://slackbuilds.org/faq/#multilib

I was going to update my SlackBuild to include that line, but SBo is overloaded with submissions at the moment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 7 64bit /usr/lib/libexpat.so: could not read symbols: File in wrong format GATTACA Fedora 1 06-21-2007 07:47 PM
/usr/lib/libfontconfig.so: could not read symbols: File in wrong format TrekJunky Linux - Newbie 2 10-01-2006 06:05 PM
kdevelop, hello world, /usr/lib/libkdeui.so: could not read symbols: File in wrong fo runlevel: 6 Programming 2 05-04-2005 12:37 AM
How to compile a C program in Glade which is included the <pcap.h> header file. swaviswa Programming 0 03-21-2004 07:47 AM


All times are GMT -5. The time now is 02:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration