-   Slackware (
-   -   Glade compile error, could not read symbols: File in wrong format (

Lethys 01-01-2011 07:06 PM

Glade compile error, could not read symbols: File in wrong format
I'm currently trying to compile glade on slackware 64 current, with multilib enabled. When trying to compile, I get:


In file included from /usr/include/python2.6/Python.h:8:0,
                from glade-python.c:27:
/usr/include/python2.6/pyconfig.h:1031:0: warning: "_POSIX_C_SOURCE" redefined
/usr/include/features.h:213:0: note: this is the location of the previous definition
/bin/sh ../../libtool --tag=CC --mode=link gcc  -g -O2  -o -rpath /usr/local/lib/glade3/modules -module -avoid-version  libgladepython_la-glade-python.lo ../../gladeui/ -L/usr/lib -lpython2.6 -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo -lpng14 -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lxml2 
gcc -shared  .libs/libgladepython_la-glade-python.o  -Wl,--rpath -Wl,/home/rick/pkgs/glade3/glade3-3.6.7/gladeui/.libs ../../gladeui/.libs/ -L/usr/lib -lpython2.6 /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ -lm /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ /usr/lib/ -lrt /usr/lib/ /usr/lib/  -pthread -Wl,-soname -Wl, -o .libs/
/usr/lib/ could not read symbols: File in wrong format

The first thing I notice is that its looking in /usr/lib/ instead of /usr/lib64. Up until that point, it seemed to have been using just /usr/lib64, and thus I assume this is the problem. Can't figure out how to fix this, any ideas?

With or without slackbuild, I get the same result.

hyperfluid 03-03-2011 12:03 PM

Have you tried building the slackbuild with LDFLAGS="-L/usr/lib64 -L/lib64"?

Keith Hedger 03-04-2011 04:55 AM

As glade is primarily for use in gnome I assume you have gnome installed so why not just use slapt-get ( or gslapt ) to install it?

Keith Hedger 03-04-2011 05:40 AM

I have noticed that the odd .pc file or generated configure/makefiles seem to ignore the libdir variable and use /usr/lib ( the usual default ) instead of /usr/lib64, as a quick and dirty workaround you can try

sudo mv /usr/lib /usr/lib.BAK
compile your code and then do

sudo mv /usr/lib.BAK /usr/lib
You shouldn't have to do this very often its just because of some sloppy written makefiles.
This works with the glad3 slackbuild by the way.

piratesmack 03-04-2011 05:51 AM


I was going to update my SlackBuild to include that line, but SBo is overloaded with submissions at the moment.

All times are GMT -5. The time now is 09:16 PM.