LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   GL games under X-Windows problem (http://www.linuxquestions.org/questions/slackware-14/gl-games-under-x-windows-problem-23947/)

joel1 06-21-2002 12:25 AM

GL games under X-Windows problem
 
Well got slackware 8.1 up and running last night! (was a redhat user b4)

Only have one problem (that I haven't solved myself yet, as had a few lol) I installed the nvidia drivers and the linux version of Return to Castle Wolfesntein and they both appear to be working, for some reason the graphics look a lot smoother than they did under redhat too. However it seems to want to run in a window and not full screen????

EXTRA INFO:
I have all the different resolutions and color depths listed in XF86Config.

"1152x864" "1024x768" "800x600" "640x480"

P.S. When I listed in the opposite order it gave me 640x480 on the screen (visible) but of a huge maybe 1152x864 desktop, and I could use the mouse to move the viewing area around this massive desktop???

Aussie 06-21-2002 07:18 AM

There is an option in the RTCW menu for window/full screen.

joel1 06-21-2002 12:36 PM

That is already set to full screen..... :)

Worked it out though, well kinda, found the problem anyway:

It turned out to be the following lines in XF86Config

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# SubSection "extmod"
# Option "omit xfree86-dga" # don't initialise the DGA extension
# EndSubSection

Disabled as they are above RTCW runs much faster and smoother but in a window, even when set to full screen....

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

Enabled as above RTCW will work correctly in full screen as I would expect but the graphics look like they're struggling, shuddering from time to time....

Aussie 06-21-2002 08:22 PM

I load xfree86-dga and RTCW runs full screen. There might something else wrong with your install. Download and run nv_check.sh and remove any conflicting openGL libs that it finds.

joel1 06-22-2002 12:48 AM

Thanks for the link I was looking for that file the other day..... :)

Unfortunately nv_check was unable to find any problems with my system :(

Mike Blick 06-23-2002 12:55 AM

I'm getting the exact same problem.

Mike Blick 06-23-2002 05:26 PM

I got it working. Try going through xf86config 1 more time and be very carefull on your selections. I picked up a few mistakes on mine and after correcting them the game works perfect.

joel1 06-24-2002 01:34 AM

All working now, taking my usb mouse out of its ps/2 converter and setting it back up as USB made a huge difference to shuddering of the graphics. So can enable extmod again and it runs smooth....


All times are GMT -5. The time now is 05:56 PM.