LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Gksu error Slackw14.1 and Mate 1.6 (http://www.linuxquestions.org/questions/slackware-14/gksu-error-slackw14-1-and-mate-1-6-a-4175486570/)

aszabo 12-02-2013 11:41 AM

Gksu error Slackw14.1 and Mate 1.6
 
Hi,

I have installed Slackware 14.1 and Mate 1.6 from mateslackbuilds. Everything works very well so far, except for gksu.
When I run "gksu /usr/sbin/gparted", I get the following error:

Failed to run /usr/sbin/gparted as user root.

Failed to communicate with gksu-run-helper

What can the problem be?

Thanks for the help in advance.

willysr 12-02-2013 12:21 PM

You are right
this is a confirmed bug

Thanks for reporting..

aszabo 12-02-2013 12:53 PM

Not at all. Since I have used Mate on Slackware intensive, every day for more than one year (first Salix and now your packages), I will send you my report of accidental bugs if any occurs.

When could we get its correction?

willysr 12-02-2013 01:32 PM

OK, libgksu has been updated in our repository and git as well
please get the latest libgksu and upgrade to that version

it should fix this problem

aszabo 12-02-2013 03:06 PM

I have upgraded with the new version, but the problem still persists.

willysr 12-02-2013 06:37 PM

My fault.... i didn't properly checked the symlink created

Building a new version now

willysr 12-02-2013 08:17 PM

And it's uploaded now

aszabo 12-03-2013 12:24 AM

Upraded, but neither gksu nor gksudo does work. The problem still existst.

willysr 12-03-2013 02:48 AM

What's your architecture? 32/64 bit?
If you are using 64 bit, can you show the output of
Code:

ls -al /usr/lib/libgksu/

willysr 12-03-2013 03:32 AM

I tested with gksu /usr/sbin/parted since i don't have gparted on my system and it asked for root password here

willysr 12-03-2013 05:10 AM

I think this is a bug which can't be fixed as there's no more development upstream.
I searched for other distributions and they don't plan to fix this either

kikinovak 12-03-2013 05:23 AM

Workaround in the meantime.
  • Open MATE Terminal.
  • 'su' to root.
  • Type 'gparted'.

Alternatively, use good old fdisk.

Cheers,

Niki

willysr 12-03-2013 05:36 AM

it did work on Slackware 14.0
Probably it don't get along well with newer libraries

willysr 12-03-2013 06:41 AM

Done, now added this issue into KNOWN_ISSUES

aszabo 12-03-2013 01:50 PM

Thanks for the help, anyway all other things run well so far.


All times are GMT -5. The time now is 04:46 AM.