LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Ghostscript problem... HELP!!!! (http://www.linuxquestions.org/questions/slackware-14/ghostscript-problem-help-571256/)

tranfuga 07-21-2007 05:49 PM

Ghostscript problem... HELP!!!!
 
Hi:

When trying to use gs, with any kind of parameters, even with no parameters get this:

Esteban@tranfuga:~/Ordenar/Himnario/listo$ /usr/bin/gs
ESP Ghostscript 815.04 (2007-03-14)
Copyright (C) 2004 artofcode LLC, Benicia, CA. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
CRIT: rangecheck in get
Operand stack:
PRIOR.ttf 0

Any have the same problem?
I've reinstalled espgs, remove and install it, install al the font's packages, but nothings seems to work...
Even compilatin from source espgs, get the same error..

I've run out of ideas...
I'm just upgrade to Slackware 12.0, non fresh install....

Thank for any help...
------------------------------------------------------------------------------------------------------------
Solution:
Delete ~/.fonts, ~/.fontconfig and .font.dir of the users directories after upgrade, and it will work... :)

uselpa 07-22-2007 03:54 AM

Set up slackpkg and run it against a mirror. If you forgot to upgrade any packages, they will show up.

tranfuga 07-22-2007 07:46 AM

Doning:
slapt-get --update
slapt-get --upgrade
get no missing packages...
Shoud I try reinstall the sets?

My slaptget-rc:
EXCLUDE=^glibc.*,.*-[0-9]dl$,^devs$,aaa_elflibs,x86_64
SOURCE=http://slackware.osuosl.org/slackware-12.0/
SOURCE=http://software.jaos.org/slackpacks/12.0/
SOURCE=http://www.software-mirror.com/linuxpackages/Slackware-12.0/
SOURCE=http://lp.slackwaresupport.com/Slackware-12.0/
SOURCE=http://mirror.pacific.net.au/linux/slackware/slackware-12.0/

uselpa 07-22-2007 07:52 AM

I don't use slapt-get, I suggest you try "slackpkg update" && "slackpkg upgrade-all".

uselpa 07-22-2007 08:01 AM

Any fonts you've installed in addition to the stock Slackware fonts?

tranfuga 07-22-2007 08:17 AM

I've installed lots of fonts on muy /.fonts/ directory, on my user account... but invoking gs as root get the same error...

tranfuga 07-22-2007 08:23 AM

about slackpkg, installing it, when I try to run slackpkg update get:

awk package not found! Please install awk before you run slackpkg,
as slackpkg cannot function without awk.

but
whereis awk:
awk: /bin/awk /usr/bin/awk /usr/X11R6/bin/awk /usr/bin/X11/awk /usr/X11/bin/awk /usr/libexec/awk /usr/share/awk /usr/man/man1/awk.1.gz /usr/share/man/man1/awk.1.gz /usr/X11/man/man1/awk.1.gz

Any Idea?

Eternal_Newbie 07-22-2007 09:03 AM

Re your slaptget.rc
Quote:

Originally Posted by tranfuga
My slaptget-rc:
EXCLUDE=^glibc.*,.*-[0-9]dl$,^devs$,aaa_elflibs,x86_64
SOURCE=http://slackware.osuosl.org/slackware-12.0/
SOURCE=http://software.jaos.org/slackpacks/12.0/
SOURCE=http://www.software-mirror.com/linuxpackages/Slackware-12.0/
SOURCE=http://lp.slackwaresupport.com/Slackware-12.0/
SOURCE=http://mirror.pacific.net.au/linux/slackware/slackware-12.0/

IMHO, you really should only have one slackware mirror and the slapt-get mirror(jaos.org) in there. If you have sources of 3rd party packages in there you will get official packages getting overwritten and unwanted dependencies introduced. Rather keep the 3rd party mirrors commented out unless you are specifically checking for 3rd party package updates and then download the updates to them manually.

Re Slackpkg: That seems like you have an old version of slackpkg. Are you running slackpkg 2.61?

tranfuga 07-22-2007 09:46 AM

Yes, the slackpkg it's version 2.61...

uselpa 07-22-2007 09:55 AM

What is the output of
Code:

ls -1 /var/log/packages/ | awk  -F - '{print $1}' | uniq -d
?
(attention, the letter after ls is a lowercase L).

tranfuga 07-22-2007 10:03 AM

root@tranfuga:/home/Esteban/Desktop# ls -l /var/log/packages/ | awk -F - '{print $1}' | uniq -d

root@tranfuga:/home/Esteban/Desktop#
whit an L lowercase on ls

uselpa 07-22-2007 10:19 AM

Gosh, I'm so bad at awk... try
Code:

ls -1 /var/log/packages/ | sort | awk  -F '-' '{ printf("%s",$1); for(i=2;i<=(NF-3);i++) {printf("-%s",$i)} printf("\n") }' | uniq -d
And of course the '-1' after ls is a ONE not an L... (best is you just copy paste).

tranfuga 07-22-2007 10:26 AM

in that case:

ls -1 /var/log/packages/ | sort | awk -F '-' '{ printf("%s",$1); for(i=2;i<=(NF-3);i++) {printf("-%s",$i)} printf("\n") }' | uniq -d
get nothing...

but
root@tranfuga:/home/Esteban/Desktop# ls -1 /var/log/packages/ | awk -F - '{print $1}' | uniq -d
alsa
apr
aspell
dbus
font
gcc
gettext
gimp
glibc
hal
k3b
kernel
libwmf
man
net
openssl
poppler
qca
sysvinit
util
xf86
xine
xorg
root@tranfuga:/home/Esteban/Desktop#

uselpa 07-22-2007 10:31 AM

If my awk script doesn't return anything then you don't have duplicate packages. Your script is wrong because there's a lot of packages (namely those you list) where the first field contains hyphens itself.

I'm running out of ideas as well.

tranfuga 07-22-2007 10:52 AM

after make slapt-get --dist-upgrade --remove-obsolete and free almost of 600Mb of installed packages, slackpkg started to work.. now it's downloading tk and tcl as well...
About the gs command, making a google search of that error, get any result except links to the PIOR.ttf font file to donwload. Even I install it on system, but the error persist...
If I compile ESP Ghostscript from sources, get the same error...
May be a bug?
Any one can reproduce the same error?

There is no duplicated packages and theres no packages from 11 version as well..
may be this help
Every time that I reinstall espgs package get the follow error:
cat: libfontconfig.so: No such file or directory
cat: libfontconfig.so.1: No such file or directory

the package is installed and libfontconfig.so and libfontconfig.so.1 exist in /usr/lib
in almost every package that I try to install get the same error


All times are GMT -5. The time now is 09:22 PM.