LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ghostscript 9.05 in current (http://www.linuxquestions.org/questions/slackware-14/ghostscript-9-05-in-current-4175413795/)

polyph 06-28-2012 03:30 AM

ghostscript 9.05 in current
 
I can't find "gstoraster" in ghostscript-9.05-i486-1.txz package,
Is it my mistake?

Thanks

willysr 06-28-2012 03:59 AM

This is what i get when upgrading to ghostscript-9.05
Code:

Removing package /var/log/packages/ghostscript-9.02-i486-2-upgraded-2012-06-28,16:00:55...
  --> Deleting symlink /usr/doc/ghostscript-9.02/doc
  --> Deleting symlink /usr/lib/cups/filter/pstoraster
  --> Deleting /etc/cups/gstoraster.convs
  --> Deleting /usr/bin/bdftops
  --> Deleting /usr/bin/fixmswrd.pl
  --> Deleting /usr/bin/pv.sh
  --> Deleting /usr/doc/ghostscript-9.02/COPYING
  --> Deleting /usr/doc/ghostscript-9.02/LICENSE
  --> Deleting /usr/lib/cups/filter/gstoraster


Alien Bob 06-28-2012 07:05 AM

This is an issue with the SlackBuild. New ghostscript requires that you explicitly tell configure to compile the cups filter.
This .diff file will fix that. I notified Pat V. and assume that the package in -current will get fixed soon.

Code:

--- source/ap/ghostscript/ghostscript.SlackBuild        2012-06-19 19:06:27.000000000 +0200
+++ work/ghostscript.SlackBuild      2012-06-28 13:17:16.873609130 +0200
@@ -102,6 +102,8 @@
  --disable-compile-inits \
  --enable-dynamic \
  --enable-cairo=no \
+  --enable-cups \
+  --with-install-cups \
  --program-prefix= \
  --program-suffix= \
  --build=$ARCH-slackware-linux

Eric

willysr 06-28-2012 07:15 AM

--enable-cairo and also the README are no longer valid, so it can be removed from the SlackBuild

polyph 06-28-2012 08:29 AM

Thanks again, I'm marking this as solved.


All times are GMT -5. The time now is 11:27 AM.