LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-27-2012, 06:34 PM   #1
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Rep: Reputation: 0
Gfire is not installing to pidgin.


I downloaded and untarred the program. I went in and ran the commands:
./configure --prefix=/usr
make

su- (password)

make install

the make install outputs these errors:

Code:
make install
Making install in data                                              
make[1]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/data'
make[2]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/data'
make[2]: Nothing to be done for `install-exec-am'.                          
test -z "/usr/share/purple/gfire" || /usr/bin/mkdir -p "/usr/share/purple/gfire"
 /usr/bin/ginstall -c -m 644 games.glade servers.glade '/usr/share/purple/gfire'
make[2]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/data'     
make[1]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/data'     
Making install in pixmaps                                                       
make[1]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/pixmaps' 
make[2]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/pixmaps' 
make[2]: Nothing to be done for `install-exec-am'.                              
test -z "/usr/share/pixmaps/pidgin/emblems/16" || /usr/bin/mkdir -p "/usr/share/pixmaps/pidgin/emblems/16"
 /usr/bin/ginstall -c -m 644 emblems/voip.png emblems/game-voip.png '/usr/share/pixmaps/pidgin/emblems/16'
test -z "/usr/share/pixmaps/pidgin/protocols/16" || /usr/bin/mkdir -p "/usr/share/pixmaps/pidgin/protocols/16"
 /usr/bin/ginstall -c -m 644 16/gfire.png '/usr/share/pixmaps/pidgin/protocols/16'                            
test -z "/usr/share/pixmaps/pidgin/protocols/22" || /usr/bin/mkdir -p "/usr/share/pixmaps/pidgin/protocols/22"
 /usr/bin/ginstall -c -m 644 22/gfire.png '/usr/share/pixmaps/pidgin/protocols/22'                            
test -z "/usr/share/pixmaps/pidgin/protocols/48" || /usr/bin/mkdir -p "/usr/share/pixmaps/pidgin/protocols/48"
 /usr/bin/ginstall -c -m 644 48/gfire.png '/usr/share/pixmaps/pidgin/protocols/48'                            
make[2]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/pixmaps'                                
make[1]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/pixmaps'                                
Making install in src                                                                                         
make[1]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/src'                                   
make[2]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/src'                                   
make[2]: Nothing to be done for `install-exec-am'.                                                            
test -z "/usr/lib/purple-2" || /usr/bin/mkdir -p "/usr/lib/purple-2"                                          
 /bin/sh ../libtool --silent   --mode=install /usr/bin/ginstall -c   libxfire.la '/usr/lib/purple-2'          
make[2]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/src'                                    
make[1]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/src'                                    
Making install in po                                                                                          
make[1]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/po'                                    
linguas="cs de ee es fr pl ro sk sv "; \                                                                      
        for lang in $linguas; do \                                                                            
          dir=/usr/share/locale/$lang/LC_MESSAGES; \                                                          
          /bin/sh /home/kelvin/Downloads/pidgin-gfire-0.9.4/install-sh -d $dir; \                             
          if test -r $lang.gmo; then \                                                                        
            /usr/bin/ginstall -c -m 644 $lang.gmo $dir/gfire.mo; \                                            
            echo "installing $lang.gmo as $dir/gfire.mo"; \                                                   
          else \                                                                                              
            /usr/bin/ginstall -c -m 644 ./$lang.gmo $dir/gfire.mo; \                                          
            echo "installing ./$lang.gmo as" \                                                                
                 "$dir/gfire.mo"; \                                                                           
          fi; \                                                                                               
          if test -r $lang.gmo.m; then \                                                                      
            /usr/bin/ginstall -c -m 644 $lang.gmo.m $dir/gfire.mo.m; \                                        
            echo "installing $lang.gmo.m as $dir/gfire.mo.m"; \                                               
          else \                                                                                              
            if test -r ./$lang.gmo.m ; then \                                                                 
              /usr/bin/ginstall -c -m 644 ./$lang.gmo.m \                                                     
                $dir/gfire.mo.m; \                                                                            
              echo "installing ./$lang.gmo.m as" \                                                            
                   "$dir/gfire.mo.m"; \                                                                       
            else \                                                                                            
              true; \                                                                                         
            fi; \                                                                                             
          fi; \                                                                                               
        done                                                                                                  
installing cs.gmo as /usr/share/locale/cs/LC_MESSAGES/gfire.mo                                                
installing de.gmo as /usr/share/locale/de/LC_MESSAGES/gfire.mo                                                
installing ee.gmo as /usr/share/locale/ee/LC_MESSAGES/gfire.mo                                                
installing es.gmo as /usr/share/locale/es/LC_MESSAGES/gfire.mo                                                
installing fr.gmo as /usr/share/locale/fr/LC_MESSAGES/gfire.mo                                                
installing pl.gmo as /usr/share/locale/pl/LC_MESSAGES/gfire.mo                                                
installing ro.gmo as /usr/share/locale/ro/LC_MESSAGES/gfire.mo                                                
installing sk.gmo as /usr/share/locale/sk/LC_MESSAGES/gfire.mo
installing sv.gmo as /usr/share/locale/sv/LC_MESSAGES/gfire.mo
make[1]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4/po'
make[1]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4'
make[2]: Entering directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4'
make[1]: Leaving directory `/home/kelvin/Downloads/pidgin-gfire-0.9.4'
make gives no errors as i can see (since obviously it lets me do make install) so i don't know what is the problem.

and install locale i think is for people that use different languages?
 
Old 01-28-2012, 01:12 AM   #2
Tash_
LQ Newbie
 
Registered: Oct 2010
Posts: 1

Rep: Reputation: 0
Hi There!

Hey what I do is take the rpm and make it a slackware compatible and it works!

rpm2txz

Try that!
 
Old 01-28-2012, 03:06 PM   #3
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Original Poster
Rep: Reputation: 0
i converted a fedora rpm to a tgz and it still did not change my pidgin.
maybe it is not installing to the correct directory?
 
Old 01-28-2012, 04:17 PM   #4
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
I compiled and installed pidgin-gfire and it showed up as xfire in the "Protocol" drop down box when adding a new account. I haven't tried using it though, so I don't know if it works.

Last edited by larryhaja; 01-28-2012 at 04:20 PM.
 
Old 01-28-2012, 06:29 PM   #5
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Original Poster
Rep: Reputation: 0
for me it doesnt even show up at all. i think it is installling to the incorrect directory. isnt it supposed to install to the pidgin folder? if so how can i do that?
 
Old 01-29-2012, 03:01 PM   #6
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
Quote:
Originally Posted by katokato View Post
for me it doesnt even show up at all. i think it is installling to the incorrect directory. isnt it supposed to install to the pidgin folder? if so how can i do that?
It looks like it installs the required libraries and other files into the correct directories. The libraries get installed to /usr/lib/purple-2/ and the glade files get installed to /usr/share/purple/gfire. Here is my build script if you'd like to check it out.
pidgin-gfire.SlackBuild
Code:
#!/bin/sh

PRGNAM=pidgin-gfire
VERSION=${VERSION:-0.9.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_lh}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
#unzip $CWD/emblems.zip
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

./autogen.sh

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --disable-silent-rules \
  --disable-dependency-tracking \
  --enable-libnotify \
  --enable-dbus-status \
  --build=$ARCH-slackware-linux

make
make install DESTDIR=$PKG
#install -m 0644 emblems/16/*.png $PKG/usr/share/pixmaps/pidgin/emblems/16/

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
  AUTHORS ChangeLog COPYING README \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
slacd-desc
Code:
            |-----handy-ruler------------------------------------------------------|
pidgin-gfire: pidgin-gfire
pidgin-gfire: 
pidgin-gfire: Gfire is an advanced open-source Xfire plugin for the popular Pidgin
pidgin-gfire: IM client.
pidgin-gfire: 
pidgin-gfire: Homepage: http://gfireproject.org/
pidgin-gfire:
pidgin-gfire:
pidgin-gfire:
pidgin-gfire:
pidgin-gfire:
 
Old 01-29-2012, 11:42 PM   #7
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Original Poster
Rep: Reputation: 0
alright ill try to install gfire with your slackbuild script. ill tell you later if it works.
 
Old 01-30-2012, 07:49 PM   #8
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Original Poster
Rep: Reputation: 0
the slackbuild did not work. i still dont see gfire in the accounts menu. i did istall libnotify and ran the script (with the tar.bz2 package in saMe dir):

http://pastebin.com/MEgEqbrr
 
Old 01-31-2012, 02:25 PM   #9
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
Quote:
Originally Posted by katokato View Post
the slackbuild did not work. i still dont see gfire in the accounts menu. i did istall libnotify and ran the script (with the tar.bz2 package in saMe dir):

http://pastebin.com/MEgEqbrr
According to your pastebin the slackbuild failed because the script was trying to do
Code:
cat: /home/kelvin/gfiredir/pidgin-gfire.SlackBuild: No such file or directory
by you have it as "pidgin-gfire.Slackbuild". Notice the lower case 'b' on SlackBuild.

Edit: also if you are using Slackware 13.1 or newer, you don't need to install libnotify. Otherwise, you can just delete the --enable-libnotify line.

Last edited by larryhaja; 01-31-2012 at 02:52 PM.
 
Old 01-31-2012, 06:45 PM   #10
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Original Poster
Rep: Reputation: 0
Haha I saw that error too before. I noticed the capital s but not the b in the name so ill try again. I'm using slackware 13 that is why I had to install lib notify

Last edited by katokato; 01-31-2012 at 06:46 PM.
 
Old 01-31-2012, 07:02 PM   #11
katokato
Member
 
Registered: May 2011
Location: united states
Distribution: i have used ubuntu, but want to switch to slackware (ubuntu is too user friendly).
Posts: 62

Original Poster
Rep: Reputation: 0
alright so the .tgz file was put into my tmp directory and i su - and then i installpkg it, and i still did not find xfire option under the menu for add accounts, and nothing under plugins. should i send an email to the developers? or could it be that i may have to reinstall pidgin all over again?

not all of it i could fit in
http://pastebin.com/DnHfLczd

Last edited by katokato; 01-31-2012 at 07:06 PM.
 
Old 02-01-2012, 10:20 PM   #12
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
Quote:
Originally Posted by katokato View Post
alright so the .tgz file was put into my tmp directory and i su - and then i installpkg it, and i still did not find xfire option under the menu for add accounts, and nothing under plugins. should i send an email to the developers? or could it be that i may have to reinstall pidgin all over again?

not all of it i could fit in
http://pastebin.com/DnHfLczd
It seems like you should have the right system requirements and the build script installed it to the the same locations as in my VM. Reinstalling pidgin may help but I don't know if it will help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i install gfire? katokato Slackware - Installation 11 06-23-2011 12:12 AM
[SOLVED] installing pidgin 2.7.10 Cultist Slackware 10 02-22-2011 09:37 AM
Problem with Gfire Wormboy Linux - Software 1 07-05-2009 11:41 AM
error on installing pidgin toxic_brain Linux - Software 3 06-14-2007 07:01 AM
gfire gaim plugin install woes th3flyboy Suse/Novell 6 05-06-2007 05:12 PM


All times are GMT -5. The time now is 03:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration