LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-30-2003, 08:53 PM   #1
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Rep: Reputation: 15
Question Getting Started with Slackware (Please Help!)


This is my first Slackware installation and I'm having a ton of problems. My previous distro was Mandrake and it was a walk in the park, but I'm ready to step up to a *real* distro!

Here's my hardware specs:

Noname generic motherboard
Pentium III, 600 mhz
2 IDE Harddrives
Netgear FA311 Ethernet (it's a natsemi chipset)
Promise Technology Ultra IDE controller (there's 1 HD connected to this)
Generic Keyboard
USB Mouse (Logitech MX700)
2 IDE ATAPI CD Burners
NVIDIA GeForce 2 MX400
SoundBlaster Live! Value

I want to either build a kernel or get one that works with my hardware. I can't seem to get X up and running, either. I believe I have to build nvidia drivers and usb drivers into the kernel? Is this true? What about cd burning?

For now, X is the big issue....

I get the errors:

xf86 Open Serial: Cannot open device /dev/mouse
Mouse1: Cannot open input device

Pre Init failed for input device "mouse1"

No core pointer
Fatal Server Error: Failed to inialize core devices

I also want to get my Soundblaster and Mouse working. Any help would be great.

Last edited by jstef; 01-31-2003 at 04:20 PM.
 
Old 01-30-2003, 11:38 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
I believe if you do a search here on LQ, perhaps limit the search to the Slack forum, you will find most all of your answers.

If you are new to Slack, then I recommend staying with the stock kernel for awhile. When you get everything working and know what your requirements are; then try a custom kernel. At present, make sure everything works with modules it is far simpler that way. That is why all the distros are module based on everything.

nVidia I believe you need to download their drivers, build and install. Modules I think they are. But I am fairly certain that it will run in framebuffer mode as well. Sample config in /etc/X11/XF86Config-fbdev. Just copy it to the XF86Config file. There is also a XF86Config-vesa if you want to try vesa mode.

Soundblaster Live uses the module emu10k1 I believe it is. (modprobe emu10k1)

For the USB mouse, you could load the modules and make sure the device /dev/mouse points to /dev/usb/mouse0 I think it is. (modprobe usbmouse)

Good luck and welcome to the Slack world.
 
Old 01-31-2003, 12:01 AM   #3
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
I got X up and running, but my soundblaster won't work.

An even bigger problem is getting on the net. netconfig refuses to find my card (a netgear fa311). It's driving me nuts! What should I do to start debugging this problem?
 
Old 01-31-2003, 12:07 AM   #4
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jstef
I got X up and running, but my soundblaster won't work.

An even bigger problem is getting on the net. netconfig refuses to find my card (a netgear fa311). It's driving me nuts! What should I do to start debugging this problem?
It occured to me to try # modprobe natsemi, but I get "Permission Denied" even when logged on as root. How do I fix that?

Puhleeeze help!
 
Old 01-31-2003, 12:37 AM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
From what I have been able to locate quickly, the fa311 card should use the natsemi driver. Perhaps another module has attempted to load and locked the resources, or maybe from netconfig probes. Power off and retry without running netconfig. Use "lsmod" to view the loaded modules. After you receive the error message, use the command "dmesg" and look at the end of the listing and see if any errors are reported that might point to where the problem is. If all else fails, then shutdown X to just a console unload all modules and then attempt to load the natsemi module. If it still fails with the same message, then perhaps the kernel is attempting to do something with it. Review the dmesg output just after booting to console mode to see what the kernel reports.
 
Old 01-31-2003, 02:20 PM   #6
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Excalibur
From what I have been able to locate quickly, the fa311 card should use the natsemi driver. Perhaps another module has attempted to load and locked the resources, or maybe from netconfig probes. Power off and retry without running netconfig. Use "lsmod" to view the loaded modules. After you receive the error message, use the command "dmesg" and look at the end of the listing and see if any errors are reported that might point to where the problem is. If all else fails, then shutdown X to just a console unload all modules and then attempt to load the natsemi module. If it still fails with the same message, then perhaps the kernel is attempting to do something with it. Review the dmesg output just after booting to console mode to see what the kernel reports.
Ok, I tried lsmod from root after a reboot and got the same Permission Denied message. Then I tried dmesg and this was the error:

kmod: failed to exec /sbin/modprobe -s -k char-major-10-134, errno=13

I hope that makes more sense to someone than it does to me.

EDIT: Another Question- How do I shut down X and why does it hog all the buffers? I can only use buffer #6 (Alt-F6). I am booting into an X login (I changed the id in /etc/inittab from id:3 to id:4).

Last edited by jstef; 01-31-2003 at 02:23 PM.
 
Old 01-31-2003, 03:54 PM   #7
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Are you running a custom kernel with modules disabled? That would explain the messages that you are receiving.

In reference to the "buffers", it is not buffers but consoles. Init level 4 only allows for a single console on tty6. If you desire more consoles, I would think you simply need to enable them the /etc/inittab for runlevel 4. Look toward the bottom of file and you will see where the consoles are enabled. I like having at least the one standard console, in the event I need to do something outside of X. But once in X, I can run as many consoles I desire, not limited to just a few. So the others are not really missed.
 
Old 01-31-2003, 03:58 PM   #8
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Quote:
Originally posted by jstef
EDIT: Another Question- How do I shut down X and why does it hog all the buffers? I can only use buffer #6 (Alt-F6). I am booting into an X login (I changed the id in /etc/inittab from id:3 to id:4).
Buffers? you mean terminals, that's a little Slack thing but if you want it RH style do these changes...

/etc/inittab:

change this line towards the top:
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
to
Code:
id:5:initdefault:
and down towards the bottom is this:
Code:
x1:4:wait:/etc/rc.d/rc.4
that you hange to this:
Code:
x1:45:wait:/etc/rc.d/rc.4
And if your bored open up /etc/rc.d/rc.modules in your favorite text editor to get an idea for how simple Slack makes things to do by hand.
 
Old 01-31-2003, 04:19 PM   #9
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Excalibur
Are you running a custom kernel with modules disabled? That would explain the messages that you are receiving.

In reference to the "buffers", it is not buffers but consoles. Init level 4 only allows for a single console on tty6. If you desire more consoles, I would think you simply need to enable them the /etc/inittab for runlevel 4. Look toward the bottom of file and you will see where the consoles are enabled. I like having at least the one standard console, in the event I need to do something outside of X. But once in X, I can run as many consoles I desire, not limited to just a few. So the others are not really missed.
I'm running the "usb" kernel off the Slack CD. I have a USB mouse that I was trying to get going so I thought this would be the best way. Should I have just used the default kernel and enabled usb through modules? Is there any reason why modules would be disabled by using this kernel?

Thanks for the help so far Excalibur, as well as everyone else!
 
Old 01-31-2003, 05:10 PM   #10
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
I just thought of something that might be important. I've been booting with my boot floppy because I didn't install LILO. Would this make a difference? Just a thought.
 
Old 01-31-2003, 05:34 PM   #11
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
What kernel is on the boot floppy?

I would think that kernel would be modules enabled. But I haven't actually used it myself. Check the directory tree /lib/modules/2.4.18 and see if anything is there. That would be the location for the modules after an install. there should be a lot of them in various directories. If it is empty for some reason, then locate them on the install CD and use "installpkg" I think it is to install it. The package is in the "a" set and is called kernel-modules-2.4.18-i386-4.tgz.

Last edited by Excalibur; 01-31-2003 at 05:35 PM.
 
Old 01-31-2003, 05:57 PM   #12
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Excalibur
What kernel is on the boot floppy?

I would think that kernel would be modules enabled. But I haven't actually used it myself. Check the directory tree /lib/modules/2.4.18 and see if anything is there. That would be the location for the modules after an install. there should be a lot of them in various directories. If it is empty for some reason, then locate them on the install CD and use "installpkg" I think it is to install it. The package is in the "a" set and is called kernel-modules-2.4.18-i386-4.tgz.
I'm not sure what kernel is on the boot floppy, I think it's also the USB kernel. Should I try installing LILO? How would I go about that without reinstalling Slack from scratch?

Thanks again, Excalibur, I know my questions are tedious!
 
Old 01-31-2003, 06:08 PM   #13
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
I cd to /lib/modules/2.4.81 and ls the files:

@build kernel/ modules.dep net/ pmcia/
modules.genericsetup modules.ieee1394map modules.isapnpmap
modules.parportmap modules.pcimap modules.pnpbiosmap modules.usbmap

Am I missing any modules?
 
Old 01-31-2003, 06:34 PM   #14
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Well those are just the directories. The modules are further down below. You would need to follow the tree, kernel/drivers/net, etc. You should be able to locate files that are like something.o. The "o" files are compiled object code and they are the modules that can be loaded. But since the tree is there then I would expect all the files to be there aas well. So then we are back to the kernel issue. We better find a solution fast, I am running out ideas? (hehe)

Without knowing your hard disk layout, It is difficult to recommend installing lilo. Why did you decide not to install lilo to start with?
 
Old 01-31-2003, 07:12 PM   #15
jstef
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware 8.1
Posts: 28

Original Poster
Rep: Reputation: 15
Well I checked the files, all the modules I need are there. I still don't understand why I don't have permission to run lsmod and modprobe as root.

I didn't install LILO because I am running linux on a secondary drive and LILO wanted to install to the MBR of my windows drive. I wanted all of Linux to be on it's own drive and not have LILO on the windows drive.

Should I scratch my install? Maybe this problem is from booting from the floppy?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows user, want to get started in Slackware, seeking all kinds of advice Zaelryn Slackware 49 07-07-2005 02:34 PM
how do I shutdown httpd after i started it? under slackware babyboss Slackware 3 10-02-2004 02:42 AM
Getting kde started in Slackware v10? nraj2644 Slackware 4 09-01-2004 04:00 AM
started slackware install...screwed up...please help GoinEasy9 Slackware 5 05-21-2004 05:50 PM
Getting started on Slackware for newbies JulianS Slackware 6 03-06-2004 01:07 AM


All times are GMT -5. The time now is 02:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration