LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2004, 03:30 AM   #1
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Rep: Reputation: 30
Question Getting rid of annoying beeps in console?


Whenever I'm working in the console I get high pitched beeps if I accidentally hit too many backspaces, or hit a wrong button in vim. It's real annoying, and is loud enough to wake up my family, anyone know how to turn 'em off?
 
Old 02-02-2004, 04:18 AM   #2
George666
Member
 
Registered: Nov 2003
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
You can turn it off in KDE (control center --> sound and multimedia --> system bell).
As for the console, to turn it completely off, I have googled all over the web but I haven't found any method which is succesfull (in software that is).
 
Old 02-02-2004, 04:34 AM   #3
Kovacs
Member
 
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 30
You can compile the kernel with no support for the bell, I've done that with 2.6.1 and it's much more pleasant, especially late at night.

You can also use the command:

setterm -blength 0

which sets the length of the beep to 0 (ie off).

Last edited by Kovacs; 02-02-2004 at 04:36 AM.
 
Old 02-02-2004, 09:12 AM   #4
George666
Member
 
Registered: Nov 2003
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
I have also just noticed that with the latest alsa you can mute the pc speaker (just run alsamixer)
 
Old 02-02-2004, 11:22 AM   #5
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
One possibility is that you haven't yet configured your sound card.
You can do that by running alsaconf.
 
Old 02-02-2004, 11:35 AM   #6
Piratero
Member
 
Registered: Sep 2003
Distribution: FreeBSD-5.2.1
Posts: 38

Rep: Reputation: 15
There is also another working way to remove that 'beep' in a few X11 apps. add this to your ~/.xinitrc file:
Code:
xset -b;
you also need to state what solutions you have tried so we can find another answer for you. I hope this helps
 
Old 02-25-2004, 04:22 PM   #7
Pres
Member
 
Registered: Jun 2002
Location: Australia
Distribution: Slack 9.1
Posts: 232

Rep: Reputation: 30
Certain terminals allow you to turn on a "visual bell" option as well (notably eterm, others may as well). Just one more suggestion.
 
Old 03-02-2004, 07:46 PM   #8
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
I found out how to do it. Under the terminal type:

xset b off

And under the console type:

setterm -blength 0

The only time it beeps now is when I'm shutting down, anyone know how I can get rid of these? And also the beeps come back everytime I restart. I believe I need to add the console command to one of the hidden bashfiles in my home directory, but I forget which one. Could someone remind me where I need to put it?

Thanks.
 
Old 03-11-2004, 12:48 AM   #9
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
Alright, just add that command

setterm -blength 0

to your .bashrc file. Anyone know if I can get rid of the beeps that happen when I shutdown?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get rid of that annoying disco music? purelithium Mandriva 4 11-09-2005 06:55 PM
annoying cron job on find, how to get rid of it feetyouwell Linux - Software 2 06-27-2005 08:44 PM
console beeps zaicheke Slackware 2 12-24-2004 05:23 AM
Annoying Internal BEEPS while playing VIDEOS w0lv3rin3 Linux - Software 1 03-13-2004 05:16 AM
How do I get rid of that annoying ping in Gnome 1.2? CragStar Linux - General 2 12-22-2000 09:18 AM


All times are GMT -5. The time now is 01:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration