LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-22-2003, 08:17 AM   #1
jspaceman
Member
 
Registered: Dec 2000
Location: Toronto, Canaduhhhh
Distribution: Slackware -current, OpenBSD 3.8-stable
Posts: 178

Rep: Reputation: 30
Getting my CD drives to work with 2.6.0


I upgraded my kernel to 2.6.0, but I didn't add SCSI emulation when I ran 'make xconfig', as it is deprecated, and from what I've read ide-cd will do the job now. Since SCSI emulation was no longer needed I removed the:

Quote:
append="hda=ide-scsi hdb=ide-scsi"
line from /etc/lilo.conf.

However, when I run a cd burning program like k3b now I get the old:

Quote:
cdrdao 1.1.7 does not support ATAPI
The configured version of cdrdao does not support writing to ATAPI devices without SCSI emulation and there is at least one writer in your system not configured to use SCSI emulation.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems. Or you install (or select as the default) a more recent version of cdrdao.
error message again.

I understand that this problem can be solved by downloading the latest CDRDAO from CVS. I tried doing that but I get an error when I run 'make' during the CDRDAO compile:

Quote:
g++ -o cdrdao main.o -L. -ldao -L../paranoia -lcdda_paranoia -L../trackdb -ltrackdb -L../scsilib/export -lscg -lschily -lpthread -lnsl
/usr/lib/gcc-lib/i486-slackware-linux/3.2.3/../../../../i486-slackware-linux/bin/ld: cannot find -lscg
collect2: ld returned 1 exit status
make[1]: *** [cdrdao] Error 1
make[1]: Leaving directory `/usr/src/cdrdao/dao'
make: *** [all] Error 1
I have 2 drives on this box. One is a CD/DVD Rom drive, and the other is a CD writer. When I run k3b and select 'Copy CD' it will display my CD writer under 'Burning Device', but it doesn't display my CD/DVD Rom under 'CD Reader Device'.

Yet when I run cdrecord -scanbus dev=ATAPI I get:

Quote:
scsibus0:
0,0,0 0) 'ATAPI ' 'DVD-ROM 16XMax ' '1.00' Removable CD-ROM
0,1,0 1) 'PLEXTOR ' 'CD-R PX-W1210A' '1.02' Removable CD-ROM
Should I just recompile my kernel with SCSI emulation, or is there a way to solve my problem so that I can use ide-cd?
 
Old 12-22-2003, 09:23 AM   #2
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
I tried to do it with scsi emulation but that's broken too. See the post halloween document maintained by Dave Jones ( http://www.linux.org.uk/~davej/docs/...loween-2.6.txt ) . I heard some other people say they could use XCDRoast on a 2.6 kernel without ide-scsi.

If you want to use k3b I guess you'll have to wait for a working cdrdao version.

Last edited by rotvogel; 12-22-2003 at 09:26 AM.
 
Old 12-22-2003, 04:43 PM   #3
jspaceman
Member
 
Registered: Dec 2000
Location: Toronto, Canaduhhhh
Distribution: Slackware -current, OpenBSD 3.8-stable
Posts: 178

Original Poster
Rep: Reputation: 30
Any idea how often the cdrdao CVS repository thingee is updated?
 
Old 12-22-2003, 06:38 PM   #4
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
No, I don't have an idea how often the cdrdao cvs is updated. it shows what files are updated when you update your local cvs tree. I decided to stick with 2.4 for a while. There are too many things not working on the 2.6.0 kernel for me. For example highpoint ataraid drivers and mga framebuffer.

Maybe there is a developper mailadres or mailing list which you can use to get information about cdrdao and 2.6 issues .

Good luck
 
Old 12-23-2003, 03:30 AM   #5
valve
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
Finally one i can answer :)

its ez in 2.6

eg to write:
cdrecord -dev=ATAPI:0,0,0 /my.iso

lurvly, and i know it woks because im using it now, on 2.6.stable
 
Old 12-23-2003, 02:18 PM   #6
jspaceman
Member
 
Registered: Dec 2000
Location: Toronto, Canaduhhhh
Distribution: Slackware -current, OpenBSD 3.8-stable
Posts: 178

Original Poster
Rep: Reputation: 30
Re: Finally one i can answer :)

Quote:
Originally posted by valve
its ez in 2.6

eg to write:
cdrecord -dev=ATAPI:0,0,0 /my.iso

lurvly, and i know it woks because im using it now, on 2.6.stable
But what if I want to do disk to disk burning, or use DAO? Can I do that with the 2.6 kernel without enabling SCSI emulation?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will ANY external drives work? Micro420 Linux - Hardware 0 10-08-2004 07:14 PM
CD drives don't work after install is done. HornOUBet Yoper 3 10-07-2004 12:35 AM
cp -p won't work across drives wayback Linux - Software 3 01-01-2004 11:20 AM
CD drives dont work Riichard Linux - Newbie 4 09-15-2003 07:49 AM
Cant get any Netgear FA311 drives to work! lexusnexus Linux - Networking 11 06-30-2001 08:18 AM


All times are GMT -5. The time now is 04:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration