LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-05-2006, 09:58 PM   #1
DrCurl
LQ Newbie
 
Registered: Dec 2006
Posts: 5

Rep: Reputation: 0
Get WPA working on 2200bg in Slack 11


Hello,

I have a centrino laptop with a 2200bg eth1 network interface. I downloaded the firmware and the card is correctly detected by Slackware 11.

I want to setup a WPA connection at home. I installed wpa_supplicant package from Alien’s website and I followed the instructions on his wiki.

Here is what I did:
Edit wpa_supplicant.conf so it look like this:
...
network={
scan_ssid=0
ssid="XXX"
proto=WPA
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
#psk="XXX"
psk=XXXXXXXXXXXXXXXXXX
}
...

Then:
chmod 600 /etc/wpa_supplicant.conf

And finally edit rc.inet1.conf:
...
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
WLAN_WPA[1]="wpa_supplicant"
WLAN_WPADRIVER[1]="wext"
...

When I do:
/etc/rc.d/rc.inet1 eth1_restart
I get:
/etc/rc.d/rc.inet1: eth1 is 'Any ESSID'
dhcpcd: MAC address = 00:0e:35:47:09:fa
and iwconfig result:
eth1 unassociated ESSIDff/any Nickname:"abi"
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate=0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

What am I doing wrong? rc.inet1 doesn't seem to see wpa_supplicant...

Thank you,

carl
 
Old 12-06-2006, 04:10 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,259

Rep: Reputation: Disabled
You don't mention these lines of wpa_supplicant.conf:
Code:
# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=10
eapol_version=1
ap_scan=1
fast_reauth=1
I assume the "...." means that these are indeed in the file?

The "eth1 is 'Any ESSID'" message is harmless. If you want to know if, and how, wpa_supplicant is loaded and functional, you can run the command
Code:
wpa_cli status
and you should get back an overview of the WPA connection parameters. If you get
Quote:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
instead, then wpa_supplicant is not running.
 
Old 12-06-2006, 07:49 AM   #3
DrCurl
LQ Newbie
 
Registered: Dec 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I use the default settings in wpa_supplicant.conf:
# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

wpa_cli status gives me:
Selected interface 'eth1'
wpa_state=SCANNING

When I do:
wpa_passphrase YOURSSID passphrase
to create my settings, I need to put the passphrase between "" because of the spaces right?

Thank you,

carl
 
Old 12-06-2006, 01:19 PM   #4
DrCurl
LQ Newbie
 
Registered: Dec 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I tried the debugging, "wpa_supplicant -dw -c/etc/wpa_supplicant.conf -Dwext -ieth1" gives me this:

Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 224 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 2
0: 00:13:46:f5:ae:04 ssid='abi-lan' wpa_ie_len=0 rsn_ie_len=26 caps=0x11
skip - SSID mismatch
Selecting BSS from priority group 0
0: 00:13:46:f5:ae:04 ssid='abi-lan' wpa_ie_len=0 rsn_ie_len=26 caps=0x11
skip - no WPA/RSN proto match
No suitable AP found.
Setting scan request: 5 sec 0 usec

Kwifimanager tells me that the name of the ssid is really "abi-lan" ... what's wrong???
 
  


Reply

Tags
slackware, wpa


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WPA on ipw2200 on Slack 10.2 brooky9999 Slackware 21 03-22-2007 12:56 PM
Intel Pro/Wireless 2200BG + WPA in Ubuntu frijolie Linux - Wireless Networking 1 11-30-2006 05:27 AM
Intel Pro 2200BG not working [Dell 600m][suse 10] mailtouam Linux - Laptop and Netbook 10 02-11-2006 01:22 PM
2200BG on Vaio T not working krispy Mandriva 2 07-17-2005 08:11 PM
WPA not working ineedanewun Linux - Wireless Networking 0 12-16-2004 06:53 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration