LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Generic kernel and full screen login? (http://www.linuxquestions.org/questions/slackware-14/generic-kernel-and-full-screen-login-4175446780/)

andreas-r 01-22-2013 01:59 PM

Generic kernel and full screen login?
 
I switched to the generic kernel suggested by the mkinitrd script. It worked fine but now the login console is a tiny 640x480 block in the middle of the screen which sort of sucks if I choose to do some work in that environment.

This makes sense - I guess I've prevented the graphics driver from being loaded at start-up. Is there an easy way to have the other advantages from a generic kernel but have the graphics drivers load so the console is full screen?

Thanks!

tuxbg 01-22-2013 02:34 PM

Edit lilo.conf and locate that line vga = normal,or edit other vga options.

andreas-r 01-22-2013 04:47 PM

'vga = normal' is already uncommented. Also tried 'vesa framebuffer console @ 1366x768' and 'normal VGA console' together and by themselves but when I 'lilo -v' it gives me error or unknown token.

It happened after I changed the image in lilo.conf so suppose it's related to switching to generic kernel.

tuxbg 01-22-2013 05:12 PM

What is your graphic card?

andreas-r 01-22-2013 05:28 PM

It's intel hd graphics 3000.

andreas-r 01-22-2013 05:32 PM

I should probably mention that i run Slackware in VirtualBox. Couldn't get the right resolution before installing VBOX additions.

andreas-r 01-23-2013 03:59 AM

Code:

vga = 791
in 'lilo.conf' gives me a 1024x768x64k console so the vga settings were of course the place to look - I just mistook the comment '#vesa framebuffer console @ 1366x768' for the actual code to do this. I'm new to Slack :)
Cheers!

cynwulf 01-23-2013 06:30 AM

Quote:

Originally Posted by andreas-r (Post 4875740)
I should probably mention that i run Slackware in VirtualBox. Couldn't get the right resolution before installing VBOX additions.

Just a guess as I haven't used virtualbox for over a year, but you might need to reinstall that as the driver may have been built for the huge kernel.

andreas-r 01-23-2013 06:40 AM

Thanks for replying! Maybe you missed my last post - adding 'vga = 791' as described above actually fixed it.


All times are GMT -5. The time now is 06:41 AM.