LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2004, 06:35 PM   #1
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
GDM Broken After Upgrade Via Swaret


After upgrading some packages, X not longer starts normally. It tries, then errors saying that an X server is already running, do I want to try another display. Answering yes or no causes the same symptom, restart attempt and fails.

Killing all GDM pids and running startx gets me into KDE. I normally run XCFE4 from GDM.

XFree86.log said that there were multiple X servers running and no screens defined (paraphrasing as the log has been overwritten.

Packages upgraded:
Mar 20 14:14 atk-1.6.0-i486-1.tgz
Mar 20 14:14 coreutils-5.2.1-i486-1.tgz
Mar 20 14:16 gimp-2.0pre4-i486-1.tgz
Mar 20 14:16 glib2-2.4.0-i486-1.tgz
Mar 20 14:17 gtk+2-2.4.0-i486-1.tgz
Mar 20 14:17 pango-1.4.0-i486-1.tgz

What can I do to further diagnose?
Anyone else having trouble with one of these packages? If so, which ones might I downgrade and to what?

note to self: Do not blindly upgrade just because swaret says that you can.
 
Old 03-20-2004, 07:18 PM   #2
Minderbinder
Member
 
Registered: Aug 2003
Location: Boston, MA
Distribution: Slackware-current
Posts: 142

Rep: Reputation: 15
Are you running dropline gnome? Those packages look like some of the ones that won't be updated in dropline until gnome 2.6 is released next week.
 
Old 03-20-2004, 07:24 PM   #3
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Original Poster
Rep: Reputation: 49
Only the vanilla Gnome is installed. Rarely used, but it's there.
No Dropline.
 
Old 03-20-2004, 08:41 PM   #4
GrayGhost
LQ Newbie
 
Registered: Jul 2003
Location: State of confusion (Wisconsin)
Distribution: Slackware 10.2 and Current
Posts: 29

Rep: Reputation: 15
I had the same problem yesterday after my swaret --upgrade. I had to switch to KDM in /etc/rc.d/rc4 to get a log in manager GDM kept giving me the same error.
 
Old 03-20-2004, 08:42 PM   #5
patfins
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Rep: Reputation: 15
I have the same problem.

Downgrade from gtk+2-2.4.0-i486-1.tgz back to gtk+2-2.2.4-i486-1.tgz.
 
Old 03-20-2004, 11:28 PM   #6
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Original Poster
Rep: Reputation: 49
Downgrading to 2.2.4 fixed it. Thanks for all of the responses.
Much appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
(swaret==broken slackware)? TRUE kersten78 Slackware 26 09-26-2004 09:13 PM
After swaret --upgrade -a....... Mingthefirst Slackware 2 07-09-2004 02:42 AM
upgrade to 10.0 or use swaret? Axion Slackware 5 06-17-2004 10:32 AM
swaret broke my gnome/gdm thrice Slackware 12 05-13-2004 12:59 PM
kaboodle and noatun broken after swaret upgrade peeks Slackware 1 05-06-2004 07:41 AM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration