LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-13-2017, 01:43 PM   #1
trem0rs
LQ Newbie
 
Registered: Apr 2017
Posts: 9

Rep: Reputation: Disabled
GCC cant create executables


Hi, I have some years now using slackware, back in 2014 I used gcc without having any problems but now I am starting to have them.

If I try to create a simple hello-world program I get this error msg:
Code:
hll.c:1:19: fatal error: stdio.h: No such file or directory
 #include <stdio.h>
                   ^
compilation terminated.
And when I try to intall anything sbo I get:
Code:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
When I open the config.log this is what I get:
Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc --localstatedir=/var --enable-plugins --enable-gtk --build=i486-slackware-linux

## --------- ##
## Platform. ##
## --------- ##

hostname = l0lvl
uname -m = i686
uname -r = 3.10.104-smp
uname -s = Linux
uname -v = #2 SMP Mon Oct 31 00:42:06 CDT 2016

/usr/bin/uname -p = Intel(R) Celeron(R) CPU B815 @ 1.60GHz
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/sbin
PATH: /sbin
PATH: /usr/local/bin
PATH: /usr/bin
PATH: /bin
PATH: /usr/games
PATH: /usr/lib/kde4/libexec
PATH: /usr/lib/qt/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1532: checking whether to enable maintainer-specific portions of Makefiles
configure:1541: result: no
configure:1564: result: 
configure:1566: result: Configuring ettercap NG-0.7.3...
configure:1568: result: 
configure:1612: checking for a BSD-compatible install
configure:1667: result: /usr/bin/ginstall -c
configure:1678: checking whether build environment is sane
configure:1721: result: yes
configure:1778: checking for gawk
configure:1794: found /usr/bin/gawk
configure:1804: result: gawk
configure:1814: checking whether make sets $(MAKE)
configure:1834: result: yes
configure:2009: checking build system type
configure:2027: result: i486-slackware-linux-gnu
configure:2035: checking host system type
configure:2049: result: i486-slackware-linux-gnu
configure:2530: checking for gcc
configure:2546: found /usr/bin/gcc
configure:2556: result: gcc
configure:2800: checking for C compiler version
configure:2803: gcc --version </dev/null >&5
gcc (GCC) 4.8.2
Copyright (C) 2013 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2806: $? = 0
configure:2808: gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.8.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.8.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.8.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,go,java,lto,objc --enable-threads=posix --enable-checking=release --enable-objc-gc --with-system-zlib --with-python-dir=/lib/python2.7/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --enable-java-home --with-java-home=/usr/lib/jvm/jre --with-jvm-root-dir=/usr/lib/jvm --with-jvm-jar-dir=/usr/lib/jvm/jvm-exports --with-arch-directory=i386 --with-antlr-jar=/root/slackware-current/source/d/gcc/antlr-runtime-3.4.jar --enable-java-awt=gtk --disable-gtktest --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.8.2 (GCC) 
configure:2811: $? = 0
configure:2813: gcc -V </dev/null >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:2816: $? = 1
configure:2839: checking for C compiler default output file name
configure:2842: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find crt1.o: No such file or directory
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find crti.o: No such file or directory
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find -lc
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find crtn.o: No such file or directory
collect2: error: ld returned 1 exit status
configure:2845: $? = 1
configure: failed program was:
| /* confdefs.h.  */
| 
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "ettercap"
| #define VERSION "NG-0.7.3"
| #define OS_LINUX 1
| #define INSTALL_PREFIX "/usr"
| #define INSTALL_EXECPREFIX "/usr"
| #define INSTALL_SYSCONFDIR "/etc"
| #define INSTALL_DATADIR "/usr/share"
| #define INSTALL_LIBDIR "/usr/lib"
| #define INSTALL_BINDIR "/usr/bin"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:2884: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i486-slackware-linux-gnu
ac_cv_build_alias=i486-slackware-linux
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -march=i486 -mtune=i686'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=
ac_cv_env_FFLAGS_value=
ac_cv_env_GTK_CFLAGS_set=
ac_cv_env_GTK_CFLAGS_value=
ac_cv_env_GTK_LIBS_set=
ac_cv_env_GTK_LIBS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_PKG_CONFIG_set=
ac_cv_env_PKG_CONFIG_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=i486-slackware-linux
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i486-slackware-linux-gnu
ac_cv_host_alias=i486-slackware-linux
ac_cv_path_install='/usr/bin/ginstall -c'
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /tmp/SBo/ettercap-NG-0.7.3/missing --run aclocal-1.8'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /tmp/SBo/ettercap-NG-0.7.3/missing --run tar'
AR=''
AS=''
AUTOCONF='${SHELL} /tmp/SBo/ettercap-NG-0.7.3/missing --run autoconf'
AUTOHEADER='${SHELL} /tmp/SBo/ettercap-NG-0.7.3/missing --run autoheader'
AUTOMAKE='${SHELL} /tmp/SBo/ettercap-NG-0.7.3/missing --run automake-1.8'
AWK='gawk'
BSD_FALSE=''
BSD_TRUE='#'
CC='gcc'
CCDEPMODE=''
CFLAGS='-O2 -march=i486 -mtune=i686'
CONVENIENCE_LTDL_FALSE=''
CONVENIENCE_LTDL_TRUE=''
CPP=''
CPPFLAGS=''
CXX=''
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS=''
CYGPATH_W='echo'
CYGWIN_FALSE=''
CYGWIN_TRUE='#'
DARWIN_FALSE=''
DARWIN_TRUE='#'
DEFS=''
DEPDIR=''
DLLTOOL=''
EB=''
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EC_CFLAGS=''
EC_LIBS=''
EGREP=''
EXEEXT=''
F77=''
FFLAGS=''
GTK_CFLAGS=''
GTK_FALSE=''
GTK_LIBS=''
GTK_TRUE=''
HAVE_DN_EXPAND_FALSE=''
HAVE_DN_EXPAND_TRUE=''
HAVE_PCRE_FALSE=''
HAVE_PCRE_TRUE=''
ICONVLIB=''
INET_ATON_WANTS_RESOLV_FALSE=''
INET_ATON_WANTS_RESOLV_TRUE=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_LTDL_FALSE=''
INSTALL_LTDL_TRUE=''
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
LDFLAGS=''
LEX=''
LEXLIB=''
LEX_OUTPUT_ROOT=''
LIBADD_DL=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LINUX_FALSE='#'
LINUX_TRUE=''
LNETINC=''
LNETLIB=''
LN_S=''
LTLIBOBJS=''
MAINT='#'
MAINTAINER_MODE_FALSE=''
MAINTAINER_MODE_TRUE='#'
MAKEINFO='${SHELL} /tmp/SBo/ettercap-NG-0.7.3/missing --run makeinfo'
MINGW_FALSE=''
MINGW_TRUE='#'
MISSING_BASENAME_FALSE=''
MISSING_BASENAME_TRUE=''
MISSING_GETOPT_LONG_FALSE=''
MISSING_GETOPT_LONG_TRUE=''
MISSING_INET_ATON_FALSE=''
MISSING_INET_ATON_TRUE=''
MISSING_MEMCMP_FALSE=''
MISSING_MEMCMP_TRUE=''
MISSING_MEMMEM_FALSE=''
MISSING_MEMMEM_TRUE=''
MISSING_SCANDIR_FALSE=''
MISSING_SCANDIR_TRUE=''
MISSING_STRCASESTR_FALSE=''
MISSING_STRCASESTR_TRUE=''
MISSING_STRLCAT_FALSE=''
MISSING_STRLCAT_TRUE=''
MISSING_STRLCPY_FALSE=''
MISSING_STRLCPY_TRUE=''
MISSING_STRSEP_FALSE=''
MISSING_STRSEP_TRUE=''
NCURSES_FALSE=''
NCURSES_TRUE=''
NCURSINC=''
NCURSLIB=''
OBJDUMP=''
OBJEXT=''
OPENSSL_FALSE=''
OPENSSL_TRUE=''
PACKAGE='ettercap'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
PCAPINC=''
PCAPLIB=''
PCREINC=''
PCRELIB=''
PKG_CONFIG=''
PLUGINS_FALSE=''
PLUGINS_TRUE=''
PL_CFLAGS=''
PL_LDFLAGS=''
RANLIB=''
SB=''
SET_MAKE=''
SFU_FALSE=''
SFU_TRUE='#'
SHELL='/bin/sh'
SOLARIS_FALSE=''
SOLARIS_TRUE='#'
SSLINC=''
SSLLIB=''
STRIP=''
VERSION='NG-0.7.3'
YACC=''
ac_ct_AR=''
ac_ct_AS=''
ac_ct_CC='gcc'
ac_ct_CXX=''
ac_ct_DLLTOOL=''
ac_ct_F77=''
ac_ct_OBJDUMP=''
ac_ct_RANLIB=''
ac_ct_STRIP=''
ac_pt_PKG_CONFIG=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include=''
am__leading_dot='.'
am__quote=''
bindir='${exec_prefix}/bin'
build='i486-slackware-linux-gnu'
build_alias='i486-slackware-linux'
build_cpu='i486'
build_os='linux-gnu'
build_vendor='slackware'
datadir='${prefix}/share'
exec_prefix='/usr'
host='i486-slackware-linux-gnu'
host_alias=''
host_cpu='i486'
host_os='linux-gnu'
host_vendor='slackware'
includedir='${prefix}/include'
infodir='${prefix}/info'
install_sh='/tmp/SBo/ettercap-NG-0.7.3/install-sh'
libdir='/usr/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='/var'
mandir='${prefix}/man'
mkdir_p='mkdir -p -- .'
oldincludedir='/usr/include'
prefix='/usr'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define INSTALL_BINDIR "/usr/bin"
#define INSTALL_DATADIR "/usr/share"
#define INSTALL_EXECPREFIX "/usr"
#define INSTALL_LIBDIR "/usr/lib"
#define INSTALL_PREFIX "/usr"
#define INSTALL_SYSCONFDIR "/etc"
#define OS_LINUX 1
#define PACKAGE "ettercap"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define VERSION "NG-0.7.3"

configure: exit 77


Hope this is the right way to post this log as it looks too long.




greets,
trem0rs
 
Old 04-13-2017, 01:46 PM   #2
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 3,954

Rep: Reputation: 685Reputation: 685Reputation: 685Reputation: 685Reputation: 685Reputation: 685
Code:
userx@slackwhere⚡~ $gcc -v
did you run that on the command line to make sure you even have gcc installed?

if you did anything other than a full install of Slack you may have inadvertently had it NOT install gcc.

Last edited by BW-userx; 04-13-2017 at 01:47 PM.
 
Old 04-13-2017, 01:56 PM   #3
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 3,885

Rep: Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902Reputation: 1902
Looks like you either have a partial installation or a broken installation. Let's try and get some more information...

What Slackware version are you running (based on your kernel, I'm thinking 14.1 and your ARCH seems to indicate you installed the 32bit version)? Did you do a full or partial installation? If it was partial, do you remember what you left out?

stdio.h that is referenced in those files is likely the one contained in the glibc package.

Quote:
Originally Posted by BW-userx View Post
Code:
userx@slackwhere⚡~ $gcc -v
did you run that on the command line to make sure you even have gcc installed?

if you did anything other than a full install of Slack you may have inadvertently had it NOT install gcc.
The ./configure script already ran gcc, so it is installed...

Quote:
configure:2803: gcc --version </dev/null >&5
gcc (GCC) 4.8.2
Copyright (C) 2013 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
 
Old 04-13-2017, 02:08 PM   #4
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,347

Rep: Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725
This can also happen if you have a multilib setup and you've someone messed it up, IIRC.

But from your log:

Code:
configure:2842: gcc -O2 -march=i486 -mtune=i686   conftest.c  >&5
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find crt1.o: No such file or directory
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find crti.o: No such file or directory
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find -lc
/usr/lib/gcc/i486-slackware-linux/4.8.2/../../../../i486-slackware-linux/bin/ld: cannot find crtn.o: No such file or directory
I'm going to go with the others in diagnosing it as an incomplete installation.

Last edited by dugan; 04-13-2017 at 02:10 PM.
 
1 members found this post helpful.
Old 04-13-2017, 05:14 PM   #5
trem0rs
LQ Newbie
 
Registered: Apr 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
I have this slackware installation since 2013 and as I said in the first post I used gcc many times with no problem, I don't think it is a partial-install cause when I installed it I had php, python and perl and except for some games and desktop environments I installed nearly everything.

But here is what I get when I type; gcc -v

Code:
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.8.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.8.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.8.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,go,java,lto,objc --enable-threads=posix --enable-checking=release --enable-objc-gc --with-system-zlib --with-python-dir=/lib/python2.7/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --enable-java-home --with-java-home=/usr/lib/jvm/jre --with-jvm-root-dir=/usr/lib/jvm --with-jvm-jar-dir=/usr/lib/jvm/jvm-exports --with-arch-directory=i386 --with-antlr-jar=/root/slackware-current/source/d/gcc/antlr-runtime-3.4.jar --enable-java-awt=gtk --disable-gtktest --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.8.2 (GCC)
Thanks for the answer,
trem0rs

Last edited by trem0rs; 04-13-2017 at 05:16 PM.
 
Old 04-13-2017, 05:23 PM   #6
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,347

Rep: Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725
Is this a 32-bit Slackware installation?

Does stdio.h actually exist somewhere in /usr/include? I'll check the exact path later tonight for you.

Is it at all possible that CFLAGS and/or might have been set incorrectly somehow? (check that)

Can you give us a better answer than "now" as to when your issues started?

Have you tried rebooting? (sorry to have to mention this)

Last edited by dugan; 04-13-2017 at 05:34 PM.
 
1 members found this post helpful.
Old 04-13-2017, 05:29 PM   #7
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,194

Rep: Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171Reputation: 3171
It seems that you are running Slackware 14.1, 32-bit.

Try fetching the glibc packages from slackware-14.1/patches/packages/ and installing/reinstalling them with this:

upgradepkg --reinstall --install-new glibc*.txz
 
Old 04-13-2017, 05:42 PM   #8
trem0rs
LQ Newbie
 
Registered: Apr 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by volkerdi View Post
It seems that you are running Slackware 14.1, 32-bit.

Try fetching the glibc packages from slackware-14.1/patches/packages/ and installing/reinstalling them with this:

upgradepkg --reinstall --install-new glibc*.txz
Thanks a lot man!!

The problem seems to be I didn't have glibc installed:
Code:
:~# upgradepkg --reinstall --install-new glibc*.txz
Cannot install glibc*.txz:  file not found
So I got to run;
slackpkg install glibc

I installed it and now I can finally compile!



Thank you,
trem0rs
 
Old 04-13-2017, 06:39 PM   #9
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,347

Rep: Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725
I'm kinda curious as to how your installation lost its glibc package. :P
 
Old 04-13-2017, 07:59 PM   #10
montagdude
Member
 
Registered: Apr 2016
Posts: 518

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Quote:
Originally Posted by trem0rs View Post
Thanks a lot man!!

The problem seems to be I didn't have glibc installed:
Code:
:~# upgradepkg --reinstall --install-new glibc*.txz
Cannot install glibc*.txz:  file not found
So I got to run;
slackpkg install glibc

I installed it and now I can finally compile!



Thank you,
trem0rs
Just so you know, the "file not found" error doesn't that glibc wasn't installed. It just means that the glibc*.txz packages you downloaded weren't in the working directory where you ran that command. However, the fact `slackpkg install glibc` worked does mean it wasn't installed.

Last edited by montagdude; 04-13-2017 at 08:00 PM.
 
Old 04-14-2017, 02:38 PM   #11
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 998

Rep: Reputation: 159Reputation: 159
did you convert this into an elf file by running link on it ?
the kernel in slack doesn't run a out binary files
so every thing coming out of gcc needs to be linked even the hello world program
 
Old 04-14-2017, 05:19 PM   #12
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,347

Rep: Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725
Quote:
Originally Posted by rob.rice View Post
the kernel in slack doesn't run a out binary files
I don't know what you're talking about.

Code:
bash-4.4$ vim helloworld.c
bash-4.4$ gcc helloworld.c 
bash-4.4$ ./a.out 
Hello world
That's with a stock -current kernel. I've always been able to run a.out files in previous versions too.

Last edited by dugan; 04-14-2017 at 11:17 PM.
 
1 members found this post helpful.
Old 04-16-2017, 06:20 PM   #13
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 998

Rep: Reputation: 159Reputation: 159
in the linux kernel configuration under executable binary formats aout is not enabled
so you have 2 options
1 link the a.out file
2 have the kernel link it at run time by enabling the aout executable binary format as a builtin in the kernel configuration then rebuilding the kernel and installing it

https://en.wikipedia.org/wiki/Execut...inkable_Format
https://en.wikipedia.org/wiki/A.out

I asways go with option 2

Last edited by rob.rice; 04-16-2017 at 06:25 PM.
 
Old 04-16-2017, 06:49 PM   #14
dugan
LQ Guru
 
Registered: Nov 2003
Location: Canada
Distribution: Slackware
Posts: 7,347

Rep: Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725Reputation: 2725
Hmm... interesting.

You are correct that support for a.out binaries are not enabled in Slackware's kernel. I checked.

Running "gcc" with no flags seems to be all that's needed to create linked, runnable ELF file. I checked that too:

Code:
➜  helloworld file a.out 
a.out: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, not stripped, with debug_info
That's the "a.out" file created in my last post.

Last edited by dugan; 04-16-2017 at 06:51 PM.
 
Old 04-17-2017, 03:20 AM   #15
rob.rice
Member
 
Registered: Apr 2004
Distribution: slack what ever
Posts: 998

Rep: Reputation: 159Reputation: 159
try this "gcc -o hello hello.c"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GCC First Pass Error: C Compiler cannot create executables firephyz Linux From Scratch 4 01-09-2017 09:37 AM
GCC -4.0.3 isn't being compiled compiler cannot create executables. fadelhomsi Linux From Scratch 2 10-15-2007 01:47 AM
gcc cannot create executables?! nectron101 Linux - Software 4 04-23-2006 02:24 AM
gcc gives error C compiler cannot create executables ADD Linux - Newbie 6 01-03-2006 05:43 AM
./configure fails because gcc can't create executables? anachron Linux - Newbie 3 03-01-2005 11:07 PM


All times are GMT -5. The time now is 08:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration