LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-19-2017, 06:20 AM   #1
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 464
Blog Entries: 2

Rep: Reputation: 151Reputation: 151
Garbled output with rxvt, font related?


Hi, i've been trying to make rxvt look nicer to use through ~/.Xresources

I'm using a font name generated by the xfontsel program
Code:
*.font: -misc-tamsyn-medium-r-normal-*-15-*-*-*-*-*-*-*
However, some commands; notably pstree, will spit out garbage instead of the ASCII styled lines (see the attached image).

I've also tried setting this to 0/1
Code:
Rxvt.utf8: 1
No success however. I'm using en_US / en_GB as my system locales if that is of any use. And the Tamsyn font works fine in other terminal emulators (xterm, konsole, xfce4-terminal, mate-terminal etc). Just seems to be rxvt doing this?

How can i fix this?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2017-03-19_11-11-34.png
Views:	55
Size:	28.4 KB
ID:	24548  
 
Old 03-19-2017, 06:34 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2 on Lenovo Thinkpad W520
Posts: 7,565

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
Not a direct answer but... Why use a software released on 26 March 2003 (nearly 14 years ago)?

Use xterm.
Attached Thumbnails
Click image for larger version

Name:	xterm.png
Views:	32
Size:	23.3 KB
ID:	24549  

Last edited by Didier Spaier; 03-19-2017 at 06:39 AM.
 
Old 03-19-2017, 07:19 AM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,574

Rep: Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490
You can try running rxvt in a non-UTF8 locale to get tree, pstree to look right.
Code:
LANG=en_GB rxvt
Since Slackware made UTF-8 the default to support extended character sets, rxvt looks antiquated. I updated to urxvt from rxvt for UTF-8 support. One nice feature of urxvt is the ability to copy columns from output on a display.
 
Old 03-19-2017, 11:57 AM   #4
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 164

Rep: Reputation: 111Reputation: 111
I suggest you to use rxvt-unicode.
 
Old 03-20-2017, 12:21 AM   #5
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 464
Blog Entries: 2

Original Poster
Rep: Reputation: 151Reputation: 151
Quote:
Originally Posted by Didier Spaier View Post
Not a direct answer but... Why use a software released on 26 March 2003 (nearly 14 years ago)?

Use xterm.
Good point, but it's included in the default Slackware packages. No other reason than that really. Maybe it should be switched out for urxvt as a standard package?

Quote:
Originally Posted by Thom1b View Post
I suggest you to use rxvt-unicode.
Quote:
Originally Posted by allend View Post
You can try running rxvt in a non-UTF8 locale to get tree, pstree to look right.
Code:
LANG=en_GB rxvt
Since Slackware made UTF-8 the default to support extended character sets, rxvt looks antiquated. I updated to urxvt from rxvt for UTF-8 support. One nice feature of urxvt is the ability to copy columns from output on a display.
That's a woking solution! Thanks. I had forgotten Slackware switched to UTF-8 as default, and i just realised the standard rxvt doesn't support unicode... However i did try building rxvt-unicode a few times a while back and always get a build error about libharfbuzz?


Code:
gcc  -o rxvt rxvt.o background.o command.o rxvtfont.o init.o main.o misc.o screen.o scrollbar.o scrollbar-next.o scrollbar-rxvt.o scrollbar-xterm.o scrollbar-plain.o xdefaults.o encoding.o rxvttoolkit.o rxvtutil.o keyboard.o rxvtimg.o ev_cpp.o fdpass_wrapper.o ptytty_wrapper.o rxvtperl.o -lsupc++ -lm -lfontconfig -lfreetype -lXft -lXrender -lX11 -lXmu -lXt -lX11  -lX11  -lgdk_pixbuf-2.0 -lgobject-2.0 -lglib-2.0 -lstartup-notification-1 -Wl,-E -Wl,-rpath,/usr/lib64/perl5/CORE  -fstack-protector-strong -L/usr/local/lib  -L/usr/lib64/perl5/CORE -lperl -lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
/usr/lib64/gcc/x86_64-slackware-linux/5.4.0/../../../../x86_64-slackware-linux/bin/ld: /usr/local/lib/libfreetype.a(autofit.c.o): undefined reference to symbol 'hb_font_destroy'
/usr/lib64/libharfbuzz.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:67: rxvt] Error 1
make[1]: Leaving directory '/tmp/SBo/rxvt-unicode-9.22/src'
make: *** [Makefile:37: all] Error 1
However it seems to be installed...
Code:
[ Status           ] [ Repository               ] [ Package                                  ]
   installed               multilib                     harfbuzz-compat32-1.4.4-x86_64-1compat32  
   installed               slackware64                  harfbuzz-1.4.4-x86_64-1
I guess the best option is to used rxvt-unicode, but how can i get this to compile on -current?
 
Old 03-20-2017, 02:04 AM   #6
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 164

Rep: Reputation: 111Reputation: 111
Quote:
Originally Posted by coralfang View Post
That's a woking solution! Thanks. I had forgotten Slackware switched to UTF-8 as default, and i just realised the standard rxvt doesn't support unicode... However i did try building rxvt-unicode a few times a while back and always get a build error about libharfbuzz?


Code:
gcc  -o rxvt rxvt.o background.o command.o rxvtfont.o init.o main.o misc.o screen.o scrollbar.o scrollbar-next.o scrollbar-rxvt.o scrollbar-xterm.o scrollbar-plain.o xdefaults.o encoding.o rxvttoolkit.o rxvtutil.o keyboard.o rxvtimg.o ev_cpp.o fdpass_wrapper.o ptytty_wrapper.o rxvtperl.o -lsupc++ -lm -lfontconfig -lfreetype -lXft -lXrender -lX11 -lXmu -lXt -lX11  -lX11  -lgdk_pixbuf-2.0 -lgobject-2.0 -lglib-2.0 -lstartup-notification-1 -Wl,-E -Wl,-rpath,/usr/lib64/perl5/CORE  -fstack-protector-strong -L/usr/local/lib  -L/usr/lib64/perl5/CORE -lperl -lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
/usr/lib64/gcc/x86_64-slackware-linux/5.4.0/../../../../x86_64-slackware-linux/bin/ld: /usr/local/lib/libfreetype.a(autofit.c.o): undefined reference to symbol 'hb_font_destroy'
/usr/lib64/libharfbuzz.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:67: rxvt] Error 1
make[1]: Leaving directory '/tmp/SBo/rxvt-unicode-9.22/src'
make: *** [Makefile:37: all] Error 1
However it seems to be installed...
Code:
[ Status           ] [ Repository               ] [ Package                                  ]
   installed               multilib                     harfbuzz-compat32-1.4.4-x86_64-1compat32  
   installed               slackware64                  harfbuzz-1.4.4-x86_64-1
I guess the best option is to used rxvt-unicode, but how can i get this to compile on -current?
I can't test on current because I don't use it, but it works fine on 14.2 (harfbuzz-1.2.7-x86_64-1)
Maybe you can try to disable pixbuf "--disable-pixbuf" in the SlackBuild.
 
Old 03-20-2017, 02:12 AM   #7
Petri Kaukasoina
Member
 
Registered: Mar 2007
Posts: 258

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by coralfang View Post
Code:
/usr/lib64/gcc/x86_64-slackware-linux/5.4.0/../../../../x86_64-slackware-linux/bin/ld: /usr/local/lib/libfreetype.a(autofit.c.o): undefined reference to symbol 'hb_font_destroy'
You have installed a broken freetype in /usr/local ?
 
Old 03-20-2017, 02:25 AM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,574

Rep: Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490Reputation: 1490
I had no problems using the SlackBuild that Thom1b linked.
Some tips on using urxvt and getting the Home/End keys to work:
Edit /etc/inputrc as per http://www.linuxquestions.org/questi...ml#post5626083 Remember to logout and login for the changes to take effect.
I have these added to ~.Xresources
Code:
!  Copied from 'man 7 uxrvt'. Use with -name URxvt
!  Also need entries in /etc/inputrc (and logout and login to activate)
! Map Home key to line start for urxvt
URxvt.keysym.Home:          \033[7~
! Map End key to line end for urxvt
URxvt.keysym.End:           \033[8~
! Set the default font for urxvt
URxvt.font: -xos4-terminus-medium-*-*-*-16-*-*-*-*-*-*-*
! Set the default bold font for urxvt
URxvt.boldFont: -xos4-terminus-bold-*-*-*-16-*-*-*-*-*-*-*
! Set the default italic font for urxvt
URxvt.italicFont: -misc-dejavu sans mono-medium-o-*-*-17-*-*-*-*-*-*-*
! Set the default bold italic font for urxvt
URxvt.boldItalicFont: -misc-dejavu sans mono-bold-o-*-*-17-*-*-*-*-*-*-*
! Start tabbed terminals in uxrvt
! URxvt.perl-ext-common: default,tabbed

Last edited by allend; 03-20-2017 at 06:39 AM.
 
Old 03-20-2017, 02:29 PM   #9
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 464
Blog Entries: 2

Original Poster
Rep: Reputation: 151Reputation: 151
Quote:
Originally Posted by Petri Kaukasoina View Post
You have installed a broken freetype in /usr/local ?
Not that i'm aware of but looking at the error i posted that seems to be the case. I must have ran a make install on something a while ago which shipped freetype2 sources along with it.

I just cleaned up /usr/local/lib/ and /usr/local/include/ removing all the freetype2 folders and urxvt has now compiled!

Sorry for being a pain, i should have noticed that the first time around. But problem solved. Thanks for all the help and suggestions!
 
  


Reply

Tags
character, font, rxvt, xresources


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
font garbled in kde applications in karmic zlya Linux - Desktop 5 03-03-2010 03:57 PM
Fixing garbled screen font smeezekitty General 1 01-18-2010 11:19 PM
rxvt & aterm: copy/paste and font jaakkop Linux - Software 1 03-26-2006 05:17 PM
How to increase font size in 'rxvt' (i.e. in fluxbox console)? kornerr Linux - General 2 02-19-2005 10:07 AM
change font size in RXVT on Mdk 9.2 UddUnderline Mandriva 1 12-16-2004 08:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration