LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-24-2008, 06:37 PM   #1
UNI
LQ Newbie
 
Registered: May 2008
Posts: 14

Rep: Reputation: 0
game server appears in master list for 10 minutes until system idles


Fitst here is my system info:
Server specs
I swapped out the video card listed and currently use Nvidia Geforce4 TI 4200 with AGP8x
My router is linksys wrt54gs v.5 with upgraded firmware.
Cable Modem is linksys befcmu10
It runs slackware 12.0
-----------
I have port forwarding set up and it allows my game server to show in the master list through the internet. My problem is when I let the server idle for about 10 minutes the screen goes blank. Once the screen has gone blank my server no longer appears in the master list. It does still appear on my lan. I'm pretty sure some power management/energy saver option is creating this problem. I can't seem to find any helpful links. Is there a configuration file I can edit to turn off this power management/energy saving option? Which power option would be creating this problem? example network card, hard drive, etc.
 
Old 05-25-2008, 12:37 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,476

Rep: Reputation: 532Reputation: 532Reputation: 532Reputation: 532Reputation: 532Reputation: 532
Console screen blanking and display power management are set in Slackware in /etc/rc.d/rc.M:

/bin/setterm -blank 15 -powersave powerdown -powerdown 60

You can modify that command within the same script or add a similar but overriding command in /etc/rc.d/rc.local, which is where user modifications to the system startup usually are stored. The setterm command has a man page to explain the options you want.

If the screen blanking and display power management are occurring while in X, then the respective options are determined by the desktop environment. KDE uses its own mechanism and ignores /etc/X11/xorg.conf. Look in the Control Center under Peripherals / Display / Power Control and Appearance & Themes / Screen Saver.

Xfce and basic window managers use xscreensaver for screen savers but use /etc/X11/xorg.conf for display power management. In a default xorg.conf, look in the Section "ServerFlags". Look for the options BlankTime, StandbyTime, SuspendTime, and OffTime.

I hope this helps.
 
Old 05-25-2008, 01:42 PM   #3
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,244

Rep: Reputation: 621Reputation: 621Reputation: 621Reputation: 621Reputation: 621Reputation: 621
Quote:
Originally Posted by Woodsman
KDE uses its own mechanism and ignores /etc/X11/xorg.conf. Look in the Control Center under Peripherals / Display / Power Control and Appearance & Themes / Screen Saver.
Although KDE does have its own settings, the xorg.conf is not ignored as far as I have experienced -- the screen will still blank without the ability to control it in KDE (unless you set the blanking time to LESS than the time specified in xorg.conf). I added the following to my xorg.conf to avoid the issue and restore control exclusively to KDE's tools:
Code:
Section "ServerFlags"
    Option         "blank time" "0"
    Option         "standby time" "0"
    Option         "suspend time" "0"
    Option         "off time" "0"
EndSection
You could probably also just use 'Option "DPMS" "off"' (replacing 'Option "DPMS"' in your xorg.conf if it exists) to accomplish the same.

Probably not directly related to the OP's question, but enough to mention.
 
Old 05-29-2008, 03:58 PM   #4
UNI
LQ Newbie
 
Registered: May 2008
Posts: 14

Original Poster
Rep: Reputation: 0
...

Thanks to those who replied.
I went ahead and tried the suggestions above. Only to find that my problem had nothing to do with power management or linux in general.
This turned out to be a port forwarding problem with my router. All is well now

---------off topic
T3Slider your name sounds familiar. Are affiliated with AOWC or some other gaming community?
 
Old 05-29-2008, 05:32 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,244

Rep: Reputation: 621Reputation: 621Reputation: 621Reputation: 621Reputation: 621Reputation: 621
Quote:
Originally Posted by UNI
T3Slider your name sounds familiar. Are affiliated with AOWC or some other gaming community?
I'm afraid I don't game much. I used to be involved in the Palm community (1src) and the Zaurus community (OESF), if those ring a bell. Otherwise, it's a coincidence.
 
  


Reply

Tags
gameserver, idle, powermanagement


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
printer appears in smbtree list but yast won't install it mangpp Linux - Networking 0 05-04-2006 02:02 AM
game server system admin wanted. Baghdad Linux - General 1 02-20-2006 05:45 PM
Automatically start a game server when system boots Kahless Linux - Software 6 08-01-2004 01:23 AM
game not receving game list from master server Rnastyracer Linux - Games 2 04-02-2004 10:20 PM


All times are GMT -5. The time now is 09:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration