Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 10-19-2013, 10:50 PM   #1
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 196

Rep: Reputation: 40
Game can't find 32bit OpenGL drivers?

I have a game that used to run in Slackware64 with MultiLib, the game is 32bit and is called Little Inferno.

Now it does not. I believe the issue is when the game runs, it can not find the correct 32 bit OpenGL drivers. When I try to run it from command line, I get the following error:

XIO:  fatal IO error 14 (Bad address) on X server ":0"
      after 1760 requests (1760 known processed) with 5 events remaining.
AL lib: ALc.c:1879: exit(): closing 1 Device
AL lib: ALc.c:1808: alcCloseDevice(): destroying 1 Context(s)
I had solved this before with a declaration before running the game, but it's been a while since I have done it I can't remember.

It's something along the lines of

XXX_XXXXX_XXXX=/usr/lib/ littleinferno
I had found it somewhere, but for the life of me I can't remember where I found that solution or what terms I used to search for it...or what the XXX_XXXXX_XXXX was...

Other 32 bit programs(Skype for example), work just fine.

Any ideas?
Old 10-19-2013, 11:07 PM   #2
Registered: Aug 2012
Posts: 473

Rep: Reputation: Disabled
I think LD_PRELOAD is what you want.

Old 11-27-2013, 08:05 PM   #3
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 196

Original Poster
Rep: Reputation: 40
Originally Posted by mancha View Post
I think LD_PRELOAD is what you want.

LD_PRELOAD did not work...I finally figured it out...I needed...

Now everything runs, including Steam.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Building libav with 64 bit NVidia drivers 32bit compatibility drivers Geist Slackware 28 10-02-2013 03:59 AM
Running 32bit openGL graphics in Debian amd64 chiendarret Linux - Software 0 10-06-2012 08:46 AM
[SOLVED] 32bit game on 64bit Fedora 16 fakie_flip Fedora 6 01-02-2012 09:39 PM
Bad opengl performance with two or more OpenGL windows on nvidia drivers (GF 7600 GS) psokol Linux - Software 0 02-21-2009 10:40 AM
lib error when trying to run 32bit game on AMD64 Zaskar Debian 1 04-03-2008 06:27 PM

All times are GMT -5. The time now is 06:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration