LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-10-2006, 06:30 AM   #1
Mercurius
Member
 
Registered: Jul 2005
Distribution: Slackware 11, Solaris 10
Posts: 143

Rep: Reputation: 15
fstab problem


I have 2 dos partitions. One /dos/c who is NTFS and the other /dos/d who is FAT32. A normal user cannot access the NTFS partitions but only the FAT32. How do I grant acces with read-write-execute on all partitions for a normal user?

Here is my fstab file:

/dev/hda3 swap swap defaults 0 0
/dev/hda2 / ext3 defaults 1 1
/dev/hda1 /dos/c ntfs ro 1 0
/dev/hdb1 /dos/d vfat defaults 1 0
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/hdd /mnt/dvdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
none /sys sysfs defaults 0 0
 
Old 10-10-2006, 06:43 AM   #2
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware and Porteus
Posts: 648

Rep: Reputation: 45
Cool It's in the man

Did You read the man-page for mount and fstab?

It says that by default the exec option is set,
however an ordinary user should not be able to write or execute files on arbitrary filesystems (sholud he?).
NTFS is AFAIK not write-capable under linux except for _some_ cases and then only on NT4 formatted paritions.
I would be glad if it would, and am still waiting the full rw support.
to wiev a manpage you jut type:
man mount
and exit with [q] ;-)
I hope it whas usefull?
 
Old 10-10-2006, 06:54 AM   #3
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
That's right, you can't write to ntfs from linux. However you should be able to read files on the ntfs partition. Change the ro to umask=0
Code:
su -c "sed -i 's: ro: umask=0:' /etc/fstab"
 
Old 10-10-2006, 08:47 AM   #4
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by Andrew Benton
That's right, you can't write to ntfs from linux. However you should be able to read files on the ntfs partition. Change the ro to umask=0
Code:
su -c "sed -i 's: ro: umask=0:' /etc/fstab"
Sorry to disagree I write to NTFS from linux every time I use my laptop, the relevant ptograms are ntfs-3g and the fuse kernel module.

I AM NOT AN EXPERT. Read the documentation first.

samac
 
Old 10-10-2006, 10:19 AM   #5
TNWestTex
Member
 
Registered: May 2006
Location: Tennessee
Distribution: current, rawhide
Posts: 87

Rep: Reputation: 16
With the technology developed with wine and fuse another way to get read write access to ntfs partitions is with the latest version of Captive. While previous versions used Windows system files the new version does not. Google the following two packages, download, expand the tarball and run the install script.

captive-static-1.1.7.tar.gz
Judy-1.0.3.tar.gz
 
Old 10-10-2006, 10:25 AM   #6
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
http://www.linux-ntfs.org/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM
fstab problem Mirari Slackware 6 12-21-2005 03:26 PM
\etc\fstab problem franklampard Linux - Newbie 5 10-03-2005 04:40 PM
/etc/fstab problem mokojin Slackware 8 08-31-2004 12:34 PM
Problem with fstab rgriffin Fedora 3 03-25-2004 06:23 PM


All times are GMT -5. The time now is 11:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration