LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-29-2011, 12:01 AM   #1
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Rep: Reputation: 33
frozen screen after running xlock


I'm -current as of this morning, the 28th. I upgraded from 13.1.

I'm using Xfce4, I've been using a button on my lower panel to launch xlock. Been working fine the last month. Upgraded to 13.37rc3.pi this morning.

Used my computer today for several hours today (after the upgrade). No problems. Hit my xlock launcher a couple hours ago, animation started. Turned monitor off. Then a few minutes ago, when I turned my monitor back on, black/blank screen, no password prompt. Killed xlock (had to use -s 9); no change. Saw xscreensaver was running, killed that too. No effect on my locked screen.

I then killed kdm and logged back in to an Xfce session. Back to normal now. I hit my xlock button. Got an animation up, typed in my password, and got back to my desktop no problem.

I'm not really sure what information to post to troubleshoot, but here's something for starters:
Code:
root@pigeon:~# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
 
Old 03-30-2011, 02:42 AM   #2
san
Member
 
Registered: Jan 2006
Location: vienna, .at
Distribution: Slackware64 13.37
Posts: 50

Rep: Reputation: 12
Quote:
Originally Posted by Andy Alkaline View Post
Code:
root@pigeon:~# lspci
...
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
which driver are you using? i had similar troubles with the fglrx-driver on 13.1; i couldn't log in anymore after locking + 1 failed attempt (but killing -9 xlock helped).

d.s.
 
Old 04-09-2011, 07:26 PM   #3
Andy Alkaline
Member
 
Registered: Jun 2004
Location: Minnesota, USA
Distribution: Slackware32-stable, Debian-wheezy-amd64, LFS 7.1
Posts: 355

Original Poster
Rep: Reputation: 33
The driver I'm using is radeon.

I'm sorry for the delayed reply.
 
  


Reply

Tags
screensaver, video, xlock


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
frozen fuzzy screen after installation rabbit2345 Suse/Novell 6 11-09-2007 07:20 PM
Help ! Frozen Grub Screen ! NVPKrypton Linux - General 2 05-31-2004 05:16 PM
Xlock / Xlock more with enterprise authentication yasir15 Linux - Software 0 04-20-2004 12:47 PM
My screen is frozen! rebayona Linux - General 9 06-19-2002 04:19 AM
frozen screen after kernel upgrade. jonathon Linux - Newbie 5 01-21-2002 04:30 PM


All times are GMT -5. The time now is 08:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration