LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   frozen screen after running xlock (http://www.linuxquestions.org/questions/slackware-14/frozen-screen-after-running-xlock-871603/)

Andy Alkaline 03-28-2011 11:01 PM

frozen screen after running xlock
 
I'm -current as of this morning, the 28th. I upgraded from 13.1.

I'm using Xfce4, I've been using a button on my lower panel to launch xlock. Been working fine the last month. Upgraded to 13.37rc3.pi this morning.

Used my computer today for several hours today (after the upgrade). No problems. Hit my xlock launcher a couple hours ago, animation started. Turned monitor off. Then a few minutes ago, when I turned my monitor back on, black/blank screen, no password prompt. Killed xlock (had to use -s 9); no change. Saw xscreensaver was running, killed that too. No effect on my locked screen.

I then killed kdm and logged back in to an Xfce session. Back to normal now. I hit my xlock button. Got an animation up, typed in my password, and got back to my desktop no problem.

I'm not really sure what information to post to troubleshoot, but here's something for starters:
Code:

root@pigeon:~# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]


san 03-30-2011 01:42 AM

Quote:

Originally Posted by Andy Alkaline (Post 4307042)
Code:

root@pigeon:~# lspci
...
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]


which driver are you using? i had similar troubles with the fglrx-driver on 13.1; i couldn't log in anymore after locking + 1 failed attempt (but killing -9 xlock helped).

d.s.

Andy Alkaline 04-09-2011 06:26 PM

The driver I'm using is radeon.

I'm sorry for the delayed reply.


All times are GMT -5. The time now is 10:10 AM.